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第 3 章 
Multisim 仿真软件 

 
 

概述 

Multisim 是一款用于电子电路计算机仿真设计与分析的软件。本章介绍了 Multisim 的

功能与基本使用方法，包括基本界面、基本操作、仿真电路的创建与分析、虚拟仪器仪表

的使用等。 

本章知识点： 

 Multisim 的菜单 
 Multisim 的基本操作方法 
 Multisim 的元器件库 
 Multisim 的虚拟仪器仪表库 
 Multisim 的分析功能 

3.1  Multisim 软件简介 

电子设计自动化（EDA，Electronic Design Automation）技术是 20 世纪 70 年代开始从

电子 CAD 技术基础上发展起来的，是指以计算机为工作平台，融合了应用电子技术、计

算机技术、信息处理及智能化技术的最新成果，进行电子产品的自动设计。利用 EDA 工

具，电子产品设计师可以从概念、算法、协议等开始设计电子系统，大量工作可以通过计

算机完成，并可以将电子产品从电路设计、性能分析到设计出 IC 版图或 PCB 版图的整个

过程在计算机上自动处理完成。 
EDA 技术借助计算机存储量大、运行速度快的特点，可对设计方案进行人工难以完成

的模拟评估、设计检验、设计优化和数据处理等工作。EDA 极大地推动了电子工业的发展，

目前 EDA 已经成为集成电路、印制电路板、电子整机系统设计的主要技术手段，是现代

电子工业不可缺少的一项重要技术。在众多的 EDA 仿真软件中，Multisim 软件因界面友好、

功能强大、易学易用而受到电气类设计开发人员和相关专业师生的青睐。 
Multisim 是美国国家仪器公司（NI，National Instruments）的一款能完成电路设计、电

路功能测试的虚拟仿真软件。Multisim 用软件的方法虚拟电子与电工元器件，虚拟电子与电

工仪器和仪表，实现了“软件即元器件”“软件即仪器”，可谓“装在 PC 中的电子实验室”。 
Multisim 的前身是由加拿大 IIT（Interactive Image Technologies）公司开发的 EWB电子
工业
出版
社版
权所
有 

   
   
 盗
版必
究



第 3 章 Multisim 仿真软件 

·53· 

（Electronics Workbench，虚拟电子工作台）。从诞生之初到目前，Multisim 发展了从 6.0 到

14.1 的不同版本，每次发布新版本时，都会增加一些创新功能以增强原型设计或电路教学

的方法。目前的最新版是 Multisim 14.1，在高校教学中使用最多的是 10.0 和 12.0 版本。各

版本之间的差异详见 NI 公司的网站，网页地址 http://www.ni.com/white-paper/5590/zhs/。 
Multisim 软件将直观的原理图搭建与强大的仿真功能结合起来，可帮助用户快速、轻

松、高效地设计和验证电路，其主要特点如下。 

1. 系统高度集成，界面直观，操作方便 

Multisim 将原理图的创建、电路的测试分析和结果的图表显示等全部集成到同一个电

路窗口中。整个操作界面就像一个实验工作台，有存放仿真元件的元件库，有存放虚拟测

试仪表的仪器库，有进行仿真分析的各种操作命令。虚拟测试仪表和某些仿真元件的外

形与实物非常接近，操作方法也基本相同。直观便捷的操作方式，使得 Multisim 软件易学

易用。 

2. 丰富易扩展的元器件库和虚拟仪器库 

Multisim 的元器件库提供数千种电路元器件供实验选用，同时也可以新建或扩充已有

的元器件库，而且建库所需的元器件参数可以从生产厂商的产品使用手册中查到，因此也

可以很方便地在工程设计中使用。 
Multisim 的虚拟测试仪器仪表种类齐全，有一般实验用的通用仪器，如万用表、函数

信号发生器、双踪示波器、直流电源；而且还有一般实验室少见的仪器，如波特图仪、字

信号发生器、逻辑分析仪、逻辑转换器、失真仪、频谱分析仪和网络分析仪等。 
从 9.0 版本开始，NI 将 Multisim 与虚拟仪器技术（LABVIEW）结合，可让用户设计

实现自定义的虚拟仪器，使得软件系统的功能更加丰富和强大。从 10.1 版本开始，NI 还

将 Multisim 与教学实验室虚拟仪器套件技术（NI ELVIS）结合，将虚拟仪器与实物测量平

台结合起来。该技术借助计算机软件和轻巧的插入式板卡结构，可实现 12 款最为常用的仪

器的功能，包括示波器、数字万用表、函数发生器和波特图分析仪等。这些功能是与实验

室真实仪器相仿的，因此，Multisim 可以当成便携的电子实验设备，便于使用者在实验室、

课堂甚至学生寝室开展内容丰富的电子技术实验。 

3. 电路分析手段完备 

Multisim 扩充了先前版本的电路测试功能，除了用常用的测试仪表对仿真电路进行测

试之外，还提供了电路的直流工作点分析、瞬态分析和稳态分析、时域和频域分析、器件

的线性和非线性分析、电路的噪声分析和失真分析、离散傅里叶分析、电路零极点分析、

交直流灵敏度分析等电路分析方法，以帮助设计人员分析电路的性能。 

4. 具有功能强大的仿真能力 

在电路窗口，我们可以利用 Multisim 设计、测试和演示各种电子电路，包括电工学、

模拟电路、数字电路、射频电路及微控制器和接口电路等。既可以分别对数字或模拟电路电子
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进行仿真，也可以将数字元件和模拟元件连接在一起进行数模混合仿真分析。从 Multisim 
9.0 版本开始，还可以对单片机、可编程逻辑器件电路进行仿真分析。 

Multisim 可以对被仿真的电路中的元器件设置各种故障，如开路、短路和不同程度的

漏电等，从而观察不同故障情况下的电路工作状况。在进行仿真的同时，软件还可以存储

测试点的所有数据，列出被仿真电路的所有元器件清单，以及存储测试仪器的工作状态、

显示波形和具体数据等。 

5. 提供了多种输入输出接口 

Multisim 还提供了与国内外流行的印刷电路板设计自动化软件 Altium Designer 
（Protel）及电路仿真软件 OrCAD（PSpice）之间的文件接口，例如可以输入由 PSpice 等

其他电路仿真软件所创建的 Spice网表文件，并自动生成相应的电路原理图。也可以把EWB
环境下创建的电路原理图文件输出给 Protel 等常见的 PCB 软件进行印刷电路板设计。也能

通过 Windows 的剪贴板把电路图送往文字处理系统中进行编辑排版，支持VHDL和 Verilog 
HDL 语言的电路仿真与设计。 

利用 NI Multisim 可以实现计算机仿真设计与虚拟实验，与传统的电子电路设计与实验

方法相比，具有如下特点：设计与实验可以同步进行，可以边设计边实验，修改调试方便；

设计和实验用的元器件及测试仪器仪表齐全，可以完成各种类型的电路设计与实验；可方

便地对电路参数进行测试和分析；可直接打印输出实验数据、测试参数、曲线和电路原理

图；实验中不消耗实际的元器件，实验所需元器件的种类和数量不受限制，实验成本低。

速度快、效率高；设计和实验成功的电路可以直接在产品中使用。 
本章以 Multisim 12.0 为例，介绍软件的使用方法。本书中所有的实验项目和课程设计

项目，都可结合 Multisim 软件仿真，实现电路的辅助分析和设计。 

3.2 Multisim 12.0 的基本界面 

Multisim 软件以图形界面为主，采用菜单、工具栏和热键相结合的方式，具有一般

Windows 应用软件的界面风格，用户可以根据自己的习惯和熟悉程度自如使用。不同的

Multisim 版本中，虚拟仪器和元器件的图形风格可能略有差异，但基本功能和操作方法都

是类似的。本节主要介绍 Multisim 的主窗口界面下的菜单栏和其中的各个菜单、常用快捷

工具栏、元器件库、仪器仪表库等内容。 

3.2.1 Multisim的主窗口界面 

启动 Multisim 12.0 的方法：单击 Windows 系统“开始”→“程序”→“ National 
Instruments” →“Circuit Design Suite 12.0”→“Multisim 12.0”选项。  

启动 Multisim 12.0 后，将出现如图 3.1 所示的界面。 
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标题栏 元器件栏 工具栏 菜单栏 启动/停止
按钮

暂停/继续
按钮

虚
拟
仪
器
仪
表
栏

设
计
工
具
箱

信息栏 电路工作区（电路工作窗口）  

图 3.1  Multisim 12.0 的主窗口 

Multisim 12.0 的主窗口如同一个实际的电子实验台。屏幕中央区域最大的窗口就是电

路工作区，在电路工作窗口上可将各种电子元器件和测试仪器仪表连接成实验电路。电路

工作窗口上方是菜单栏、工具栏和元器件栏，右边是虚拟仪器仪表栏。从菜单栏中可以选

择电路连接、实验所需的全部命令。工具栏中包含了菜单中一些常用的操作命令，并以按

钮的形式展示。元器件栏存放着各种电子元器件，虚拟仪器仪表栏存放着各种测试仪器仪

表。用鼠标操作可以很方便地从元器件和仪器库中，提取实验所需的各种元器件及仪器、

仪表到电路工作窗口并连接成实验电路。 
主窗口左边是设计工具箱窗口，在这里可以以资源管理器的模式显示所有打开的项目

和相关文件资源。单击电路工作窗口上方的“启动／停止”按钮或“暂停／继续”按钮可

以方便地控制仿真的进程。 
用户也可以通过 View（视图）菜单中的命令或用鼠标拖动未锁定状态下的工具栏，改

变主窗口的视图内容和排布形式，得到自定义的工作界面，以适应自己的操作习惯。 

3.2.2  Multisim的菜单栏 

Multisim 12.0 有 12 个主菜单选项，如图 3.2 所示，菜单中提供了本软件几乎所有的功

能命令。 

 

图 3.2  Multisim 12.0 的主菜单 电子
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1. File（文件）菜单 

File 菜单中包含了对文件和项目的基本操作以及打印等命令，各项功能如下： 
 
 New：建立新文件。 
 Open：打开文件。 
 Open samples：打开 Multisim 自带的示例电路。 
 Close：关闭当前文件。 
 Close all：关闭所有打开的文件。 
 Save：保存。 
 Save as：另存为。 
 Save all：将电路工作区内的文件全部存盘。 
 Snippets：包括 4 个子菜单，分别是 Save selection as snippet（将所选项保存为 snippet

格式）、Save active design as snippet（将当前设计保存为 snippet 格式）、Paste snippet
（粘贴 snippet 文件）、Open snippet file（打开 snippet 文件）。 

注：snippet 是一种特殊的.png 图片文件，其中包含 Multisim 设计电路（包括所有自电

路）的图片和所有元器件信息（包括符号、模型、脚注和电路连接网表）。图片仅

显示电路图，不显示电路具体信息。用户可以将用 snippet 格式保存的文件发布在

论坛上或者用 Email 传送，以便于在 Internet 上共享自己的设计。 

注意：如果用图片查看或者编辑软件（如 Paint）打开一个 Multisim snippet 的.png 文

件，则保存这个文件后，Multisim 版本和 snippet 信息会以标签（tab）形式显

示在图片顶部。若用图片编辑软件保存此类文件，会导致其中的 Multisim 特殊

数据被丢弃，且再次用 Multisim 打开这个文件时将报错。因此，不可用图片编

辑软件来保存 Multisim snippet 的.png 文件，或者在保存时改变文件名。 

 Projects and packing：项目与打包菜单，包括 8 个子菜单： 
 New project：新建项目； 
 Open project：打开项目； 
 Save project：保存当前项目； 
 Close project：关闭项目； 
 Pack project：打包当前项目； 
 Unpack project：解包当前项目； 
 Upgrade project：升级当前项目； 
 Version control：版本管理。 

 Print：打印电路图。 
 Print preview：打印预览。 
 Print options：打印选项，包括两个子菜单： 

 Print sheet setup：电路图纸打印设置。 
 Print instruments：打印工作区内的仪表。 电子
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 Recent designs：最近编辑过的设计文件。 
 Recent projects：最近编辑过的项目。 
 File information：显示当前文件信息（保存路径、创建和修改时间、应用程序版本

等）。 
 Exit：退出 Multisim。 

2. Edit（编辑）菜单 

Edit 命令提供了类似于图形编辑软件的基本编辑功能，用于对电路图进行编辑。 
 
 Undo：取消前一次操作。 
 Redo：恢复前一次被撤销的操作。 
 Cut：剪切所选择的元器件，放在剪贴板中。 
 Copy：将所选择的元器件复制到剪贴板中。 
 Paste：将剪贴板中的元器件粘贴到指定的位置。 
 Paste special：特殊粘贴命令，包括两个子菜单命令： 

 Paste as subcircuit：作为子电路粘贴； 
 Paste without renaming on-page connectors：粘贴时不重命名页面上的端口连接器。 

 Delete：删除所选择的元器件、导线或仪器仪表。 
 Delete multi-page：删除多页面。 
 Select all：选择电路中所有的元器件、导线和仪器仪表。 
 Merge selected busses：合并选中的总线。 
 Find：查找电路原理图中的元件。 
 Graphic annotation：图形注释。可对工作区的图形元素（Graphic Elements）进行格

式设置，包括线型、线条颜色、填充纹理等。其中图形元素可通过执行菜单命令

View→Toolbars→Graphic annotation，调用图形注释工具栏来添加。 
 Order：图形叠放顺序。有 2 个子菜单： 

 Bring to front：上移一层； 
 Send to back：下移一层。 

 Assign to layer：图层分配，用于将某个选中的对象分配到某个注释层。 
 Layer settings：图层设置，单击后会调出相应的对话框，列出当前可见的固定图层

（Layer），并可添加用户自定义图层。此功能亦可通过执行菜单命令 Options→Sheet 
properties 调出 Sheet Properties 对话框，在 Layer settings 标签项下完成。 

 Orientation：旋转方向选择。包括 4 种操作： 
 Flip horizontal：将所选择的元器件左右翻转； 
 Flip vertical：将所选择的元器件上下翻转； 
 Rotate 90°clockwise：将所选择的元器件顺时针旋转 90 度； 
 Rotate 90°counter clockwise：将所选择的元器件逆时针旋转 90 度。 

 Align：对齐。可将选中状态的对象对齐排布，包括 6 种对齐方式： 
 Align left：左对齐； 电子
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 Align right：右对齐； 
 Align centers vertically：垂直中心对齐； 
 Align bottom：底部对齐； 
 Aligns top：顶部对齐； 
 Align centers horizontally：水平中心对齐。 

 Title block position：工程图明细表位置。可选择原理图纸上的 4 个位置： 
 Bottom right：右下角； 
 Bottom left：左下角； 
 Top right：右上角； 
 Top left：左上角。 

 Edit symbol/title block：编辑选中的元器件符号，或者工程明细表。 
 Font：字体设置。 
 Comment：编辑评论/注释。 
 Forms/questions：格式/问题，用于显示编辑表格（Edit Form）对话框，可对设计相

关问题进行编辑。 
 Properties：属性编辑。单击后会显示当前选中的对象的属性对话框；如果没有对

象被选中，则打开 Sheet Properties 对话框。 

3. View（视图）菜单 

通过 View 菜单可以决定使用软件时的视图，对一些工具栏和窗口进行控制。 
 
 Full screen：全屏显示电路图工作区。 
 Parent sheet：显示（当前子电路的）上级电路图。 
 Zoom in：放大电路原理图。 
 Zoom out：缩小电路原理图。 
 Zoom area：放大选中的区域（用鼠标拖拽选择区域）。 
 Zoom to sheet：显示完整电路图纸。 
 Zoom to magnification：显示缩放对话框，按比例放大。 
 Zoom selection：放大选中的元器件。 
 Grid：显示或者隐藏工作区底纹栅格（打钩时表示显示）。 
 Border：显示或者隐藏图纸边界的框格。 
 Print page bounds：显示或者隐藏打印页边界。用虚线显示的页边界可帮助用户知

道打印后图纸上的元素会显示在哪张或者哪部分打印纸上。 
 Ruler bar：显示或者隐藏标尺栏。 
 Status bar：显示或者隐藏状态栏。 
 Design toolbox：显示或者隐藏设计工具箱。 
 Spreadsheet view：显示或者隐藏电子数据表扩展显示窗口。 
 SPICE netlist viewer：显示 SPICE 网表查看器。 电子
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 LabVIEW co-simulation terminals：显示 LabVIEW 联合仿真终端窗口栏（注：联合

仿真需安装相关软件和插件支持）。 
 Description box：打开电路描述窗口栏，可用于添加或者编辑电路注释和其他信息。 
 Toolbars：显示或者隐藏工具栏，其下有多个子选项，打钩的工具栏会在界面上

显示。 
 Show comment/probe：显示或者隐藏注释/标注。 
 Grapher：显示或者隐藏图形编辑器。 

4．Place（放置）菜单 

通过 Place 命令输入电路图所需的各种元素。 
 
 Component：放置元器件，单击后会显示元器件数据库浏览窗口，可选择需要的对

象放入电路图工作区。 
 Junction：放置节点。 
 Wire：放置导线。 
 Bus：放置总线。 
 Connectors：放置输入／输出端口连接器。子菜单中有 6 种类型的端口连接器，其

含义和使用方法详见 3.3.2 节。 
 New hierarchical block：新建层次模块，用于在层次结构中放置一个未添加任何元

器件的新的层次模块。 
 Hierarchical block from file：放置一个来自文件的层次模块。 
 Replace by hierarchical block：将选中的一组元素用一个层次模块替换。 
 New subcircuit：创建一个新的空白子电路。 
 Replace by subcircuit：将选中的一组元器件用一个包含这些元器件的子电路替换。 
 Multi-page：打开一个新的平面页面，用于在一个设计下设置多页电路图。 
 Bus vector connect：总线矢量连接。当一个多引脚器件（如 IC）与总线相连时，推

荐采用总线矢量连接。 
 Comment：注释，用于在工作区或者在元器件上添加一个注释标签。 
 Text：放置文字。 
 Grapher：放置图形。可选图形对象有： 

 Line：直线； 
 Multiline：组合直线； 
 Rectangle：矩形； 
 Ellipse：椭圆形； 
 Arc：弧线； 
 Polygon：多边形； 
 Picture：图片。 

 Title block：放置工程标题栏。 电子
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5. MCU（微控制器）菜单 

MCU 菜单提供在电路工作窗口内 MCU 的调试操作命令，可对电路与 MCU 进行联合

仿真，实现对嵌入式设备的软件开发，包括编写和调试程序代码等工作。 
 
 No MCU component found：没有创建 MCU 器件。 
 Debug view format：调试视图格式。 
 Line numbers：显示线路数目。 
 Pause：暂停。 
 Step into：单步执行，遇到子函数就进入并且继续单步执行。 
 Step over：单步执行，遇到子函数就越过，即把子函数整个作为一步。 
 Step out：与 Step into 配合使用。当单步执行到子函数内时，用 Step out 就可以执

行完子函数余下部分，并返回到上一层函数。 
 Run to cursor：使程序运行到当前鼠标光标所在行时暂停执行。 
 Toggle breakpoint：设置断点。 
 Remove all breakpoint：移除所有的断点。 

6. Simulate（仿真）菜单 

Simulate 菜单中包括各种电路仿真设置与操作命令。 
 
 Run：开始仿真。 
 Pause：暂停仿真。 
 Stop：停止仿真。 
 Instruments：选择虚拟仪器仪表。虚拟仪器仪表与仪器仪表工具栏上的对象相同，

使用详情参照 3.2.5 节和 3.4 节。其子菜单包括： 
 Multimeter：数字万用表； 
 Function generator：函数信号发生器； 
 Wattmeter：瓦特表/功率计； 
 Oscilloscope：双踪示波器； 
 Four channel oscilloscope：四通道示波器； 
 Bode plotter：波特图仪； 
 Frequency counter：频率计； 
 Word generator：字信号发生器； 
 Logic analyzer：逻辑分析仪； 
 Logic converter：逻辑转换仪； 
 IV analyzer：IV 分析仪（晶体管特性曲线测试仪）； 
 Distortion analyzer：失真度分析仪； 
 Spectrum analyzer：频谱分析仪； 
 Network analyzer：网络分析仪； 
 Agilent function generator：安捷伦函数信号发生器； 电子
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 Agilent multimeter：安捷伦万用表； 
 Agilent oscilloscope：安捷伦示波器； 
 LabVIEW instruments：LabVIEW 虚拟仪器； 
 NI ELVISmx instruments：NI ELVISmx 仪器； 
 Tektronix oscilloscope：泰克示波器； 
 Measurement probe：测量探针； 
 Preset measurement probe：预置的测量探针； 
 Current probe：（钳夹感应式）电流测量探针。 

 Interactive simulation settings...：交互式仿真设置。用于对基于瞬态分析的仪器仪表

（如示波器、频谱分析仪、逻辑分析仪）进行默认工作参数的设置。 
 Mixed-mode simulation settings...：混合模式仿真设置。当设计中包含数字器件时，

允许用户选择仿真的最佳精度或最优速度。 
 Analyses：选择仿真分析类型。Multisim 可实现多达 20 种仿真分析操作（具体分

析内容详见 3.3.3 节），包括： 
 DC operating point：直流工作点分析； 
 AC analysis：交流分析； 
 Single frequency AC analysis：单一频率交流分析； 
 Transient analysis：瞬态分析； 
 Fourier analysis：傅里叶分析； 
 Noise analysis：噪声分析； 
 Noise figure analysis：噪声系数分析； 
 Distortion analysis：失真分析； 
 DC sweep：直流扫描分析； 
 Sensitivity：灵敏度分析； 
 Parameter sweep：参数扫描分析； 
 Temperature sweep：温度扫描分析； 
 Pole zero：零-极点分析； 
 Transfer function：传递函数分析； 
 Worst case：最坏情况分析； 
 Monte Carlo：蒙特卡罗分析； 
 Trace width analysis：导线宽度分析； 
 Batched analysis：批处理分析； 
 User defined analysis：用户自定义分析； 
 Stop analysis：停止当前正在运行的仿真分析。 

 Postprocessor：启动后处理器。 
 Simulation error log/audit trail：仿真误差记录/查询索引。 
 XSPICE command line interface：XSPICE 命令行界面。 
 Load simulation setting：导入仿真设置。 电子
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 Save simulation setting：保存仿真设置。 
 NI ELVISmx instruments：NI ELVISmx 仪器。 
 Auto fault option：自动故障选择，可在设计的电路中随机选择元器件为其设置故障

进行仿真分析，故障数量和类型可由用户自行设定。 
 Dynamic probe properties：显示动态探针属性对话框。 
 Reverse probe direction：将一个已放置的探针极性反向。 
 Clear instrument data：清除仪器数据。 
 Use tolerances：使用容差。当此菜单项左侧显示√时，仿真中会使用元器件参数中

已设置的容差。 

7. Transfer（传输）菜单 

可以用 Transfer 菜单命令把 Multisim 的文件格式转换为其他 EDA 软件的文件格式。 
 
 Transfer to Ultiboard：将电路图传送给 Ultiboard 12.0 或者其他早期版本。 
 Forward annotate to Ultiboard：创建 Ultiboard 12.0 注释文件或者其他早期版本注释

文件。 
 Backward annotate from file：从文件中反向传输注释。将一个 Ultiboard 设计文件中

的修改（如删除某一元器件）用注释文件反向传送给 Multisim 设计文件。 
 Export to other PCB layout file：输出非 Ultiboard 格式的 PCB 设计图。 
 Export SPICE netlist：输出 SPICE 网表文件。 
 Highlight selection in Ultiboard：高亮显示被选中对象。当 Ultiboard 处于运行状态

时，在 Multisim 中被选中的元器件，会在 Ultiboard 中被高亮显示。 
 NI ELVISmx instruments：NI ELVISmx 仪器。 

8. Tools（工具）菜单 

Tools 菜单提供的命令主要用于元器件的编辑与管理。 
 
 Component wizard：元件编辑器。 
 Database：数据库。其下有 4 个子菜单： 

 Database manager：显示元件数据库管理窗口； 
 Save component to database：把当前选中元件（包括用户对其所做的修改）保存

到数据库中； 
 Merge database：将其他元件数据的内容合并到用户或者公司的元件数据库中； 
 Convert database：将一个现有的公司或者用户元件数据库的元件转换成

Multisim 格式。 
 Variant manager：变量管理器。 
 Set active variant：设置动态变量。 
 Circuit wizards：电路编辑器。其下有 4 个子菜单： 

 555 timer wizard：555 定时器编辑器； 电子
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 Filter wizard：滤波器编辑器； 
 Opamp wizard：运算放大器电路编辑器； 
 CE BJT amplifier wizard：共射极三极管放大电路编辑器。 

 NI ELVISmx instruments：NI ELVISmx 仪器。 
 SPICE netlist viewer：网表查看器。其下有 5 个子菜单： 

 Save SPICE netlist：将 SPICE 网表查看器中的内容另存为一个.cir 文件； 
 Select all：选中 SPICE 网表查看器中的所有文本内容； 
 Copy SPICE netlist：复制 SPICE 网表查看器中的内容； 
 Print SPICE netlist：打印 SPICE 网表查看器中的内容； 
 Regenerate SPICE netlist：更新当前设计的 SPICE 网表。 

 Rename/renumber components：元件重新命名/编号。 
 Replace components...：元件替换。 
 Update components on sheet...：将用更早版本 Multisim 创建的电路图中的元件更新，

以匹配当前的元件数据库。 
 Update HB/SC symbols：更新层次模块（Hierarchical block）或子电路（Subcircuit）

的符号。 
 Electrical rules check：电气规则检验。 
 Clear ERC marker：清除 ERC 标志。 
 Toggle NC marker：设置 NC 标志。 
 Symbol editor...：符号编辑器。 
 Title block editor...：工程图纸标题栏编辑器。 
 Description box editor...：描述箱编辑器。在描述箱中，可插入文本、位图、声音、

视频等，对电路进行整体描述。 
 Capture screen area：选择区域屏幕抓图。 
 Online design resources：网上设计资源。将弹出 Web 页面，允许用户查找和选择网

上的器件、电路或其他资源。 

9. Reports（报告）菜单 

Reports 菜单提供材料清单等 6 个报告命令。 
 
 Bill of materials：材料清单。用于列出当前用到的所有元件，生成制作电路板所需

的元件汇总表。 
 Component detail report：元件详细报告。调出元件数据库对话框，可选择某一元件，

生成该元件的数据库详情报告。 
 Netlist report：网表报告。生成网表文件，用文本方式显示/打印电路元件之间的连

接关系。 
 Cross reference report：交叉引用报告。生成当前设计的所有元件详情表。 
 Schematic statistics：统计报告。列出设计中各种元素的统计数据，如器件、门、引

脚、页面等的数量。 电子
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 Spare gates report：剩余门电路报告。生成设计中所有元件里未使用的门的列表。 

10. Options（选项）菜单 

通过 Options 菜单可以对软件的运行环境进行定制和设置。 
 
 Global preferences...：全局偏好设置。可在弹出的对话框中，设置包括存储路径、

消息弹出、保存方式、元器件放置和显示模式、鼠标滚轮控制方式、仿真、预览

方式等。 
 Sheet properties：工作台界面设置。 
 Lock toolbars：锁定工具栏。 
 Customize interface...：用户界面设置。 

11. Window（窗口）菜单 

Window 菜单提供各种窗口操作命令，同时在菜单中列出当前所有打开的文件名称。 
 
 New window：建立新窗口。 
 Close：关闭窗口。 
 Close all：关闭所有窗口。 
 Cascade：窗口层叠。 
 Tile horizontal：窗口水平平铺。 
 Tile vertical：窗口垂直平铺。 
 Next window：下一个窗口。 
 Previous window：前一个窗口。 
 Windows...：窗口选择。 

12. Help（帮助）菜单 

Help 菜单提供了对 Multisim 软件的在线帮助和辅助说明。 
 
 Multisim Help：主题目录，快捷键为 F1，可检索关于 Multisim 软件的各种帮助信息。 
 NI ELVISmx help：关于 NI ELVISmx 的帮助。 
 Getting Started：打开 pdf 格式帮助文档“NI 电路设计套件入门”。 
 Multisim Fundamentals：打开 pdf 格式帮助文档“NI Multisim 基础”。 
 Release notes：打开 pdf 格式文档“NI 电路设计套件版本说明”。 
 Patents...：专利权。 
 Find examples...：查找示例电路。 
 About Multisim：有关 Multisim 的说明。 

3.2.3  Multisim的工具栏 

图 3.3 所示为 Multisim 的几种常用工具栏，使用时把鼠标悬停在某按钮上，就会显示电子
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按钮对应功能的简单英文注释说明。如需详细说明，可通过执行菜单命令 Help→ Multisim 
help，在打开的帮助对话框中用相关关键词搜索。 

工具栏的所有功能都可在某个菜单项里找到。如果菜单 Options 中的 Lock toolbars 命
令没有被选中（前面没有√）时，表示工具栏没有被锁定，用户可以用鼠标拖动工具栏左

侧或顶部的双线，自由安排每个工具栏的摆放位置。它们可以直接排列在菜单栏下面，也

可作为一个独立对象，单独放在页面上的任何位置。 
 

 

（a）标准工具栏与视图工具栏 

 

 

（b）主工具栏 

图 3.3  Multisim 12.0 的常用工具栏 

3.2.4  Multisim的元器件库 

Multisim 12.0 提供了丰富的元器件库，元器件库栏图标和名称如图 3.4 所示。 
 

 

图 3.4  Multisim 12.0 的元器件库栏 

用鼠标左键单击元器件库栏的某一个图标即可打开该元件库。读者还可使用在线帮助

功能查阅有关的内容。在元器件库中，虚拟器件的参数是可以任意设置的，非虚拟元器件

的参数是固定的，但是是可以选择的。 电子
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各元器件库的主要内容说明如下： 
 
 电源/信号源库（Source）：包含有接地端、直流电压源（电池）、正弦交流电压源、

方波（时钟）电压源、压控方波电压源等多种电源与信号源。 
 基本器件库（Basic）：包含有电阻、电容等多种元件。 
 二极管库（Diode）：包含有二极管、可控硅等多种器件。 
 晶体管库（Transistor）：包含有晶体管、FET 等多种器件。 
 模拟集成器件库（Analog）：包含有多种运算放大器。 
 TTL 器件库（TTL）：包含有 74××系列和 74LS××系列等 74 系列数字电路器件。 
 CMOS 器件库（CMOS）：包含有 40××系列和 74HC××系列等多种 CMOS 数字集

成电路系列器件。 
 其他数字器件库（Misc Digital）：包含有 DSP、FPGA、CPLD、VHDL 等多种器件。 
 数模混合集成电路库（Mixed）：包含有 ADC/DAC、555 定时器等多种数模混合集

成电路器件。 
 指示器件库（Indicator）：包含有电压表、电流表、7 段数码管等多种器件。 
 电源器件库（Power）：包含有三端稳压器、PWM 控制器等多种电源器件。 
 其他器件库（Miscellaneous）：包含有晶体、滤波器等多种器件。 
 键盘显示器库（Advanced Peripherals）：包含有键盘、LCD 等多种器件。 
 机电类器件库（Electro Mechanical）：包含有开关、继电器等多种机电类器件。 
 微控制器器件库（MCU）：包含有 8051、PIC 等多种微控制器。 
 射频元器件库（RF）：包含有射频晶体管、射频 FET、微带线等多种射频元器件。 
 NI 元器件库（NI Components）：包含 NI 公司的通用接口、DAQ 芯片等多种 NI 公

司的元器件。 
 
此外，元器件库栏还有两个图标： 
 
 放置层次模块（Hierarchical block from file…）：打开某个已有的电路文件，作为一

个层次模块放置在当前电路中。 
 放置总线（Bus）：单击该图标后可在电路图中绘制总线连接。 

3.2.5  Multisim的仪器仪表库 

对电路进行仿真运行，通过对运行结果的分析，判断设计是否正确合理，是 EDA 软

件的一项主要功能。为此，Multisim 为用户提供了类型丰富的虚拟仪器，可以用菜单命令

（Simulation→Instrument），或者从仪器仪表工具栏选用这 18 种仪表。在选用后，各种虚

拟仪表都以面板的方式显示在电路中。在这些虚拟测试仪器仪表中，有普通电子实验室常

见的通用仪器，如数字万用表、函数信号发生器、各种示波器、直流电源等；还有一些科

研开发中常用的测试仪器，如波特图仪、字信号发生器、逻辑分析仪、逻辑转换器、失真

度分析仪、频谱分析仪和网络分析仪等；此外还有与现实中的特定仪器结合的虚拟仪器，

如与安捷伦（Agilent）公司的示波器、万用表、函数信号发生器，以及泰克（Tektronix）电子
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公司的示波器对应的虚拟仪器，其在软件中的工作面板和操作方式与实际仪器完全一致，

只是改用鼠标操作而已。Multisim 的仪器仪表库栏中的图标及功能如图 3.5 所示。习惯上，

我们也经常在工作时把仪器仪表库栏放到工作区的右边纵向排列，便于随时调用需要的仪

器仪表。在后面的 3.4 节中，我们将介绍部分常用虚拟仪器仪表的功能和操作方法。 
 

 

图 3.5  Multisim 12.0 的仪器仪表库栏 

3.3  Multisim 软件的基本操作 

Multisim 软件界面简洁清晰，虚拟仪器调用方便，易于学习，是一种特别适合初学者

上手的电子电路仿真软件。本节主要介绍 Multisim 软件的常用基本操作，电路图的绘制与

编辑方法，以及常用的电路分析方法。 

3.3.1  常用基本操作 

1. 文件的基本操作 

（1）新建文件 
新建文件有三种操作方式： 
 
 用鼠标选择菜单命令 File→New； 
 单击工具栏中的“新建（New）”按钮 ； 
 用键盘键入快捷键“Ctrl+N”。 
 
此操作可打开一个无标题的电路窗口，可用它来创建一个新的电路。当启动 Multisim

时，也会自动打开一个新的无标题电路窗口，在关闭当前电路窗口前将提示是否保存它。 

（2）打开文件 
打开文件有三种操作方式： 
 
 用鼠标选择菜单命令 File→Open； 
 单击工具栏中的“打开（Open）”按钮 ； 
 用键盘键入快捷键“Ctrl+O”。 
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此操作可打开一个标准的文件对话框，选择存放文件所需要的驱动器／文件目录或磁

盘／文件夹，用鼠标单击所需要的电路文件名，则该电路便显示在电路工作窗口中。 

（3）关闭文件 
用鼠标选择菜单命令 File→Close，或者单击菜单栏同行中右上角的小图标 ，可关闭

当前电路工作区内的文件。 

（4）保存文件 
保存文件有三种操作方式： 
 
 用鼠标选择菜单命令File→Save； 
 单击工具栏中的“保存（Save）”按钮 ； 
 用键盘键入快捷键“Ctrl+S”。 
 
此操作以电路文件形式保存当前电路工作窗口中的电路。对新电路文件进行保存操作，

会显示一个标准的保存文件对话框，选择保存当前电路文件的目录／驱动器或文件夹／磁

盘，然后键入文件名，单击“保存”按钮即可将该电路文件保存。 

（5）文件换名保存 
用鼠标选择菜单命令 File→Save as 选项，可将当前电路文件换名保存，新文件名及保

存目录／驱动器均可选择。原存放的电路文件仍保持不变。 

（6）打印 
通过鼠标选择菜单命令 File→Print 选项，或用快捷键“Ctrl＋P”，或者单击工具栏中

的“打印（Print）”按钮 ，可对当前电路工作窗口中的电路及测试仪器进行打印操作。 
如果需要，可在进行打印操作之前进行打印设置工作。设置方法：用鼠标单击菜单命

令 File→Print options→Print circuit setup 选项，显示一个标准的打印设置对话框，从中选择

各打印的参数进行设置。打印设置内容主要有打印机选择、纸张选择、打印效果选择等。 

2. 编辑的基本操作 

（1）撤销与重做 
通过鼠标选择菜单命令 Edit→Undo，或者单击工具栏中的“撤销（Undo）”按钮 ，

或者用快捷键“Ctrl+Z”可撤销最近一次的操作；通过鼠标选择菜单命令 Edit→Redo，或

者单击工具栏中的“重做（Redo）”按钮 ，或者用快捷键“Ctrl+Y”可恢复最近一次被撤

销的操作。 

（2）元器件旋转与翻转 
如果元器件在电路图中的摆放方式不合适，可以通过旋转与翻转命令进行调整。 
旋转包括顺时针旋转与逆时针旋转。用鼠标选择菜单命令 Edit→Orientation→Rotate 

90°clockwise 或使用快捷键“Ctrl＋R”，可将当前处于选中状态的元器件顺时针旋转 90°；
用鼠标选择菜单命令 Edit→Orientation→Rotate 90°counter clockwise 或用快捷键“Shift＋电子
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Ctrl＋R”，将所选择的元器件逆时针旋转 90°。与元器件相关的文本，例如标号、数值和模

型信息可能重置，但不会旋转。 
翻转包括水平镜像翻转与垂直镜像翻转。用鼠标选择菜单选项 Edit→Orientation→Flip 

horizontal，可将所选元器件以纵轴为轴翻转 180°；用鼠标选择菜单选项 Edit→Orientation
→Flip Vertical，可将所选元器件以横轴为轴翻转 180°。与元器件相关的文本，例如标号、

数值和模型信息可能重置或翻转。 

（3）编辑元件属性 
选中元器件，用鼠标单击菜单命令 Edit→Properties 或使用快捷键“Ctrl＋M”，或者在

原理图编辑窗口中用鼠标器双击所选元器件，可弹出该元器件的特性对话框。使用该对话

框，可对元器件的标签、编号、数值、模型参数等进行设置与修改。对话框中的选项与所

选的元器件类型有关。 

3. 输入文字说明或电路注释 

为加强对电路图的理解，给电路图添加适当的文字注释有时是必要的。在 Multisim 中，

有两种对电路进行注释说明的方法。 
一种是在 Multisim 的电路工作窗口内，放置文本框，输入中英文文字说明。操作方法

是用鼠标选择菜单命令 Place→Text，在电路图编辑窗口中用鼠标单击需要放置文字的位

置，可以在该处放置一个文字块（文本框），然后在文字输入框中输入所需要的文字。文字

输入框会随文字的多少自动缩放，文字输入完毕，用鼠标单击文字输入框以外的地方，文

字输入框会自动消失。如果需要改变字体或文字的颜色，可以用鼠标指向该文字块，用鼠

标右键单击弹出快捷菜单，在快捷菜单中选择 Font 选项可改动文字的字体和大小；选取

Pen color 命令，在出现的“颜色”对话框中可选择文字颜色。 
第二种方式是在电路图中加入注释标签，操作方法是执行菜单命令 Place→Comment，

在电路图编辑窗口中用鼠标单击需要放置文字的位置，可以在该处放置一个文字块（文本

框），然后在文字输入框中输入所需要的注释文字。利用注释标签可以对元器件的作用、电

路的功能、使用说明等进行详尽的描述，并且在电路图中以一个小图标 的形式出现，不

占用电路窗口空间，需要查看时用鼠标悬停在小图标上即可打开注释，双击它时会出现一

个注释属性对话框，可以对注释的显示方式，包括颜色、字体、背景等进行设置。 

4. 编辑图纸标题块 

执行菜单命令 Place→Title block，可打开一个标题块模板选择对话框，如图 3.6 所示，

在标题栏文件中包括 10 个可选择的标题块的模板文件。 
选中其中一个模板文件，以 default.tb7 为例，单击“打开”按钮，会有一个标题块粘

附在鼠标上，选择电路图编辑窗口合适的位置（通常习惯是选择电路图某一边角，不会遮

盖电路图的空白区域），单击鼠标，即可将标题块放置在电路图中。此标题块模板如图 3.7
所示。 
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图 3.6 标题块模板选择对话框 

 

 

图 3.7   default.tb7 的标题块模板 

图 3.7 中的标题块模板中包括 11 个栏位： 
 
 Title：当前电路图的图名，程序会自动将文件名称设定为图名。 
 Desc.：当前电路图的功能描述。 
 Designed by：当前电路图的设计者姓名。 
 Checked by：当前电路图的检查者姓名。 
 Approved by：当前电路图的核准者姓名。 
 Document No：当前电路图的图号。 
 Date：当前电路图的绘制日期。 
 Sheet：标明当前电路图为图集中的第几张图。 
 of：当前电路图所属的图集，总共有多少张图。 
 Revision：当前电路图的版本号。 
 Size：图纸尺寸。 
 
双击鼠标可以打开标题栏设置对话框，在对话框中可以编辑修改标题栏内容，编辑完

毕单击 OK 按钮即可。 电子
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5. 软件中的基本设置 

（1）电路符号标准设置 
Multisim 提供两组常用标准的电路符号，美国 ANSI 标准元器件符号和欧洲 DIN 标准

元器件符号（如表 3.1 所示）。其中 DIN 标准与中国国内大部分电子技术类著作及教材采

用的符号标准风格基本一致，所以本书将 Multisim 设置为采用 DIN 标准的电路符号。 

表 3.1 部分常见元件的 DIN 标准元器件符号与美国 ANSI 标准元器件符号对照表 

元件名称 DIN 标准符号 ANSI 标准符号 

定值电阻   

可变电阻 
  

与门 

  

或门 

  

非门 
  

与非门 

  

或非门 

  

异或门 

  

同或门 

  
 
修改电路图中电路符号标准的方法是，通过执行菜单命令 Options→Global preferences

设置。在弹出的 Global Preferences 对话框（如图 3.8 所示）中选择 Components 选项卡，然

后在 Symbol standard 区域选择元器件符号为 DIN 标准，最后单击 OK 按钮确认设置。 
注意，在同一个设计或者同一张电路图中应当保持元器件符号标准一致。 

（2）元器件操作模式设置 
在如图 3.8 所示的Global Preferences 对话框的Components 选项卡中，从 Place component 

mode 区域可设置放置元器件时的操作模式。 
 

  &

>=1

&

>=1

=1

=1
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图 3.8 Global Preferences 对话框的 Components 选项卡 

选项左边的方框表示可复选项，打钩为确认选中该项；圆框表示单选项，出现小点为

确认选中该项。各选项具体含义如下： 
 
 Return to Component Browser after placement：放置完元器件后回到元器件库浏览窗

口。选中此项时，每次放置完一个元器件，即跳回到元器件库浏览窗口，便于选

择并放置下一个器件；不选中此项时，每次放置完一个元器件，即回到电路图编

辑窗口，不再跳回元器件库 Components 浏览窗口。 
 Place single component：选中时，从元器件库里取出元器件，只能放置一次。 
 Continuous placement for multi-section component only（ESC to quit）：选中时，如果

从元器件库里取出的元器件是 74××之类的单封装内含多组件的元器件，则可以

连续放置元器件；停止放置元器件，可按 ESC 键退出。 
 Continuous placement（ESC to quit）：选中时，从元器件库里取出的零件，可以连

续放置；停止放置元器件，可按 ESC 键退出。 

（3）电路图显示方式的设置 
选择 Options 菜单中的 Sheet properties（电路图纸属性设置）命令（Options→Sheet 

properties），用于设置与电路图显示方式有关的一些选项。需要注意的是，在执行菜单命令

Options→Sheet properties 后出现的对话框中，多数选项卡的左下角有一个用于用户默认的

设置 Save as default，勾选该选项则可将当前设置存为用户的默认设置，默认设置的影响范

围是新建图纸；若仅单击 OK 按钮但不选中 Save as default 选项则不影响用户的默认设置，电子
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仅影响当前图纸的设置。Sheet Properties 对话框中几个常用选项卡简介如下。 
1）Sheet visibility（电路图纸可见性设置）选项卡 
执行菜单命令 Options→Sheet properties，在出现的对话框中单击 Sheet visibility 选项

卡，如图 3.9 所示，其中：  
 
 在 Component（元器件）区域中可选择是否显示各种元器件参数。Labels 选项用于

是否显示元器件的标志，RefDes 选项用于是否显示元器件编号，Values 选项用于

是否显示元器件数值，Initial conditions 选项用于初始化条件，Tolerance 选项用于

公差。 
 在 Net names（网络别名）区域中可以选择电路中各导线网络别名的显示方式，可

以在 Show all（全部显示）、Use net-specific setting（使用网络特定设置）、Hide all
（全部隐藏）三个选项中选择一个。 

 在 Connectors（端口连接器）区域中可以选择是否显示某一类端口连接器的名字。 
 在 Bus entry（总线输入）区域中，可以选择是否显示总线的标签（Labels），以及

是否显示总线的网络别名（Bus entry net names）。 
 
2）Colors（颜色）选项卡 
执行菜单命令 Options→Sheet properties，在出现的对话框中单击 Colors 选项卡，如图

3.10 所示，其中： 
 

     

         图 3.9  Sheet visibility 选项卡                       图 3.10  Colors 选项卡 

 Color scheme（颜色方案）中有 5 个下拉选项，每一项对应一种颜色方案，用来确

定合适的电路工作区的背景、元器件、导线、文字、已选中对象等的颜色等。5 个

下拉选项中有 4 个选项（包括 White background、Black background、White& Black、
Black& White）是已有的成套的颜色方案，还有一种是用户自定义方案（Custom），

允许用户自己指定每种图形对象的颜色。 电子
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 Preview（预览）区域里，显示了当前选择的颜色方案的显示效果。 
 
3）Workspace 选项卡 
执行菜单命令 Options→Sheet properties，在出现的对话框中单击 Workspace 选项卡，

如图 3.11 所示，其中各选项的功能如下： 
 
 Show grid：选择电路工作区里是否显示栅格点。这些栅格点的主要功能是在绘制

电路图时便于对齐连线或元器件，可根据用户需求选择是否打开或关闭。执行菜

单命令 View→Grid 也有同样的功能。 
 Show page bounds：选择电路工作区里是否显示页面分隔线（边界）。 
 Show border：选择电路工作区里是否显示边界。 
 Sheet size 区域的功能是设定图纸大小（A～E、A0～A4 以及 Custom 选项），并可

选择尺寸单位为 Inches（英寸）或 Centimeters（厘米），以及设定图纸方向是 Portrait
（纵向）或 Landscape（横向）。 

 
4）Wiring 选项卡 
执行菜单命令 Options→Sheet properties，在出现的对话框中单击 Wiring 选项卡，在其

中的 Drawing option（绘图选项）中可以设置两种类型导线在绘图中的线宽：  
 
 Wire width：设置单股导线的线宽，默认数值为 1。 
 Bus width：设置总线的线宽，默认数值为 3。 
 
其中，线宽用数字表示，数字越大，表示相应导线的线条就越粗。 
5）Font 选择卡 
执行菜单命令Options→Sheet properties，在出现的对话框中单击 Font 选项卡，如图 3.12

所示，其中各选项的功能如下： 
 

     

         图 3.11  Workspace 选项卡                          图 3.12  Font 选项卡 电子
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 Font 区域可以选择字体，可以直接在栏位里选取所要采用的字体。 
 Font style 区域选择字形，字形可以为粗体字（Bold）、粗斜体字（Bold Italic）、斜

体字（Italic）、正体字（Regular）。 
 Size 区域选择字号，可以直接在栏位里选取，也可直接在输入框输入表示字号的数

字。 
 Preview 区域显示的是所设定的字体的预览效果。 
 Change all 区域选择本对话框所设定的字体应用到哪些对象，有对钩时表示选中可

选项，包括以下几类文字： 
  Component RefDes：元器件编号。 
  Component values and labels：元器件标注文字和数值。 
  Component attributes：元器件属性文字。 
  Footprint pin names：引脚名称。 
  Symbol pin names：符号引脚。 
  Net names：网络表名称。 
  Schematic text：电路图里的文字。 
  Comments and probes：注释和探针文字。 
  Bus line name：总线名称。 

 Apply to 区域选择本对话框所设定的字体的应用范围，有两个可选项：  
  Entire sheet：将应用于整个电路图。 
  Selection：应用在选取的项目上。 

（4）软件界面风格设置 
用户可通过 View 菜单中的命令设置 Multisim 主窗口的各类栏目的显示模式，包括是

否显示某些栏目、栏目的位置、工具栏的布局等。View 菜单展开状态如图 3.13 所示，选

中某项时，该菜单项前面出现小钩，表示显示对应的栏目。例如图 3.13 中 Design Toolbox
选项前面有一个小钩，表示在主界面中显示设计工具箱，单击则可去掉小钩，表示在主界

面中不显示设计工具箱。 
View 菜单中部分选项的作用解释如下： 
 
 Spreadsheet View：显示或者关闭电子数据表扩展显示窗口。该栏目主要用于显示

电路仿真进程、错误等相关信息。 
 Description Box：显示或者关闭电路描述窗口。该窗口是一个文本记录窗口，其中

的文本文字是由用户自定义的对电路各类信息的描述说明。 
 Toolbars：显示或者关闭各种工具栏。工具栏的各项内容说明详见图3.13中的注释。 
 Show comment/probe：显示或者关闭注释/标注。 
 Grapher：显示或者关闭多用途图形显示工具 Grapher。Grahper 界面主要用于显示、

保存或输出各种 Multisim 电路分析的结果，并以图形或表格的形式显示出来。 
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标准工具栏（复制、剪切、粘贴、打印等）

视图工具栏（放大、缩小电路图等）

主工具栏（查找示例、电气规则校验等）

图形注释工具栏

模拟元器件工具栏

基本元器件工具栏

二极管工具栏

晶体管工具栏

测量工具栏（电压表、电流表、指示灯等）

其他元器件工具栏

元器件库工具栏

电源工具栏

额定值虚拟元器件工具栏

信号源元器件工具栏

虚拟元器件工具栏

仿真开关

仿真工具栏

仪器仪表工具栏

描述编辑器工具栏

单片机工具栏

LabVIEW虚拟仪器工具栏

NI ELVISmx仪器工具栏

 

图 3.13  View 菜单展开状态及各项控制命令 

在 Options 菜单中，如果 Lock toolbars 菜单项处于非选中状态，用户还可以用鼠标拖

动各个显示在主窗口的工具栏，改变工具栏的位置和布局。方法是用鼠标单击（按住不放）

需要调整的工具栏左侧或上侧的双线，在图 3.14 中视图工具栏左侧的划圈位置，将其拖拽

到合适的位置，再放开鼠标，该工具栏即可被移动到新的位置上。如果 Lock toolbars 菜单

项处于选中状态，则工具栏将被锁定，不能改变位置和布局。  

 
图 3.14  视图工具栏（虚线框处为可拖动位置） 

3.3.2  电路图的绘制与编辑 

1. 元器件的选用与放置 

绘制电路图首先需要在电路图中放置各种元器件。下面以放置 1kΩ 欧姆电阻为例，说

明选用与放置元器件的基本方法。 
首先打开元器件库。有两种方式，第一种是选择菜单命令项 Place→Component…，出

现元器件库对话框（如图 3.15 所示），在 Group 列表中选中 Basic 选项。第二种方式是在

元器件库栏中直接用鼠标单击图标 ，打开 Basic 元器件库。 
然后在 Family 列表中选中 RESISTOR 系列，在 Component 列表栏用鼠标单击选中 1.0k电子
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（默认单位欧姆），单击OK按钮（或直接用鼠标双击 1.0k），元器件库对话框消失，在 Symbol
符号框中的器件图标就粘附在鼠标上，用鼠标在电路工作区中需要放置该器件的地方单击，

1k 欧姆电阻即出现在电路图中，如图 3.16 所示。电阻会被自动命名为 Rn，其中 n 是程序

按照放置顺序自动分配的数字，用户可以使用元器件的默认名称，也可放置好后自行修改。

注意，在 Multisim 的一个电路图中，每个元器件的名字都是不允许重复的。 
 

             

            图 3.15  选择元器件库对话框图                         图 3.16  放置好的电阻 

2. 选中元器件 

在连接电路时，要对元器件进行移动、旋转、删除、设置参数等操作，这就需要先选

中该元器件。要选中某个元器件，可使用鼠标的左键单击该元器件，被选中的元器件的四

周出现 4 个黑色小方块（电路工作区为白底），便于识别。对选中的元器件可以进行移动、

旋转、删除、设置参数等操作。用鼠标拖拽形成一个矩形区域，可以同时选中在该矩形区

域内包围的一组元器件。 
要取消某一个元器件的选中状态，只需单击电路工作区的空白部分即可。 

3. 移动元器件 

要想移动某一元器件，只需在电路图中用鼠标选中该元器件（左键不松手），然后将其

拖拽到合适的位置，放开鼠标即可。 
要移动一组元器件，必须先用前述的矩形区域方法选中这些元器件，然后用鼠标左键

拖拽其中的任意一个元器件，则所有选中的部分就会一起移动。元器件被移动后，与其相

连接的导线就会自动重新排列。 
选中元器件后，也可使用键盘上的方向键（↑、↓、←、→）使之做微小的移动。 

4. 元器件的旋转与反转 

对元器件进行旋转或反转操作，需要先选中该元器件，然后单击鼠标右键或者选择菜电子
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单项 Edit，接着选择 Flip horizontal（将所选择的元器件左右旋转）、Flip vertical（将所选择

的元器件上下旋转）、Rotate 90°clockwise（将所选择的元器件顺时针旋转 90°）、Rotate 90°
counter clockwise（将所选择的元器件逆时针旋转 90°）等命令。也可使用 Ctrl 键实现旋转

操作。Ctrl 键的使用标在菜单命令的旁边。 

5. 元器件的复制、删除 

对选中的元器件，进行元器件的复制、移动、删除等操作：可以单击鼠标右键，选择

弹出的快捷菜单命令，或者使用菜单 Edit 下的命令，选择 Cut（剪切）、Copy（复制）、Paste
（粘贴）、Delete（删除）等命令实现元器件的复制、移动、删除等操作。 

也可利用键盘或组合快捷键实现相关功能。如用 Delete 键实现删除操作，用快捷键

“Ctrl+C”实现复制操作，用“Ctrl+V”实现粘贴操作，用“Ctrl+X”实现剪切操作。 

6. 元器件标签、编号、数值、模型参数的设置 

在选中元器件后，双击该元器件，或者选择菜单命令 Edit→Properties（元器件特性）

会弹出相关的对话框，可供输入数据。 
元器件特性对话框具有多种选项可供设置，包括 Label（标识）、Display（显示）、Value

（数值）、Fault（故障设置）、Pins（引脚端）、Variant（变量）、User fields（用户域）等内

容。不同的器件，标签中的具体内容可能不同。例如，电容器的特性对话框如图 3.17 所示。 
 

 

图 3.17  电容器的特性对话框（Value 选项卡） 

（1）Label（标识）选项卡 
Label 选项卡用于设置元器件的 Label（标识）和 RefDes（编号）。 
RefDes（编号）由系统自动分配，必要时可以修改，但必须保证编号的唯一性。注意电子
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连接点、接地等元器件没有编号。在电路图上是否显示标识和编号可由 Options 菜单中的

Sheet properties 命令在 Sheet visibility 选项卡下进行设置。 

（2）Display（显示）选项卡 
Display 选项卡用于设置 Label、Values、RefDes 等参数的显示方式。默认为采用电路

图纸的可见性设置（Use sheet visibility settings），此时相关参数的显示方式与 Sheet 
Properties 对话框中的 Sheet visibility 选项卡中的设定有关。此外，也可采用元器件特定的

参数显示设置（Use component-specific visibility settings），单独设置电容器的各项参数是否

显示。 

（3）Value（数值）选项卡 
单击 Value 选项卡，可设置元器件的电气参数。例如，电容器的 Value 选项卡如图 3.17

所示，可设置电容器容值（Capacitance），以法拉（F）为基本单位，用 μF 表示“微法”。

此外，还可设置容差（Tolerance）、元器件型号（Component type）、超链接（Hyperlink）、
附加的 SPICE 仿真参数（Additional SPICE simulation parameters）、布线设置（Layout 
settings）等。 

（4）Fault（故障）选项卡 
Fault 选项卡可供人们设置元器件的隐含故障。例如在三极管的故障设置对话框中，E、

B、C 为与故障设置有关的引脚号，对话框提供 Leakage（漏电）、Short（短路）、Open（开

路）、None（无故障）等设置。如果选择了 Open 设置，则图中设置引脚 E 和引脚 B 为 Open
状态，尽管该三极管仍连接在电路中，但实际上隐含了开路的故障。这可以为电路的故障

分析提供方便。 

（5）改变元器件的颜色 
在复杂的电路中，可以将元器件设置为不同的颜色，使电路图更加清晰易读。要改变

元器件的颜色，可用鼠标指向该元器件，单击右键可以出现快捷菜单，选择其中的 Color
选项，出现颜色选择框，然后选择合适的颜色即可。 

7. 导线的绘制与编辑 

（1）连接导线 
在两个元器件之间，首先将鼠标指向一个元器件的端点使其出现一个带十字的小圆点，

按下鼠标左键并拖拽出一根导线，拉住导线并指向另一个元器件的端点使其出现小圆点，

释放鼠标左键，则导线连接完成。 
连接时，导线将自动选择合适的走向，不会与其他元器件或仪器发生重合。如果用户

希望自己选择导线的排布方式，可以在连线的中间用鼠标单击，自主确定连接线的转折点。 

（2）导线的删除与改动 
用鼠标单击一条导线，使之处于选中状态（导线上出现方形标示点），按键盘上的 Delete

键，即可删除选中的导线。用鼠标拖拽，即可移动某段被选中的导线。 电子
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（3）改变导线的颜色 
在复杂的电路中，为使电路图更加清晰易读，可以将导线设置为不同的颜色。要改变

导线的颜色，可用鼠标指向该导线，单击右键，在出现的菜单中选择 Net color 选项，出现

颜色选择框，然后选择合适的颜色即可。 

（4）在导线中插入元器件 
将元器件直接拖拽放置在导线上，然后释放即可在电路中插入元器件。 

（5）为导线设置网络名称（Net Name） 
在 Multisim 中，术语“Net”译为网络，用于描述电路图中引脚之间的连接线。为连

接线命名有利于使电路图更具有可读性，并易于在电路分析时发现信号的走向。在 Multisim
的电路图中创建网络时，软件会自动用数字为线路进行命名，在一个电路图中每一条线都

有一个独一无二的名称。  
但有时用户可能希望为某条线路设置有特殊意义的名称，如“Output”，那么也可以为

连接线指定所需的名称。设置自定义网络名称的方法是，双击要命名的连接线，弹出 Net 
Properties（网络属性）对话框，选择 Net name 选项卡，如图 3.18 所示。当前使用的网络

名称和命名来源即显示在选项卡中，在 Net name 文本框里输入自定义网络名称，单击 OK
按钮，即可为选定导线指定新的网络名称。复选框 Show net name (when net-specific settings 
are enabled)是否选中用于确定是否在电路图中显示网络名称。 

 

 

图 3.18  Net Properties 对话框 电子
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在 Multisim 中，如果将两条导线命名为同一名称，则两条导线会在电路中被自动合并

实现连通，但由于在电路图中不一定有可见的连接线将其连接，因此称之为“虚拟接线”。

这种方式可用于减少电路连线图的复杂程度，使电路图在视觉上更为简洁。 
需要特别注意的是，当一条导线连接在一些特殊节点上，如全局节点 VCC、GND、页

面内连接器（On-page connector）、页面间连接器（Off-page connector）和层次模块/子电路连

接器（HB/SC connector）时，网络名字会自动匹配这些特殊节点的名称，不会再使用原有的

自动命名名称或用户自定义名称。例如，任何与全局节点模拟地（Analog Ground） 相连

的导线，网络名称即被自动更名为 0，不能再被编辑为其他名称。 

（6）在导线上放置连接点 
“连接点”（Junction）也叫节点，在电路中是导线交叉处的一个小圆点，可以实现交

叉点导线的电连通。根据电路图绘制规范，在多条导线交叉时，有交叉相连和交叉不相连

两种方式。只有交叉处有连接点的，这些导线才是电连通的；没有连接点的，即使位置上

看来线路交叉，也是不连通的状态。 
单击菜单项 Place→Junction 可以放置连接点。一个连接点最多可以连接来自 4 个方向

的导线。可以直接将连接点插入连线中。 
在连接电路时，Multisim 自动为每个节点（连接点）分配一个编号。是否显示节点编

号可由 Options→Sheet properties 命令出现的对话框进行设置。选择 RefDes 选项，可以选

择是否显示连接线的节点编号。 

8. 创建子电路 

子电路是由用户自己设计定义的一个电路，可存放在自定义元器件库中，成为一个电

路模块，供电路设计时反复调用。利用子电路可使大型的复杂系统的设计模块化、层次化，

从而提高设计效率与设计文档的简洁性、可读性，实现设计的重用，缩短产品的开发周期。 
子电路的创建步骤示例如下： 
（1）首先在电路工作区连接好一个电路，如图 3.19 所示的是一个全加器（Full Adder）

电路。 
 

 

图 3.19 全加器电路图 

（VCC 为软件自动生成，等同于 VCC） 
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（2）用鼠标单击菜单命令 Place→Replace by subcircuit，即出现子电路命名对话框，

如图 3.20 所示。 
 

 

图 3.20 子电路命名对话框 

（3）输入电路名称如 FA（最多为 8 个字符，包括字母与数字）后，用鼠标单击 OK
按钮，选择的电路复制到用户器件库中，同时给出子电路图标，完成子电路的创建。生成

的子电路图标如图 3.21 所示。 
 

 

图 3.21 生成的子电路图标 

用鼠标单击菜单命令 File→Save 或键入快捷键“Ctrl＋S”，可以保存生成的子电路。

用鼠标单击菜单命令 File→Save As，可将当前子电路文件换名保存。 
子电路的调用：执行菜单命令 Place→New Subcircuit 或使用快捷键“Ctrl+B”，在打开

的对话框里输入已创建的子电路名称 FA，即可在电路图中放入一个全加器的子电路模块。  
子电路的修改：双击子电路模块，在出现的层次模块 /子电路（Hierarchical 

Block/Subcircuit）对话框中单击 Edit HB/HC 按钮，则可调出并显示子电路的电路图，直接

修改该电路图，然后存盘，即得到修改后的子电路。   
子电路的输入／输出端口：为了能对子电路进行外部连接，需要对子电路添加输入／

输出功能。添加方法如下：执行菜单命令 Place→Connectors→HB/SC connector 或使用

“Ctrl+I”快捷键操作，屏幕出现输入／输出连接器（HB/SC Connector）符号“ ”，将

该符号与子电路的输入／输出信号连接器进行连接。注意，带有输入／输出连接器的子电

路才能与外电路连接。当你把一个输入／输出连接器与电路中的某根线连接时，如果这根

线已经有用户自定义的网络别名（Net name），那么这个连接器会自动被赋名为该线的网络

别名；如果这根线是自动分配的名字，那么这根线的网络别名会与连接器名称匹配一致。 
此外，还有一种子电路的创建方法。如果在子电路调用操作时，输入的是新的未创建

的子电路名称，则可在当前电路图中放入一个空的子电路，然后双击该子电路模块，在出

现的层次模块/子电路对话框中单击 Edit HB/HC 按钮，则可显示一个空白的子电路内部电

路图，直接修改该电路图，然后存盘，即可得到修改后的子电路模块。 
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9. 输入/输出连接器 

用鼠标单击 Place 菜单中的 Connectors 选项（Place→Connectors）即可取出所需要的一

个输入/输出连接器，放置在当前电路图之中。输入/输出连接器简称为连接器，可用于实

现和表示电路内部或多页面、多层次各电路之间的非实线连接，有些文献资料中也称其为

端口或者接口。输入/输出连接器菜单如图 3.22 所示。在电路控制区中，输入/输出连接器

可以看作是只有一个引脚的元器件，所有操作方法与元器件相同。不同的是输入/输出连接

器只有一个连接点。 
 

 

图 3.22 输入/输出连接器菜单 

各端口名称含义如下： 
 
 On-page connector：单页面连接器。用于在同一张电路图中，实现导线间的非实线

连通。即不在电路图上增画实线形式的导线，也可用同名连接器实现多个节点的电

路连通。 
 Global connector：全局连接器。用于定义一个全局网络名称。全局连接器无论放在

层次电路图中的任何位置，网络名称始终保持不变。  
 HB/SC connector：层次电路模块或者子电路的输入或输出连接器。 
 Bus HB/SC connector：层次电路模块或者子电路的总线输入或输出连接器。 
 Off-page connector：用于在平面多张同级电路图（即非嵌套电路图）中作为电路图

间的连接器。  
 Bus off-page connector：用于在平面多张同级电路图（即非嵌套电路图）中作为电

路图间的总线连接器。 
 
注意，模拟地（Analog Ground）是一个特殊的全局连接器（也称全局端口），其名称

是不可修改的。而在电路图中如果想要知道某一个端口的类型，只需将鼠标悬停在该端口

图标上，即可显示该端口类型的提示信息。  

3.3.3 Multisim的电路分析方法 

Multisim 的电路分析方法主要有直流工作点分析、交流分析、瞬态分析、傅里叶分析、

噪声分析、失真分析、直流扫描分析、灵敏度分析、参数扫描分析、温度扫描分析、零-
极点分析、传递函数分析、最坏情况分析、蒙特卡罗分析、批处理分析、用户自定义分析、

噪声系数分析等。这些分析可通过执行菜单项 Simulate→Analyses，然后通过其子菜单项调

用实现。各种分析的功能如下： 电子
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（1）直流工作点分析（DC operating point）：用于分析电路的静态工作点，即仅为电

路接通直流电源，不加交流输入信号时，电路中各点的电压和电流值。在进行直流工作点

分析时，电路中的交流源将被置零，电容开路，电感短路。 
（2）交流分析（AC analysis）：交流分析用于分析电路的频率特性。需先选定被分析

的电路节点，在分析时，电路中的直流源将自动置零，交流信号源、电容、电感等均处于

交流模式，输入信号也设定为正弦波形式。若把函数信号发生器的其他信号作为输入激励

信号，在进行交流频率分析时，会自动把它作为正弦信号输入。因此输出响应也是该电路

交流频率的函数。 
（3）单一频率交流分析（Single frequency AC analysis）：工作方式类似于 AC analysis，

但是只在单一频率下做仿真分析。 
（4）瞬态分析（Transient analysis）：瞬态分析是指定所选定的电路节点的时域响应。

即观察该节点在整个显示周期中每一时刻的电压波形。在进行瞬态分析时，直流电源保持

常数，交流信号源随着时间而改变，电容和电感都是能量储存模式元件。 
（5）傅里叶分析（Fourier analysis）：用于分析一个时域信号的直流分量、基频分量和

谐波分量。即把被测节点处的时域变化信号作为离散傅里叶变换，分析的节点，一般将电

路中的交流激励源的频率设定为基频，若在电路中有几个交流源时，可以将基频设定在这

些频率的最小公因数上。 
（6）噪声分析（Noise analysis）：噪声分析用于检查电子线路输出信号的噪声功率幅

度，用于计算、分析电阻或晶体管的噪声对电路的影响。在分析时，假定电路中各自噪声

源是互不相关的，因此它们的数值可以分开各自计算。总的噪声是各自噪声在该节点的和

（用有效值表示）。 
（7）噪声系数分析（Noise figure analysis）：主要用于研究元件模型中的噪声参数对电

路的影响。在 Multisim 的噪声系数定义中：No 是输出噪声功率，Ns是信号源电阻的热噪声，

G 是电路的 AC 增益（即二端口网络的输出信号与输入信号的比）。噪声系数的单位是 dB。 
（8）失真分析（Distortion analysis）：失真分析用于分析电子电路中的谐波失真和内

部调制失真（互调失真），通常非线性失真会导致谐波失真，而相位偏移会导致互调失真。

若电路中有一个交流信号源，则该分析能确定电路中每一个节点的二次谐波和三次谐波的

复值，若电路中有两个交流信号源，该分析能确定电路变量在三个不同频率处的复值：两

个频率之和的值、两个频率之差的值以及二倍频与另一个频率的差值。该分析方法是对电

路进行小信号的失真分析，采用多维的“Voterra”分析法和多维“泰勒”（Taylor）级数来

描述工作点处的非线性，级数要用到三次方项。这种分析方法尤其适合观察在瞬态分析中

无法看到的、比较小的失真。 
（9）直流扫描分析（DC sweep）：是利用一个或者两个直流电源分析电路中某一节点

上的直流工作点的数值变化的情况。注意：如果电路中有数字器件，则可将其当作一个大

的接地电阻处理。 
（10）灵敏度分析（Sensitivity）：是分析电路特性对电路中元器件参数的敏感程度。

灵敏度分析包括直流灵敏度分析和交流灵敏度分析。直流灵敏度分析的仿真结果以数值的

形式显示，交流灵敏度分析仿真的结果以曲线的形式显示。 电子
工业
出版
社版
权所
有 

   
   
 盗
版必
究



第 3 章 Multisim 仿真软件 

·85· 

（11）参数扫描分析（Parameter sweep）：采用参数扫描分析方法分析电路，可以较快

地获得某个元件的参数，在一定范围内变化时对电路的影响。相当于该元件每次取不同的

值，进行多次仿真。对于数字器件，在进行参数扫描分析时将被视为高阻接地。 
（12）温度扫描分析（Temperature sweep）：采用温度扫描分析，可以同时观察到在不

同温度条件下的电路特性，相当于该元件每次取不同的温度值进行多次仿真。可以通过温

度扫描分析对话框，选择被分析元件的温度的起始值、终值和增量值。在进行其他分析时，

电路的仿真温度默认值设定在 27℃。 
（13）零-极点分析（Pole zero）：用于寻找一个电路在交流小信号工作状态下，其传

递函数的零点和极点，是一种对电路的稳定性进行分析的相当有用的工具。通常先进行直

流工作点分析，对非线性器件求得线性化的小信号模型。在此基础上再分析传输函数的零、

极点。零-极点分析主要用于模拟小信号电路的分析，对数字器件将被视为高阻接地。 
（14）传递函数分析（Transfer function）：可以分析一个源与两个节点的输出电压或一

个源与一个电流输出变量之间的直流小信号传递函数。也可以用于计算输入和输出阻抗。

需先对模拟电路或非线性器件进行直流工作点分析，求得线性化的模型，然后再进行小信

号分析。输出可以是电路中的节点电压，输入必须是独立源。 
（15）最坏情况分析（Worst case）：是一种统计分析方法。它可以使你观察到元件参

数变化时，电路特性变化的最坏可能性。所谓最坏情况是指电路中的元件参数在其容差域

边界上取某种组合时所引起的电路性能的最大偏差，而最坏情况分析是在给定电路元件参

数容差的情况下，估算出电路性能相对于标称值时的最大偏差。 
（16）蒙特卡罗分析（Monte Carlo）：是采用统计分析方法来观察给定电路中的元件

参数，按选定的误差分布类型在一定的范围内变化时，对电路特性的影响。用这些分析的

结果，可以预测电路在批量生产时的成品率和生产成本。 
（17）导线宽度分析（Trace width analysis）：主要用于计算电路中电流流过时所需要

的最小导线宽度。 
（18）批处理分析（Batched analysis）：在实际电路分析中，通常需要对同一个电路进

行多种分析，例如对一个放大电路，为了确定静态工作点，需要进行直流工作点分析；为

了了解其频率特性，需要进行交流分析；为了观察输出波形，需要进行瞬态分析。批处理

分析可以将不同的分析功能放在一起依序执行。 
（19）用户自定义分析（User defined analysis）：允许用户手动载入一个 SPICE 卡片或

者网表，并使用 SPICE 命令输入来创建一个仿真分析。相比 Multisim 图形界面，这给了用

户更多自由来设置仿真分析的内容和参数，但也需要用户具有高级的SPICE程序设计知识。 

3.4 虚拟仪器仪表的使用 

强大易用、功能丰富的虚拟仪器仪表库是 Multisim 与其他电子电路仿真软件相比的一

个突出的亮点。本节主要介绍 Multisim 中虚拟仪器仪表的选用、连接、设置等一般操作，

以及最常用的一些通用虚拟仪器仪表的功能、图标、面板、设置等使用基本知识。这些通电子
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用的虚拟仪器仪表主要包括数字万用表、函数信号发生器、瓦特表、示波器、波特图仪、

频率计、字信号发生器、逻辑分析仪、逻辑转换仪、IV（电流/电压）分析仪、测量探针、

电压表、电流表等。 

3.4.1 仪器仪表的基本操作 

1. 仪器的选用与连接 

（1）仪器选用 
仪器的放置方法类似元器件的拖放。从仪器库工具栏中，用鼠标单击选中所需的仪器

图标，该仪器即可粘附在鼠标上，在电路工作区合适的位置单击，即可将该仪器图标放入

电路图中。  

（2）仪器连接 
将仪器图标上的连接端（接线柱）与相应电路的连接点相连，连线的方法类似元器件

的连线。 

2. 仪器参数的设置 

（1）设置仪器仪表参数 
双击电路图中的仪器图标即可打开仪器面板。可以用鼠标操作仪器面板上相应按钮、

旋钮，通过对话框中可编辑栏目设置仪器参数。 

（2）改变仪器仪表参数 
在测量或观察过程中，可以根据测量或观察结果来改变仪器仪表参数的设置，如示波

器、逻辑分析仪等。 

3.4.2 数字万用表 

数字万用表（Multimeter）是一种可以用来测量交直流电压、交直流电流、电阻及电路

中两点之间的分贝损耗，自动调整量程的数字显示的多用表。数字万用表在电路中的图标、

面板和参数设置对话框如图 3.23 所示。 

                  
(a) 图标           (b) 面板                               (c) 参数设置对话框 

图 3.23 数字万用表 
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用鼠标双击电路图中的数字万用表图标，可以显示数字万用表面板。可通过单选按钮，

确定数字万用表当前功能，如按钮 A 表示电流表、V 表示电压表、Ω 表示欧姆表，dB 表

示用分贝形式显示电压电平[1]。按钮 表示测量交流参量，按钮 表示测量直流参量。 

注[1]： 使用 dB 功能时，显示的电平是一个相对量。一般电压表以 600Ω 电阻功耗为

1mW 时的端电压（有效值）0.775V 为参考，即 u(dB)=20lg(u/0.775)，如交流

电压有效值分别为 0.775V 和 7.75V 时，其电压电平分别为 0dB 和 20dB。 

用鼠标单击数字万用表面板上的“Set…”按钮，则弹出参数设置对话框，在该对话框

中，可以设置数字万用表的电流表内阻（Ammeter resistance）、电压表内阻（Voltmeter 
resistance）、欧姆表电流（Ohmmeter current）、分贝相对值（dB relative value）及各

测量范围（overrange）等参数。大部分时候，我们可以直接使用默认参数。 

3.4.3 函数信号发生器 

函数信号发生器（Function generator）是可提供正弦波、三角波、方波三种不同波形

信号的电压信号源。用鼠标双击电路图中函数信号发生器图标，可以显示函数信号发生

器的面板。函数信号发生器的图标、面板及方波输出时的上升/下降时间设置对话框如图

3.24 所示。 
 

             

(a) 图标               (b) 面板                  (c) 方波输出时的上升/下降时间设置对话框 

图 3.24 函数信号发生器 

函数信号发生器的输出波形（Waveforms）、工作频率（Frequency）、占空比（Duty cycle）、
幅度（Amplitude）和直流偏置（Offset），可通过鼠标单击波形选择按钮和在各窗口中设

置相应的参数来实现。频率设置范围为 1Hz～999THz；占空比调整值为 1％～99％：幅

度设置范围为 1μV～999kV；偏移设置范围为-999～999kV。若选择的波形是方波，还可

单击函数信号发生器面板上的 Set rise/Fall time 按钮，打开上升/下降时间设置对话框（如

图 3.24（c）所示），设置方波的上升和下降时间，以模拟实际情况中的非理想数字波形。 

3.4.4 瓦特表 

瓦特表（Wattmeter）也称为功率计，用来测量电路的功率，交流或者直流均可测量。
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用鼠标双击电路图中瓦特表的图标，可以显示瓦特表的面板。瓦特表的图标和面板如图 3.25
所示。面板中显示当前测量对象的功率数值（以瓦特 W 为基本单位）和功率因数（Power 
factor）。在连入电路时，电压（Voltage）输入端与测量电路并联连接，电流（Current）输

入端与测量电路串联连接。 

                 
(a) 图标                         (b) 面板 

图 3.25 瓦特表 

3.4.5 示波器 

示波器（Oscilloscope）是用来显示电信号波形的形状、大小、频率等参数的仪器。用

鼠标双击电路图中示波器的图标，可以显示示波器的面板，示波器面板各按钮（键）的作

用及参数的设置与实际的示波器类似。示波器的图标和面板如图 3.26 所示。 
 

   

（a）图标                                     （b）面板 

图 3.26 示波器 

1. 时基（Time base）控制部分的调整 

（1）时间基准 
X 轴刻度显示示波器的时间基准，其基准刻度（Scale）从 0.1fs/Div～1000Ts/Div 可供选

择。其中时间的基本单位为秒（s），“/Div”的含义是“per division”，表示横向的每个分格。 
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（2）X 轴位置 
X 轴位置（X pos.(Div)）控制 X 轴的起始点。其中“pos.”的含义是“position”，即位

置；调节单位是分格数（Div）。当 X 的位置调到 0 时，信号从显示器的左边缘开始，正值

使起始点右移，负值使起始点左移。X 位置的调节范围为﹣5.00～＋5.00，即可从左移 5
个分格变化到右移 5 个分格。 

（3）显示方式 
利用示波器面板左下角的 4 个按钮可以选择示波器的显示方式。4 个按钮分别表示 4

种垂直方式：Y/T（幅度/时间）、A/B（A 通道/B 通道）、B/A（B 通道/A 通道）和 Add（相

加）方式。 
1）Y/T 方式：X 轴显示时间，Y 轴显示电压值。可用于显示电压随时间变化的波形图。 
2）A/B、B/A 方式：X 轴与 Y 轴都显示电压值。A/B 方式表示以通道 A 的输入电压为

纵坐标（Y 轴），以通道 B 的输入电压为横坐标（X 轴）；B/A 方式与 A/B 方式坐标取值相

反。此方式可以用来测量相同频率信号之间的相位差，如观察李沙育图形，还可以用来进

行元件测试，例如描绘二极管的伏安特性曲线，测量集成运算放大器的电压转移特性等。 
3）Add 方式：X 轴显示时间，Y 轴显示 A 通道、B 通道的输入电压之和。 

2. 示波器输入通道（Channel A 和 Channel B）的设置 

（1）Y 轴刻度 
Y 轴电压刻度（Scale）范围为 1fV/Div～1000TV/Div，可以根据输入信号大小来选择

Y 轴刻度值的大小，使信号波形在示波器显示屏上显示出合适的幅度。其中幅度的基本单

位为伏特（V），“/Div”的含义是“per division”，表示纵向的每个分格。 

（2）Y 轴位置 
Y 轴位置（Y pos.(Div)）控制 Y 轴的起始点。当 Y 的位置调到 0 时，Y 轴的起始点与

X 轴重合，如果将 Y 轴位置增加到 1.00，则 Y 轴原点位置从 X 轴向上移一大格。若将 Y
轴位置减小到﹣1.00，则 Y 轴原点位置从 X 轴向下移一大格。Y 轴位置的调节范围为﹣

3.00～＋3.00。改变 A、B 通道的 Y 轴位置有助于比较或分辨两通道的波形。 

（3）Y 轴输入方式 
Y 轴输入方式即信号输入的耦合方式，可通过每个通道下方的 AC、0、DC 三个按钮

选择。当用 AC 耦合时，示波器显示信号的交流分量。当用 DC 耦合时，显示的是信号的

AC 和 DC 分量之和。当用 0 耦合时，在 Y 轴设置的原点位置显示一条水平直线。 

3. 触发方式（Trigger）调整 

触发方式调整可通过示波器面板右下角的 Trigger 区域中相关的按钮和选项进行。 

（1）触发沿（Edge）选择 
触发沿（Edge）可选择上升沿 或下降沿 触发。 电子
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（2）触发电平（Level）选择 
触发电平（Level）可选择触发电平范围，直接在框中输入电平的数值，并选择电压单

位即可。 

（3）触发信号选择 
触发信号来源可选择来自通道 A、通道 B，或者外部信号 Ext。触发方式通过 4 个按

钮选择，包括 Single（单次脉冲触发）、Normal（常规脉冲触发）、Auto（自动触发）和 None
（无触发）。一般情况下选择自动触发（Auto）。 

4. 示波器显示波形读数 

要显示波形读数的精确值时，可用鼠标将垂直光标拖到需要读取数据的位置，显示在

屏幕下方的方框内，显示光标与波形垂直相交点处的时间和电压值，以及两光标位置之间

的时间、电压的差值。 
用鼠标单击 Reverse 按钮可将示波器屏幕的背景颜色反色，即从默认的黑色背景变成

白色背景。用鼠标单击 Save 按钮可按 ASCII 码格式存储波形读数。 

3.4.6 波特图仪 

波特图仪（Bode Plotter）可以用来测量和显示电路的幅频特性（Magnitude）与相频

特性（Phase），类似于扫频仪。用鼠标双击电路中的波特图仪图标，可显示波特图仪的

面板图，如图 3.27 所示。在面板中可选择幅频特性或者相频特性。波特图仪有 In 和 Out
两对端口，其中 In 端口的﹢和﹣分别接电路输入端的正端和负端；Out 端口的﹢和﹣分

别是电路输出端的正端和负端。使用波特图仪时，必须在电路的输入端接入 AC（交流）

信号源。 
 

    

(a) 图标                                  (b) 面板 

图 3.27 波特图仪 

1. 坐标设置 

在垂直（Vertical）坐标或水平（Horizontal）坐标控制面板图框内，单击 Log 按钮，则

坐标以对数（底数为 10）的形式显示；单击 Lin 按钮，则坐标以线性的结果显示。 
水平（Horizontal）坐标（1mHz～1000THz）：水平坐标轴显示频率值。它的标度由水
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平轴的初始值 I（Initial）或终值 F（Final）决定。 
在信号频率范围很宽的电路中，分析电路频率响应时，通常选用对数坐标（以对数为

坐标所绘出的频率特性曲线称为波特图）。 
垂直（Vertical）坐标：当测量电压增益时，垂直轴显示输出电压与输入电压之比，若

使用对数基准，则单位是分贝；如果使用线性基准，显示的是比值。当测量相位时，垂直

轴以度为单位显示相位角。 

2. 坐标数值的读出 

要得到特性曲线上任意点的频率、增益或相位差，可用鼠标拖动读数指针（位于波特

图仪中的垂直光标），或者用读数指针移动按钮来移动读数指针（垂直光标）到需要测量的

点，读数指针（垂直光标）与曲线的交点处的频率和增益或相位角的数值显示在读数框中。 

3. 分辨率设置 

Set 按钮用来设置扫描的分辨率，用鼠标单击 Set 按钮，出现分辨率设置对话框，数值

越大分辨率越高。 

3.4.7 频率计 

频率计（Frequency counter）主要用于测量信号频率和相关参数。频率计的图标和面板

如图 3.28 所示。 
 

              

(a) 图标                                  (b) 面板 

图 3.28 频率计 

频率计面板中的各项设置说明如下。 

1. Measurement（测量方式） 

 Freq 按钮：用于测量频率。 
 Pulse 按钮：用于测量一个正脉冲或负脉冲的脉冲宽度。 
 Period 按钮：用于测量信号周期。 
 Rise/Fall 按钮：用于测量一个信号周期的上升和下降时间。 
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2. Coupling（耦合方式） 

 AC 按钮：单击该按钮仅测量信号中的交流成分。 
 DC 按钮：单击该按钮测量信号中的交流成分和直流成分之和。 

3. Sensitivity (RMS)（敏感度） 

在左边的文本框中输入敏感度电压数值，在右边的单位栏中选择电压单位。 

4.Trigger level（触发电平） 

在左边的文本框中输入触发电平的数值，在右边的单位栏中选择电压单位。只有输入

波形达到触发电平时，仪器才能有读数显示。  

3.4.8 字信号发生器 

字信号发生器（Word generator）是能产生 32 路（位）同步逻辑信号的一个多路逻辑

信号源，用于对数字逻辑电路进行测试。用鼠标双击电路图中的字信号发生器图标，可调

出字信号发生器面板，如图 3.29 所示。 
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(a) 图标                                       (b) 面板 

图 3.29 字信号发生器 

1. 字信号的输入 

在字信号编辑区，32 位的字信号以 8 位十六进制数编辑和存放，编辑区可以存放 1024
条字信号，地址编号为 0000～03FF。 

字信号输入操作：将光标指针移至字信号编辑区的某一位，用鼠标单击后，由键盘输

入如二进制数的字信号，光标自左至右，自上至下移位，可连续地输入字信号。 
在字信号显示（Display）编辑区可以编辑或显示与字信号格式有关的信息。四种格式

分别为 Hex（十六进制）、Dec（十进制）、Binary（二进制）和 ASCII（ASCII 码）。字信号

发生器被激活后，字信号按照一定的规律逐行从底部的输出端送出，同时在面板的底部对电子
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应于各输出端的小圆圈内，实时显示输出字信号各个位（bit）的值。 

2. 字信号的输出方式 

通过单击字信号编辑区数字左侧的小方块，可设置字信号的起始位置（Initial Position）、
终止位置（Final Position）和断点（Breakpoint）。字信号的输出方式分为 Step（单步）、Burst
（单帧）、Cycle（循环）三种方式，三种输出方式以不同的模式输出字信号： 

用鼠标每单击一次 Step 按钮，字信号输出一条，在起始位置至终止位置之间的范围内

不断循环。这种方式可用于对电路进行单步调试。 
用鼠标单击 Burst 按钮，则从起始位置开始连续地输出字信号，直至终止位置停止；

若中间设有断点，则在断点处会暂停，暂停后再次单击 Burst 按钮会连续输出字信号，直

至终止位置停止。 
用鼠标单击 Cycle 按钮，字信号在起始位置至终止位置之间的范围内不断循环，连续

输出；若中间设有断点，则每次到断点处会暂停一次，暂停后再次单击 Cycle 按钮会继续

连续输出字信号。 
在 Burst 和 Cycle 情况下的输出节奏由输出频率的设置决定。 

3. 字信号的触发方式 

字信号的触发分为 Internal（内部）和 External（外部）两种触发方式。当选择 Internal
触发方式时，字信号的输出直接由输出方式按钮（Step、Burst、Cycle）启动。当选择 External
触发方式时，则需接入外触发脉冲，并定义“上升沿触发”或“下降沿触发”。然后单击输

出方式按钮，待触发脉冲到来时才启动输出。此外在数据准备好后，输出端还可以得到与

输出字信号同步的时钟脉冲输出。 

4. 字信号的存盘、重用、清除等操作 

用鼠标单击 Set 按钮，弹出 Pre-Setting Patterns 对话框，对话框的 Clear buffer（清字信

号编辑区）、Open（打开字信号文件）、Save（保存字信号文件）三个选项用于对编辑区的

字信号进行相应的操作。字信号存盘文件的后缀为“. DP”。对话框的 UP counter（按递增

编码）、Down counter（按递减编码）、Shift right（按右移编码）、Shift left（按左移编码）

四个选项用于生成一定规律排列的字信号。例如选择 UP counter，则按 0000～03FF 排列；

如果选择 Shift right，则按 8000、4000、2000 等逐步右移一位的规律排列；其余类推。 

3.4.9 逻辑分析仪 

逻辑分析仪（Logic Analyzer）用于对数字逻辑信号的高速采集和时序分析，可以同步

记录和显示 16 路数字信号。逻辑分析仪的面板如图 3.30 所示。 

1. 数字逻辑信号与波形的显示、读数 

面板左边的 16 个小圆圈对应 16 个输入端，各路输入逻辑信号的当前值在小圆圈内

显示，从上到下依次从最低位至最高位排列。16 路输入的逻辑信号的波形以方波形式显

示在逻辑信号波形显示区。通过设置输入导线的颜色可修改相应波形的显示颜色。波形电子
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显示的时间轴刻度可通过面板下边的 Clocks/Div 设置。读取波形的数据可以通过拖放读

数指针完成。在面板下部的两个方框内显示指针所处位置的时间读数和逻辑读数（4 位十

六进制数）。 

              

(a) 图标                                     (b) 面板 

图 3.30 逻辑分析仪 

2. 触发方式设置 

单击 Trigger 区的 Set 按钮，就会弹出触发方式设置对话框（如图 3.31 所示），触发方

式有多种选择，在 Trigger clock edge 区域，可以选择触发时钟的有效边沿是 Positive（上升

沿）、Negative（下降沿）或是 Both（两者皆可）。在 Trigger patterns 区域中可以输入 A、B、
C 三个触发字（也称为触发模式，Trigger patterns）。逻辑分析仪在读到一个指定字或几个

字的组合后触发。触发字的输入：可单击标为 A、B 或 C 的编辑框，然后输入二进制数（0
或 1）或者×，×代表该位为“任意”（0、1 均可）。用鼠标单击触发方式设置对话框中 Trigger 
combinations 方框右边的按钮，弹出由 A、B、C 组合的八组触发字，选择八种组合之一，

并单击 OK 按钮后，在 Trigger combinations 方框中就被设置为该种组合触发字了。 
 

 

图 3.31  逻辑分析仪的触发方式设置对话框 
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三个触发字的默认设置均为 16 个，表示只要第一个输入逻辑信号到达，无论是什么逻

辑值，逻辑分析仪均被触发开始波形的采集，否则必须满足触发字条件才被触发。此外，

Trigger qualifier（触发限定字）对触发有控制作用。若该位设为×，则触发控制不起作用，

触发完全由触发字决定；若该位设置为“1”（或“0”），则仅当触发控制输入信号为“1”（或

“0”）时，触发字才起作用，否则即使触发字组合条件满足也不能引起触发。 

3. 采样时钟设置 

用鼠标单击逻辑分析仪面板下部 Clock 区的 Set 按钮，会弹出时钟控制对话框，在该

对话框中，波形采集的控制时钟（Clock source）可以选择内时钟（Internal）或者外时钟

（External）。如果选择内时钟，则内时钟频率（Clock rate）可以设置。此外还可对采样数

据的数量和阈值进行设置。Clock Qualifier（时钟限定）仅当选择外时钟的时候有效，其设

置决定时钟控制输入对时钟的控制方式，若该位设置为“1”，表示时钟控制输入为“1”时

开放时钟，逻辑分析仪可以进行波形采集；若该位设置为“0”，表示时钟控制输入为“0”
时开放时钟；若该位设置为“×”，表示时钟总是开放的，不受时钟控制输入的限制。 

3.4.10 逻辑转换仪 

逻辑转换仪（Logic converter）是 Multisim 特有的虚拟仪器，能够完成真值表、逻辑

表达式和逻辑电路三者之间的相互转换，实际中不存在与此对应的设备。逻辑转换仪面板

如图 3.32 所示。 

      

(a) 图标                                        (b) 面板 

图 3.32 逻辑转换仪 

1. 逻辑电路→真值表 

逻辑转换仪可以导出多路（最多八路）输入、一路输出的逻辑电路的真值表。首先画

出逻辑电路，并将其输入端接至逻辑转换仪的输入端，输出端连至逻辑转换仪的输出端。

单击 按钮，在逻辑转换仪的显示窗口中，即真值表区出现该电路的真值表。  
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2. 真值表→逻辑表达式 

真值表的建立：一种方法是根据输入端数，用鼠标单击逻辑转换仪面板顶部代表输入

端的小圆圈，选定输入信号（从 A 至 H）。此时真值表区自动出现输入信号的所有组合，

而输出列的初始值全部为零。可根据所需要的逻辑关系修改真值表的输出值而建立真值表；

另一种方法是利用逻辑转换仪，将电路图转换为和其逻辑功能一致的真值表。 
对已在真值表区建立好的真值表，可用鼠标单击 按钮后，就会在面板

的底部逻辑表达式栏中出现相应的逻辑表达式。如果要简化该表达式或直接由真值表得到

简化的逻辑表达式，可单击 按钮，就会在逻辑表达式栏中出现相应的该真

值表的简化逻辑表达式。逻辑表达式中变量右上角的小撇号表示逻辑变量的“非”。在图

3.32（b）中，面板靠下方显示的表达式为 ，表示为通常的逻

辑表达式就是ABCD+ABCD+ABCD+ABCD+ABCD。 

3．表达式→真值表、逻辑电路或逻辑与非门电路 

可以直接在逻辑表达式栏中输入逻辑表达式，“与-或”式及“或-与”式均可，然后单

击 按钮得到相应的真值表；单击 按钮得到相应的逻辑电路；

单击 按钮得到由与非门构成的逻辑电路。 

3.4.11 IV分析仪 

IV（电流/电压）分析仪用来分析二极管、PNP 和 NPN 晶体管、PMOS 和 CMOS FET
的伏安特性。注意：IV 分析仪只能够测量未连接到电路中的元器件。IV 分析仪的图标和

面板如图 3.33 所示，其中图（b）面板中显示的是某 PNP 型 BJT 的共射极输出特性曲线，

利用光标可查看曲线上某点的详细坐标值。 
 

      

(a) 图标                                 (b) 面板 

图 3.33 IV 分析仪 
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3.4.12 测量探针 

Multisim 提供便于显示和放置的测量探针（Measurement Probe）。在仪器仪表栏上单击

图标 可调出测量探针，然后在电路中单击被测量点的导线节点，可将测量探针放置到电

路中的测量点上。在处于电路仿真状态时，测量探针旁即可以黄色小注释标签的形式显示

该点的电压、电流和频率的相关参数。 

3.4.13  电压表 

电压表（Voltmeter）存放在指示器件库中，在使用中数量没有限制，且仿真时可直接

在其电路图图标中显示测量值。电压表用来测量电路中两点间的电压。测量时，将电压表

与被测电路的两点并联。电压表预置的内阻很高，在 1MΩ 以上。但是，在低电阻电路中

使用极高内阻电压表，仿真时可能会产生错误。如需对电压表交、直流工作模式及其他参

数进行设置，可双击电压表图标，弹出电压表参数对话框。电压表的图标和参数设置对话

框如图 3.34 所示。该对话框具有多种选项可供设置，包括 Label（标识）、Display（显示）、

Value（数值）、Fault（故障设置）、Pins（引脚）、User fields（用户域）等内容的设置，设

置方法与元器件中标签、编号、数值、模型参数的设置方法相同。 
 

             

(a) 图标                                    (b) 面板 

图 3.34  电压表 

3.4.14  电流表 

电流表（Ammeter）存放在指示器件库中，在使用中数量没有限制，如图 3.35 所示。
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电流表用来测量电路回路中的电流，测量时将它串联在被测电路回路中，双击电流表图标，

弹出电流表参数对话框，电流表参数对话框具有多种选项可供设置，包括 Label、Display、
Value、Fault、Pins、User fields 等内容的设置，设置方法与元器件中标签、编号、数值、

模型参数的设置方法相同。 
 

            

(a) 图标                                   (b) 面板 

图 3.35  电流表 
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