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第 2 章  电路图绘制软件 Capture 

在调用 PSpice 软件对电路进行模拟仿真和优化设计之前，需要采用 Capture 软件生成电路图。

Capture 软件不但可以绘制各种类型的电路图（包括模拟电路、数字电路以及数/模混合电路），而且

可以对电路设计图进行各种后处理，包括进行电学规则检查、生成多种格式要求的电连接网表和多

种报表。本章主要针对 PSpice 模拟仿真的需要，介绍生成电路图过程中与电路模拟相关的问题，包

括设计项目的建立和管理、电路图的绘制和元器件属性参数的编辑修改、软件运行环境参数的设置

等内容。 

2.1  电路图绘制软件 Capture 介绍 

本节简要介绍 Capture 软件的结构、功能特点、调用方法以及电路图的绘制步骤和相关的命令

系统等。 

2.1.1  OrCAD/Capture 软件的构成 

OrCAD中电路图绘制软件分Capture和Capture CIS两个系列。两者的差别只是后者包括 CIS 模
块。按功能划分，Capture CIS 软件的构成如图 2-1 所示。图中还表示了该软件与外部的联系关系。 

 

图 2-1  Capture CIS 软件的构成 

图 2-1 中元器件库（Library）是一个库文件，提供绘制电路图过程中需要的各种元器件符号。

下面简要介绍图 2-1 所示 Capture CIS 软件中 5 个模块的功能。 

1．元器件信息管理模块（CIS） 
CIS 是 Component Information System 的缩写，表示元器件信息管理系统。CIS 模块不但有助于

元器件的使用和库存实施高效管理，而且还具有互联网元器件助理 ICA（Internet Component 
Assistant）功能，可以在设计电路图过程中，通过 Internet 到指定网点提供的元器件数据库中查阅元

器件，从而可以将需要的元器件应用到电路设计中，或添加到 OrCAD 符号库中。本书主要介绍

Capture 软件的相关应用。关于 CIS 所特有的功能参见参考资料[8]和[11]。 
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2. 设计项目管理模块（Project Manager） 
在 OrCAD 软件包中，将一项设计任务当做一个项目（Project），由项目管理器（Project Manager）

对该项目涉及的电路图、模拟要求、相关的图形符号库和模型参数库、有关输出结果等实施组织管

理。同时还处理电路图与 OrCAD 中其他软件之间的接口和数据交换，管理各种设计资源和文件。

在 2.1.4 节将介绍 Project Manager 窗口的结构和功能。 

3. 电路图绘制模块（Page Editor） 
Capture 的基本功能是生成各种类型的电路设计原理图，这一任务是由绘图模块 Page Editor 完

成的。本章后面几节将详细介绍电路图的绘制和编辑修改方法。 

4. 电路设计的后处理工具（Processing Tools） 
对设计好的电路图，Capture CIS 软件中还提供有一系列后处理工具，对电路图中的元器件进行

自动编号、电学设计规则检查、生成各种统计报告以及生成供几十种其他 CAD 软件调用的电连接

网表文件。绘制好电路图后，为了生成满足 PSpice 仿真要求的电连接网表文件，相关的后处理工作

由 PSpice 软件自动完成，无须用户干预。如果在处理过程中发现电路图绘制中存在问题，软件将显

示出错信息。因此，就绘制供 PSpice 模拟需要的电路图而言，用户无须调用后处理工具。Capture
软件中后处理工具的使用方法可参见参考资料[1]和[11]。 

5. 元器件符号编辑和建库模块（Part Editor） 
Capture CIS 软件提供的元器件符号库中包括有 3 万多种常用的元器件符号，供绘制电路图调用。

同时软件中还包括有元器件符号编辑模块 Part Editor，可以对符号库中元器件符号图形进行编辑修

改，或者添加新的元器件图形符号。本教材主要介绍电路模拟软件 PSpice 的使用，调用 Part Editor
编辑修改元器件符号图形的方法可参见参考资料[1]和[11]。 

2.1.2   OrCAD/Capture 软件的功能特点 

OrCAD/Capture CIS 软件的基本功能是进行电路原理图设计，并生成供其他 CAD 软件调用的电

连接网表文件。在完成这些功能方面，该软件具有下述主要特点： 
① 电路图绘制软件 Capture 与电路模拟软件 PSpice 集成在一个软件包中。完成电路设计后，即

可以在同一个运行环境下直接调用 Cadence/PSpice 软件，对电路进行模拟分析。 
② Capture 软件的运行环境是典型的 Windows 图形界面，直观形象，使用方便。在屏幕上可以

同时打开多个窗口，显示同一个项目中不同部分的内容。 
由于 Capture 和 PSpice 都是在 Windows 环境下运行的，其界面结构等也与 Windows 的界面类

似，因此除要求使用 PSpice 的用户应具有一定的电子线路知识外，还要求用户熟悉并掌握 Windows
的使用方法，包括在 Windows 下调用应用程序，了解 Windows 中的文件管理，会操作鼠标，能使

用图标、命令菜单、对话框、帮助文件等。对这些基本操作，本书将不做具体解释。 
③ OrCAD 软件包对电路设计采用项目管理的模式，不但引导电路图的绘制，而且还延伸管理

对电路图的模拟仿真和印制电路板（PCB）设计。与同一个电路设计相关的电路原理图、模拟仿真

和印制电路板设计中采用的参数设置、设计资源、生成的各种文件、分析结果等相关内容均以设计

项目（Project）的形式统一保存，这有助于对设计的有效管理。 
④ 调用 Capture 绘制的各种电路图可以采用单页式（One Page）、拼接式（Flat Design）和分层

式（Hierarchical Design）这三种电路结构形式，符合当前电路和系统设计的潮流。 
⑤ 在绘制电路图时，具有各种方便灵活的绘图和编辑功能，其中包括：对选中的一个或一组电
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路元素进行删除、复制、移动、旋转、镜像等处理，并在移动时保持电连接关系不变；用不同倍率

显示电路图，可以采用多种方式查找电路元素；对绘图操作具有撤销（Undo）、恢复（Redo）和重

复执行（Repeat）等功能。 
⑥ 在电路图中可以绘制起说明作用的多种几何图形、添加文字字符、插入 Bitmap 格式图形（包

括公司标志图形）。 
⑦ 可以采用多种方法修改元器件的属性参数及其显示方式，包括以对话框方式修改单项属性参

数，在属性参数编辑器窗口中以交互方式按类型逐类修改属性参数等。用户还可以为元器件添加由

用户自定义的属性参数。  
⑧ OrCAD/Capture 软件的元器件库文件中包括有 3 万多种常用的元器件符号，同时还包括有元

器件的特性参数模型和封装信息。采用软件中提供的 Part Editor 模块，可以修改库文件中的图形符

号或添加新的元器件。 
⑨ 可以对绘好的电路图进行各种后处理，包括对电路中的元器件自动编号或修改编号、设计规

则检查、元器件属性参数批处理、元器件统计信息报表输出，以及电连接网表文件生成等，供多种

CAD 软件调用。对于与 PSpice 模拟相关的后处理，则由 Capture 自动进行，无须用户干预。 
⑩ 绘好电路图后，可以生成 DXF 格式文件，供 AutoCAD 软件调用。也可以用 EDIF200 格式

与其他软件交换设计结果。 
⑪ 用户可以按语法规定，将经常采用的多步绘图操作编成“宏”（Macro），加速绘图进程。用

户可以对宏进行新建、复制、修改、创建快捷方式等多种处理。 
⑫ 为了保证软件的广泛适用性，软件提供了对不同习惯或标准的支持。例如，尺寸单位可以选

用公制（毫米）或英制（英寸），相应图纸幅面等级也采用两种不同单位制下的规定。 

2.1.3  基本名词术语 

绘制电路图时将涉及许多英文名词术语。如果不明确这些术语的确切含义，将难以顺利完成电

路图的绘制。在这些英文名词中，有些名词含义很清楚，例如 Wire（互连线）、Bus（总线）、Power
（电源）、Part（元器件）、Part Pin（元器件引线）等，无须解释说明。但仍有相当一部分名词术语，

其含义不很直观。其中有些英文术语尚无公认的中文名词。为了叙述方便起见，本书根据这些术语

的基本含义，赋予了相应的中文名称。下面简要介绍部分常用名词术语的含义。每个名词后面括号

中的英文术语是在命令菜单或对话框中出现的相应英文名称。有些专业性很强或者使用范围并不大

的名词术语，将在以后各章节相应部分作出解释。 

1. 与电路设计项目有关的名词术语 
① 设计项目（Project）：与电路设计有关的所有内容组成一个独立的设计项目。设计项目中包

括有电路图设计、配置的元器件库、采用的设计资源、生成的各种结果文件等。存放设计项目的文

件以 opj 为扩展名。 
② 电路图设计（Schematic Design）：指设计项目中的电路图部分。根据所绘电路图的规模和复

杂程度的不同，Capture 绘图软件支持单页电路图、拼接式电路图和分层式电路图这三种结构。整个

电路图设计存放在以 dsn 为扩展名的文件中。 
③ 单页电路图设计（One-page designs）：若所绘电路图规模不大，可将整个电路图绘制在同一

张图纸中，这种电路图称为单页图纸结构。 
④ 拼接式电路图设计（Flat designs）：如果电路图规模较大，可以将整个电路图分为几个部分，

每个部分用一张图纸绘制，各张图纸之间的电连接关系用端口连接器（Off-page connector）表示。
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不同电路图纸上具有相同名称的端口连接器之间在电学上是相连的。 
⑤ 分层式电路图设计（Hierarchical designs）：对较大规模电路的另一种处理方法是采用分层结

构，对应于设计一个复杂系统时通常采用的自上而下的设计方法。采用这种方法时，首先用框图形

式设计出总体结构，存放总体结构图文件的子目录称为根图纸目录（root schematic folder）；然后分

别设计每一个框图代表的电路结构。每一个框图的设计图纸中可能还包括下一层框图……按分层关

系将子电路框图逐级细分，直到最底一层完全为某一个子电路的具体电路图。 
按调用关系的不同，分层电路图结构又细分如下。 

 简单分层式电路设计（Simple hierarchical designs）：不同层次子电路框图内部包含的各种子

电路框图或具体子电路都不相同，即每一个子电路框图或子电路只被调用一次。 
 复合分层式电路设计（Complex hierarchies）：某些层次框图中含有相同的子框图或子电路。

这些相同的部分用一个子电路框图表示，该子电路框图在多处被调用。 
说明：由于本书重点介绍 PSpice 的应用，因此本章只结合单页图纸结构介绍电路图的生成方法。

关于拼接式和分层式设计的电路图生成方法，可参阅参考资料[1]和[10]。 
⑥ 一幅电路图页（Schematic Page）：绘制电路图的一页图纸。 
⑦ 一个层次电路图（Schematic Folder）：指分层式电路图结构中同一个层次上的所有电路图。

一个层次电路图可以包括一幅或多幅电路图页。 
⑧ 电路设计专用元器件符号库（Design Cache）：电路设计中，主要从 Capture 符号库（Library）

调用元器件符号。完成电路设计后，将自动生成一个由该设计中采用的各种元器件符号组成的只适

用于该电路设计的符号库，称为 Design Cache。该符号库与相应的电路设计一起保存。 

2. 关于电路图组成元素的名词术语 
① 电路图基本组成元素（Object）：指绘制电路图过程中通过绘图命令绘制的电路图中的最基

本组成部分，如元器件符号、一段互连线、结点等。 
② 结点（Junction）：在电路图中，如果要求相互交叉的两条互连线在交叉点处电学上连通，则

应在交叉位置绘一个粗圆点，该点称为结点。 
③ 元器件编号（Part Reference）：为了区分电路图上同一类元器件中的不同个体而分别给其编

的序号。例如，不同的电阻编号为 R1、R2 等。 
④ 元器件值（Part Value）：指表征元器件特性的具体数值（如 100Ω）或器件型号（如 7400、

2N2222、μA741）。对每个器件型号，都有一个模型描述其功能和电特性。 
⑤ 端口连接器（Off-page Connector）：指一种表示连接关系的符号。同一层次电路的不同页面

电路图之间以及同一页电路图内部，名称相同的端口连接器在电学上是相连的。 
⑥ 节点别名（Net Alias）：电路中电学上相连的互连线、元器件引出端等构成一个节点（Net），

或者称为网络。用户为节点确定的名称就称为该节点的 Net Alias。 
⑦ 图纸标题栏（Title Block）：描述电路图相关信息的“表格”。 
⑧ 电路元素的属性参数（Property）：指描述电路元素各种信息的参数。其中直接由 OrCAD 软

件赋给的属性参数称为固有参数（Inherent Property），例如元器件值、封装类型等。由用户添加的属

性参数称为用户定义参数（User-defined Property），例如在电路模拟过程中由用户设置的参数。 
⑨ 图幅分区（Grid Reference）：为了便于确定电路元素在电路图中的位置，可以在图纸的 X 和

Y 方向划分几个区，分别用字母和数字作为每个区的代号。图纸中各个位置可以用其所在的字母数

字分区编号表示。 
说明：用通常的 X、Y 坐标值虽然可以比较精确地表示图纸中的位置，但是由于坐标值划分太
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细，有时使用起来并不如采用图幅分区方便。 
⑩ 标签（Bookmark）：用于代表电路图中某个特定位置而在该位置设置的标签代号。代表标签

代号的字符并不显示在电路图上。 

2.1.4  电路图生成的基本步骤 

调用 Capture 软件生成电路图包括下述 8 个步骤。 

1. 调用 Capture 软件 
OrCAD 是一个应用软件包，Capture 是其中的一个软件。因此可以采用 Windows 中应用软件的

调用方法启动 Capture 软件。图 2-2 为 Capture 启动后的窗口。 

 

图 2-2  Capture 启动窗口 

2. 新建设计项目（Project） 
在启动窗口（见图 2-2）中选择执行 File→New→Project 子命令，屏幕上将弹出如图 2-3 所示的

New Project 对话框，在此需进行三项设置。 

 

图 2-3  New Project 对话框 
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① 设定设计项目名称：在 Name 下方的对话框中键入新建的设计项目名称。 
② 选定设计项目类型：图 2-3 中有 4 个选项用于选定该设计项目的类型。本书只介绍对绘制的

电路图如何进行 PSpice 电路模拟，因此应选中 Analog or Mixed A/D。若电路图要用于印制电路板设

计，则应选择 PC Board Wizard。Programmable Logic Wizard 表示电路图将用于 CPLD 或 FPGA 设计。

如果只是绘制一般的电路图，并不专门用于上述几种电路设计，则应选中 Schematic。 
提示：有些情况下在屏幕上出现的 New Project 对话框中默认设置是 Schematic 自动处于选中状

态。如果用户未改选为 Analog or Mixed A/D，则在完成电路图绘制后，命令菜单栏将不会出现 PSpice
命令，用户就无法对电路进行 PSpice 模拟仿真，因为软件认为用户要绘制的只是一般的电路图，没

有进行模拟仿真的要求。 
③ 设置设计项目路径名：图 2-3 的 Location 项用于设置新建设计项目所在的子目录。与常用的

应用软件一样，采用 Browse 按钮可帮助用户尽快确定路径名。 

3. 创建 PSpice 项目方式的选定 
在图 2-3中完成新建项目参数设置后，单击OK按钮，屏幕上即出现如图 2-4所示的Create PSpice 

Project 对话框，供用户选择创建项目的方式。 

 

图 2-4  Create PSpice Project 对话框 

若选中 Create based upon an existing project，再单击其下方选择框右侧的下拉按钮，可以从显示

的下拉列表中选择一个已建项目名称，在该项目基础上创建新的项目，则新建项目就具有选择项目

中的全部内容。 
若选中 Create a blank project，则创建一个空的、全新的项目。 

4. 进入设计项目管理窗口 
完成图 2-4 所示设置后，单击 OK 按钮，屏幕上出现对新建设计项目实施管理的窗口。 
说明：如果要处理一个已有的设计项目，应在图 2-2 所示的 Capture 启动窗口中，选择执行

File→Open→Project，从弹出的 Open Project 对话框中，选择欲打开的设计项目文件名（以 opj 为扩

展名），这时，屏幕上也会出现设计项目管理窗口。图 2-5 就是打开一个 example.opj 设计项目后的

设计项目管理窗口。标题栏中显示的是该项目的名称及其所在的路径。 
图 2-5 中显示的是 File 标签页的内容。若单击图中的 Hierarchy 标签，相应标签页中将列出电路

图中的分层结构关系。 
说明：图 2-5 中列出的设计项目是一个差分对电路，这也是 PSpice 软件本身随带的一个范例。

如果软件安装在 C 盘，则该差分对电路设计项目名称和所在的路径为： 
C:\Cadence\SPB_16.6\tools\pspice\capture_samples\anasim\example.opj 

本章从 2.2 节开始将以该差分对电路图为例，介绍绘制电路图的具体方法。本书第 3 章和第 4 章也

将结合该电路，介绍各种电路特性的分析方法。 
Project Manager 窗口中包含了从绘制电路图直到 PSpice 模拟仿真过程中需要在设计项目管理窗

口处理的相关文件。由图 2-5 可见，项目管理器中包含有三类文件。 
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图 2-5  Project Manager 窗口 

（1）电路设计文件 
项目管理器中 Design Resources 部分包括有与电路图有关的下述三种文件。 
① 电路图文件：生成的电路图存放在以 dsn 为扩展名的文件中。每一张电路图内容对应一页

（PAGE）。Example 电路为单页式电路图，因此只有 PAGE1 一页图纸。双击 PAGE1 图标，可显示该

图纸中电路图的具体结构。 
说明：PAGE1 是软件给电路图纸确定的默认名称，如果有多张图纸，则以 PAGE 后面的数字编

号相区分。用户也可以采用 Windows 系统中修改文件名的方法修改图纸名称。 
② 电路图专用符号库：在绘制电路图的过程中，Capture 软件自动将该电路图中采用的各种元

器件图形符号提取出来，形成该电路图专用的符号库，这就是图 2-5 的 Design Cache 中存放的内容。 
③ 当前配置的图形符号库：Capture 中提供的 3 万多种元器件图形符号存放在 100 多个不同的

图形符号库文件中（以 OLB 为扩展名）。用户进行一个新的设计项目时，需根据电路设计的需求，

确定将要从哪些库中调用元器件符号并预先为该电路设计配置所需的符号库（参见 2.2 节）。图 2-5
的 Library 中存放的就是该电路设计中已配置的符号库文件名及其路径。 

（2）中间结果输出文件 
完成电路图设计以后，可以对电路图进行多种后处理，包括检查电路图中是否存在违反常规连

接关系规则的情况（例如是否在电源和地之间出现了短接，是否有浮置的节点等）、生成电路连接网

表文件等。后处理结果生成的文件存放在图 2-5 中 Outputs 的下方。其中连接网表文件以 net 为扩展

名。如果进行了元器件统计报表生成等其他后处理，生成的输出文件也会在 Outputs 下方列出。 
（3）与 PSpice 运行有关的文件 
图 2-5 中 PSpice Resources 下方是下述与 PSpice 电路模拟有关的几项内容。 
① Include Files：在早期的 PSpice 版本中采用编写 PSpice 输入文件的方式进行电路特性分析。
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PSpice 输入文件中包括电路连接网表描述和对分析要求的指定。在后期的版本中，电路图输入代替

了连接网表，Profile 代替了基本的分析要求指定。为了与早期版本兼容，用户也可以按照 PSpice 规
定的格式描述连接网表和/或分析要求，并将这些要求放在一个以 INC 为扩展名的文件中。Include 
Files 下方列出的是用户为相应电路设计生成的 INC 文件名称。 

② Model Libraries：显示的是针对当前设计项目由用户配置的模型参数库文件名。 
③ Simulation Profiles：PSpice 模拟过程中涉及的一个称为 Simulation Profile 的概念非常重要，

其作用是描述 PSpice 进行电路模拟时要进行的电路特性分析要求和相关参数设置，也就是说，对于

电路进行的每种基本特性分析需要设置一项Profile。关于Profile的概念、功能、设置方法将在3.1节详细介

绍。用户在模拟过程中设置的几项 Profile 就出现在图 2-5 中 Simulation Profiles 的下方。PSpice 运行

时就是根据这些参数设置的要求分析模拟相应的电路特性。第 3 章和第 4 章将详细介绍每种电路特

性分析的作用，以及如何采用 Simulation Profile 设置相应的分析要求和相关参数。 
④ Stimulus Files：电路模拟时施加在输入端的激励信号波形可以采用两种方法，即调用激励信

号源符号设置波形参数，或者采用激励信号编辑模块 StmEd 产生的激励信号波形。若由 StmEd 模块

产生，则激励信号波形存放在以 stl 为扩展名的文件中，这些文件的文件名存放于 Stimulus Files 文
件夹中。 

5. 启动电路图编辑模块 
在设计项目管理窗口中，按内定设置，电路图纸页面的名称是在 PAGE 一词后带有不同数字编

号，单页式图纸则只有 PAGE1 一张图纸，如图 2-5 所示。双击图纸页面名或该名称左侧的图标，均

可调用图纸编辑器（Page Editor）并打开该图纸。 
双击图 2-5 中 PAGE1 名称，显示有相应差分对电路的 Page Editor 窗口，如图 2-6 所示。 

 

图 2-6  绘制有差分对电路的 Page Editor 窗口 
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由图 2-6 可见，Page Editor 窗口是一个典型的 Windows 窗口，包括标题栏、主命令菜单区、工

具栏、工作区、滚动条和状态栏。 
2.1.5 节将介绍 Page Editor 窗口命令系统的功能。 

6. 绘制/编辑修改电路图 
绘制新电路图或者编辑修改已绘制的电路图都是在 Page Editor 窗口中进行的，这也是 Capture

软件中使用最频繁的一个软件模块。本章 2.2 节、2.3 节和 2.4 节将分别介绍在 Page Editor 窗口中绘

制电路图、修改电路图，以及编辑修改元器件属性参数的具体方法。 

7. 电路图的后处理 
绘制好电路图后，在图 2-5 所示项目管理窗口中选择执行 Tools 命令菜单中的有关命令，可对电

路图进行各种后处理，包括元器件自动编号、设计规则检查、统计报表输出和电连接网表生成等。 
由于模拟仿真软件 PSpice 与电路图绘制工具 Page Editor 集成在统一的 Captue 环境下，因此绘

制好电路图后，为了生成满足 PSpice 仿真要求的电连接网表文件等后处理工作由 PSpice 软件自动完

成，无须用户干预。如果在处理过程中发现电路图绘制中存在问题，将给出描述问题的出错信息。

因此，就绘制供 PSpice 模拟需要的电路图而言，用户无须调用后处理工具。 

8. 电路图保存和打印输出 
完成电路图绘制后，选择执行 File 命令中的相关子命令，可以打印输出电路图，也可以将设计

结果保存在文件中。 

2.1.5  Page Editor 窗口结构和 13 条主命令 

如图 2-2、图 2-5 和图 2-6 所示，在不同的 Capture 子窗口中，命令菜单包含的命令各不相同。

本节介绍绘制电路图时将会频繁使用的 Page Editor 窗口中的命令系统。 
Page Editor 窗口中共有 13 条主命令，如图 2-7 所示。 

 

图 2-7  Page Editor 窗口中的 13 条主命令 

需要说明的是，除了调用 PSpice 对电路设计进行模拟之前需要绘制电路图以外，进行可编程器

件分析、完成 PCB 设计等也首先需要采用 Capture 绘制电路图，因此 Capture 软件中不同窗口的命

令菜单包括的命令条目较多，涉及多方面功能。从应用的角度考虑，这些命令中有一部分命令与其

他常用软件工具中的命令名称相同，功能也一样，一般用户均已熟悉它们的使用，因此本书不再重

复介绍。还有一部分命令基本上与调用 PSpice 进行模拟仿真没有关系，因此本书也没有必要展开分

析。本节以分类的方式简要介绍这 13 条主命令的功能，重点说明与调用 PSpice 对电路设计进行模

拟仿真有关的那部分命令的功能，其中在绘制电路图、编辑修改电路图，以及调用 PSpice 进行模拟

仿真中将要频繁使用的命令功能和使用方法将在相关部分进一步详细介绍。 
在绘制电路图过程中，单击鼠标右键，在出现的快捷菜单中将显示出与当前操作相关的命令，

这些命令来自不同主命令的下拉子命令菜单中，因此本书无须再专门介绍各种快捷菜单的内容和  
使用。 
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1. 与常用软件工具中名称相同的 6 条命令 
Page Editor 窗口的 13 条主命令中有 6 条命令是一般常用的软件工具中都具有的命令，因此其名

称完全相同，功能和使用方法也基本一样。但是 Page Editor 窗口中的这 6 条命令还具有一些特殊的   
功能。 

（1）File 主命令菜单 
Page Editor 窗口中的 File 下拉式子命令菜单如图 2-8 所示。其中新建、打开、关闭、打印等功

能与常用软件工具中的相同。需要说明的是下面 4 条子命令。 
① 与电路图中单元存取有关的两条子命令：为提高绘图效率，可以将电路图中的某一单元（又

称为 Block）存入用户建立的符号库。在随后的电路图绘制过程中，可将其调入以减少绘制工作量。

图 2-8 中第三组的两条子命令用于单元电路的存取。 
Import Selection：从存放单元电路的文件中调入需要的单元。 
Export Selection：将电路中选中的单元存入库文件。 
2.3.4 节将详细介绍这两条子命令的使用方法。 
② 与电路图数据格式转换有关的两条子命令：为了与其他电路图绘制软件交换数据，有时需要

转换电路图的数据格式，图 2-8 中第四组内的两条子命令用于电路图数据格式的转换。 
Import Design：将采用 EDIF 和 PDIF 格式的电路图以及 Schematic 绘制的电路图（在版本 8 以

前 PSpice 软件包中采用）转换为 OrCAD/Capture 接受的数据格式。 
Export Design：将 OrCAD/Capture 中绘制的电路图转化为通用的 EDIF 格式，或 AutoCAD 软件

接受的 DXF 格式。 
（2）Edit 主命令菜单 
Page Editor 窗口中的 Edit 下拉式子命令菜单中包含有多达 33 条子命令，在屏幕上都不能同时

全部显示，因此下拉菜单的顶部和底部分别有一个箭头，供用户翻滚查找，如图 2-9 所示。其中复

制、剪切、粘贴、删除、全选、查找、替换、撤销等功能与常用软件工具中的相同。下面需要说明

的是几条与模拟仿真过程密切相关的子命令。 
① Label State：为电路图绘制过程中不同阶段设置标志，从而可以随时按照设置的标志转向某

个阶段的绘制状态。 
② Properties：在电路图中选中一个或多个元器件并执行本条子命令，即调出元器件属性参数编

辑器，可以编辑修改选中元器件的属性参数（详见 2.4 节），这是绘制电路图过程中将会频繁使用的

一条命令。 
③ Part：选中电路图内的一个元器件符号，再选择执行 Part 子命令，即可调出 Part Editor 窗口，

供用户编辑修改该元器件符号以及相关参数[1][11]。一般情况下，如果绘制电路图和模拟仿真过程中

都采用 PSpice 软件提供的元器件库，无须调用 Part Editor。 
④ PSpice Model：在电路图中选中一个元器件后执行本条子命令，将调用 PSpice 软件包中的模

型参数编辑模块 Model Editor，对该元器件的模型参数进行编辑处理[3][5]。第 4 章介绍的蒙特卡罗分

析中将涉及 Model Editor 的调用（参见 4.3 节）。 
⑤ PSpice Stimulus：绘制电路图时，如果信号源符号是从 SOURCSTM 库中调出的，则选中该

信号符号后再执行 PSpice Stimulus 子命令，将调出 PSpice 软件中的 StmEd 模块[9][10]，供用户以人机

交互方式设置输入激励信号的波形。 
⑥ Mirror 和 Rotate 两条子命令分别用于对选中元器件符号作“镜向”和“旋转”处理（参见

2.2.2 节）。Lock 和 UnLock 两条子命令用于对电路图中元器件符号的选中状态进行锁定处理（参见

2.3.1 节）。 
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图 2-8  File 命令菜单                         图 2-9  Edit 命令菜单 

（3）View 主命令菜单 
Page Editor 窗口中 View 主命令的下拉式菜单中共有 23 条子命令，其中除了一部分子命令的功

能与常用软件工具中的相同外，还有一部分适用于元器件符号的编辑修改。下面简要说明与绘制电

路图相关的几条命令。 
① 对于分层式电路设计中包含的多个层次电路图，View 下拉菜单中下述两条子命令用于显示

不同层次电路图。 
Ascend Hierarchy：显示上一层次的电路图。 
Descend Hierarchy：显示下一层次的电路图。 
② Grid 和 Grid References 两条子命令的作用是分别决定在电路图绘制窗口中是否显示坐标网

格点和图幅分区。 
③ Selection Filter 子命令的作用是有选择地确定元器件的选中状态。2.3.1 节将详细介绍这条子

命令及其应用。 
④ 在绘制电路图的过程中可能涉及多页电路图页面，View 下拉菜单中下述两条子命令可以灵

活地在不同页之间切换。 
Previous Page：切换到当前电路页的前一页。 
Next Page：切换到当前电路页的下一页。 
（4）Tools 主命令菜单 
在 Page Editor 窗口中，Tools 命令下拉菜单中主要包括对电路图进行后处理的多条命令，与绘

制电路图相关的子命令是 Customize，其功能是供用户设置工具按钮的配置与显示方式。2.1.6 节将
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具体介绍该命令的使用方法。 
（5）Window 主命令 
Page Editor 窗口中的 Window 主命令包含的子命令与通常 Windows 应用程序中的 Window 命令

菜单基本相同，用于对窗口实施管理。 
（6）Help 主命令菜单 
绘制电路图中，Page Editor 的 Help 主命令与通常应用软件中的 Help 命令基本相同，提供多方

面帮助信息。 
（7）Options 主命令菜单 
OrCAD/Capture 运行过程中有关参数配置是由 Options 主命令菜单中的 4 条子命令完成的。用不

同子命令设置的参数，其影响的范围互不相同。2.6 节将具体介绍这些参数的设置方法。 

2. 在绘制电路图及模拟仿真中频繁使用的两条命令 
（1）Place 主命令菜单 
在 Page Editor 窗口中，电路图的绘制是通过执行 Place 主命令菜单中的各种子命令完成的，因

此这也是在绘制电路图过程中使用最频繁的一条命令。按其功能的不

同，Place 主命令菜单（参见图 2-10）中的 32 条子命令可分为三组。

由于子命令太多，在屏幕上不能同时全部显示，因此 Place 下拉菜单的

顶部和底部分别有一个箭头，供用户翻滚查找。下面简要介绍这些子

命令的功能。从 2.2 节开始，将详细介绍调用其中使用最频繁的几条子

命令绘制、编辑和修改电路图的方法。 
① 图 2-10 中的前 19 条子命令中的 Pin、Pin Array、IEEE Symbol

用于元器件符号的修改，在绘制电路图的过程中基本不会使用。 
② 图 2-10中前 19条子命令中的其他 16条分别用于绘制电路图中

的各种不同元素，包括调用符号库中的图形绘制元器件（Part）、调用

参数化元器件（Parameterized Part）、绘制互连线（Wire）、自动绘制互

连线（Auto Wire）、绘制总线（Bus）、放置互连线电连接结点（Junction）、
绘制总线引入线（Bus Entry）、为节点命名（Net Alias）、绘制电源符号

（Power）和地线（Ground）、绘制端口连接符（Off-Page Connector）、
绘制分层电路图中的框图单元（Hierarchical Block）、绘制分层式电路

框图中的端口连接符（Hierarchical Port）、绘制分层式电路框图中的内

部连接符（Hierarchical Pin）、放置浮置引线标志（No Connect）。其中

大部分子命令的左侧都显示有代表这些子命令的工具按钮。 
提示：对于初次使用 Capture 的用户，只要掌握 Part、Wire、Junction、

Net Alias、Power 和 Ground 这 6 条子命令的使用，就可以绘制基本电

路图。 
③ 第二组包括 Title Block 和 Bookmark 两条子命令，分别用于绘

制图纸标题框和在图纸中设置书签标志。 
④ 第三组的前 9 条子命令用于在电路图中绘制标示符号，包括添

加说明字符串（Text），以及绘制直线段（Line）、矩形（Rectangle）、
椭圆（Ellipse）、圆弧（Arc）、椭圆弧段（Elliptical Arc）、多弯曲线（Bezier 
Curve）、 折线（Polyline），调用 bmp 文件中存放的图片（Picture）。 

 

图 2-10  Place 主命令菜单 
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⑤ Place 下拉菜单中第 31 条子命令 OleObject 的作用是插入来自其他软件的对象。 
⑥ Place 下拉菜单中第 32 条子命令 NetGroup 的作用是设置节点组。 
（2）PSpice 主命令菜单 
绘制电路图的目的之一是进行电路模拟。PSpice 主命令的作用就是在 Page Editor 中绘制好电路

图后直接调用 PSpice AD 以及 PSpice AA 软件对绘制的电路图进行模拟分析，并显示和分析得到的

结果。按作用的不同，图 2-11 所示 PSpice 主命令菜单中的 10 条子命令可分为 4 组。以下简要介绍

这些命令，本书第 3 章、第 4 章和第 6 章将详细介绍如何使用这些子命令进行电路的模拟分析和优

化设计。 
① 第一组包含 5 条子命令，用于电路特性分析。 
New Simulation Profile：新建一个模拟剖面，指定电路特性

分析类型并设置分析参数。 
Edit Simulation Profile：修改已有的模拟剖面，包括修改电

路特性分析要求和参数设置。 
说明：Simulation Profile 是调用 PSpice 进行电路模拟过程

中的一个非常重要的概念，将影响模拟过程能否顺利进行并取

得良好的效果。相关概念和注意事项将在 3.1.2 节详细介绍。 
Run：调用 PSpice AD 软件，进行电路模拟。 
View Simulation Results：调用PSpice 中的Probe 模块，以交互

方式在Probe 图形窗口中显示分析电路模拟的结果（见第 5 章）。 
View Output File：浏览存放在 ASCII 码文本文件中的模拟

结果（见第 5 章）。 
② 第二组包括与电连接网表有关的两条子命令。 
Create Netlist：生成当前电路图的电连接网表文件。 
View Netlist：浏览当前电路图的电连接网表。 
③ 第三组只包含一条子命令 Advanced Analysis，但是其下层子命令菜单中还包含有 7 条子命

令，其作用是对电路进行高级分析，包括灵敏度分析和极端情况分析、蒙特卡罗分析、优化设计、

针对热电应力的可靠性分析、多重参数扫描等功能。第 6 章将详细介绍各种高级分析的功能和使用

方法。 
④ 第四组包含两条子命令。 
Markers：设置电路模拟中的数据采集点。第 5 章将详细介绍其使用方法。 
Bias Point：模拟结束后直接在电路图中直观显示描述直流工作点的节点电压、支路电流、功耗

等信息（参见 3.2.1 节）。 

3. 其他命令 
（1）Design 主命令菜单 
该命令适用于 OrCAD 软件包中各个软件模块，用于新建一个对象。 
（2）SI Analysis 主命令菜单 
该命令用于进行信号完整性（SI, Signal Integrity）分析。 
（3）Macro 主命令菜单 
为了提高绘图效率，OrCAD/Capture 中提供了“宏”（Macro）功能。Macro 主命令菜单包括 3

条子命令，用于对宏的新建、配置以及运行实施管理。 

 

图 2-11  PSpice 主命令菜单 
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如果用户已为当前绘图过程配置了可调用的宏命令，则这些已配置的宏命令也会以子命令的形

式出现在 Macro 命令菜单中。 
对于初学者来说，开始阶段暂时不需要应用该命令。 
（4）Accessories 主命令 
在 OrCAD 软件系统发展的过程中，还开发了一些扩展 Capture 功能的配套软件，如生成特定格

式电连接网表的软件等。如果用户配置了这些软件，它们就将以子命令形式出现在 Accessories 主命

令菜单中。 

2.1.6   Page Editor 工具按钮 

为了方便用户，Capture 软件也配置有多个工具按钮。其中大部分工具按钮都对应于一条常用的

子命令，也有少数工具按钮不是直接对应子命令，而是对应一种参数设置或者操作。将光标移至一

个工具按钮图形上，屏幕上该按钮位置处将出现描述该按钮功能的一串字符。在图 2-6 所示 Page 
Editor 窗口中，与电路图绘制及模拟仿真有关的工具按钮可以分为三组。通过 Tools→Customize 子

命令可以快速查看每组工具按钮的组成，以及每个工具按钮的功能描述，并且还可以由用户自定义

适用于自己习惯和应用特点的工具栏组成。 

1. 与 Capture 软件操作有关的工具按钮 
在 Page Editor 窗口中与 Capture 操作有关的工具按钮一共有 26 个，如图 2-12 所示。 

图中大部分工具按钮是一般应用程序中都有的按钮，

还有一部分工具按钮的作用是对设计项目实施后处理。就

调用 PSpice 进行模拟而言，需要对电路图实施的后处理由

软件自动进行，无须用户执行相关命令。下面仅简要说明

其中几个与 PSpice 模拟过程有关的工具按钮的作用。 
① Place Part：第 10 个工具按钮用于元器件绘制，显

示为下拉列表框形式，称为“最近采用的元器件符号”列

表框。其中列出了最近采用过的元器件符号名称。绘制电

路图时可以直接选用该列表中的元器件符号。 
② 第 15 个工具按钮的名称是 Fisheye view，其作用是

局部放大电路图中选定的元器件，未选定的元器件仍然显示为原来的大小，相当于屏幕上电路图采

用不同倍率显示。 
③ 第 22 个工具按钮的名称是 Snap To grid，其作用是强制使光标只能在坐标网格点上移动。 
④ 第 24 个工具按钮的的名称是 Drag connected object，其作用是拖动连接的对象。 

2. 与绘制电路图操作有关的工具按钮 
图 2-13 显示的是与电路图绘制（Draw）有关的 22 个工具按钮。其中大部分按钮分别对应于     

图 2-10 所示 Place 主命令菜单中的子命令。但是第一个按钮名称是 Select，没有对应的子命令。在

执行 Place 主命令菜单中的任何一条子命令绘制电路图中元素时，只要单击该按钮，立即终止绘制

电路元素状态，光标恢复为选择功能状态。 

3. 与 PSpice 模拟仿真有关的工具按钮 
图 2-14 显示的是与 PSpice 运行有关的 15 个工具按钮。其中大部分按钮分别对应于图 2-11 所示

PSpice 主命令菜单中的子命令。第一个工具按钮的名称是 Active Profile，用于确定当前已设置的仿

图 2-12  最基本的 26 个按钮 
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真剖面中哪一个被选为激活状态。详细功能和使用方法将在第 3 章介绍。 

 

图 2-13  电路图绘制工具按钮 

 

图 2-14  PSpice 工具按钮 

4. 工具栏显示方式的设置 
确定在窗口工具栏中是否显示某一组工具按钮的方法有下述两种。 
① 采用 View 命令：View 下拉子命令菜单中的 Toolbar 子命令下一层次包含有 Capture、Draw、

PSpice 等条目，选择其中一条，使得该条目前出现选中标志√，则该条目对应的工具按钮将出现在

工具栏中。若再次选择该条目，使得该条目前面的选中标志√消失，则对应的工具按钮也就从工具

栏中消失。 

② 采用 Customize 对话框：在 Page Editor 窗口中选择执行 Tools→Customize 子命令，将出现

Customize 对话框，如图 2-15 所示。图中的 Toolbars 标签页显示有 Capture、Draw、PSpice 等条目列

表。通过单击方式，使得一个条目前面出现选中标志√，则该条目对应的工具按钮将出现在工具栏

中。若再次单击，使得选中标志√消失，则对应的工具按钮也就从工具栏中消失。 

5. 工具栏组成的定制 
图 2-15 显示的是 Commands 标签页，描述了工具按钮的分组组成。选择 Categories 下方列表框

中的一项，右侧 Buttons 一栏将列出该组的工具按钮组成。单击一个按钮，图中 Description 下方即

显示出该按钮功能的简要描述。 
图 2-12 到图 2-14 显示的是软件内部对每组工具按钮的配置，仅这三组工具按钮就多达近 70 个。

实际上有些按钮很少使用，例如就调用 PSpice 进行模拟而言，需要对电路图实施的后处理由软件自

动进行，无须用户执行相关命令。为了保持工具栏的简洁实用，用户也可以根据自己的使用习惯， 
采用下述方法，定制工具按钮的配置，在工具栏中只包括最常用的工具按钮。  

首先按照前面说明的方法使得工具栏中不显示整个一组的工具按钮。然后执行 Tools→
Customize 子命令，在出现的 Customize 对话框中选择 Commands 标签页，如图 2-15 所示。在图中

Categories 下方选择要定制的工具按钮类型（图中选择的是 Capture），再在其右侧显示的工具按钮图
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标列表中依次选择需要的工具按钮，并将其拖拉到 Page Editor 窗口的工具栏中，就完成了工具栏按

钮组成的定制。 

 

图 2-15  定制工具栏的组成内容 

2.2  电路图的绘制 

电路图是通过选择执行 Place 命令菜单（见图 2-10）中的有关子命令绘制的。本节在说明绘制

电路图基本步骤的基础上，结合图 2-6 所示差分对电路实例，介绍几种常用电路元素的绘制方法，

以及需要注意的问题。 

2.2.1  绘制电路图的基本步骤 

新建设计项目（见 2.1.4 节）后，要生成一个满足 PSpice 电路模拟要求的电路图通常包括下述 4 步。 

1. 调用 Page Editor 
要生成电路图，首先应在建立电路设计项目后调用 Page Editor（见 2.1.4 节中的图 2-6）。 

2. 绘制电路图 
在 Page Editor 窗口中绘制一个完整的电路图，通常需要绘制以下三部分内容。 
① 绘制元器件符号：实际上是从 OrCAD/Capture 符号库中调用合适的元器件符号，如电阻、

电容、晶体管、电源和接地符号等，并将它们放置在电路图的适当位置。对分层式电路设计，还需

绘制各层次框图。 
② 绘制元器件间的电连接：包括互连线、总线、电连接标识符、节点符号及节点名等。对分层

式电路设计，还需绘制框图端口符。 
③ 绘制电路图中的辅助元素：对于一个完整的电路图，除上述表示电路拓扑结构的元器件及其

连接关系外，有时还需绘制图纸标题栏、在电路图中添加“书签”、绘制特殊符号（如矩形、椭圆等）

以及注释性文字说明。 
本节后面几个小节将具体介绍电路图中几种常用元素的绘制方法。 
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3. 修改电路图 
对绘好的电路图，通常都要根据需要进行修改，如删除电路中无用的元素、改变元器件的放置

位置、修改元器件的属性参数等。在 2.3 节和 2.4 节将详细介绍电路图的编辑、修改方法。 

4. 结果输出 
绘制好的电路图，可存入文件，用打印机、绘图仪打印输出。对于要进行模拟仿真的电路图，

Capture 将自动生成供 PSpice 电路模拟程序使用的电连接网表。 

2.2.2  元器件的绘制（Place→Part） 

在电路图中绘制元器件实际上就是从系统配置的元器件符号库中调出所需的元器件符号，并按

一定的方位放置在电路图中的合适位置。 

1. 绘制元器件的步骤 
（1）调出元器件符号选择框 
在 Page Editor 窗口中执行 Place→Part 子命令，屏幕上弹出图 2-16（a）或者图 2-16（b）所示元

器件符号选择框。 
说明：出现的是图 2-16（a）还是图 2-16（b）对话框取决于运行环境参数设置（见图 2-42）。

按照默认设置，出现的是图 2-16（a）。  
（2）按下述步骤选取所需的元器件符号 
① 选取元器件符号所在的符号库名称。图 2-16 中 Libraries 下方的列表框里显示的是在该设计

项目中已配备的符号库名称清单。单击某一库名称后，该库中的元器件符号将按字母顺序列在其上

方的 Part List（元器件符号列表）框中。 
② 在 Part List 列表框中单击需要调用的元器件符号名称，则该元器件符号名称将出现在图 2-16

上部分的 Part 文本框中，同时在图中的预览框内显示出被选的元器件符号图形。 

 
（a）                                                 （b） 

图 2-16  Place Part 选择框 
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图 2-16 是选取交流小信号电压源 VAC 的情况。 
③ 若所选符号正是要求的元器件符号，单击位于图 2-16 中上方的 （Place Part（Enter））按

钮，该符号即被调至电路图中，并且附着在光标上，随着光标的移动而移动。 
（3）按照下述方式放置元器件符号 
用光标控制元器件符号的移动，到合适位置时单击鼠标左

键，即在该位置放置一个元器件符号。这时继续移动光标，还

可在电路图的其他位置继续放置该元器件符号。 
说明：在放置元器件符号的过程中，还可以执行快捷菜单

（见图 2-17）中的相关子命令，改变元器件符号的放置方位。 
（4）结束元器件的放置 
可以采用下述三种方法之一结束绘制元器件状态。 
方法 1：单击鼠标右键，屏幕上将弹出快捷菜单（见图 2-17）。

选择执行其中的 End Mode 命令即可结束绘制元器件状态。 
方法 2：按 Esc 键。 
方法 3：在绘制元器件符号的过程中，单击 Place 工具按钮

中的 Select 按钮，也可结束元器件的绘制状态。同时，光标恢

复为箭头状，进入选择状态。 
在绘制本节介绍的其他电路元素的过程中，都可以采用上述三种方法结束电路元素的绘制。在

相应部分介绍绘制步骤时，不再全部罗列这三种方法。 

2. 绘制元器件的快捷菜单 
在上述绘制元器件的步骤（3）中，单击鼠标右键，则出现图 2-17 所示快捷菜单。其中前 5 条

是与绘制元器件密切相关的几条子命令。在放置元器件符号之前，用户可以选择执行这几条子命令，

调整元器件符号的放置方位。 
① End Mode：结束绘制元器件状态。 
② Mirror Horizontally：将元器件符号水平翻转，即对 Y 轴作镜向翻转处理。 
③ Mirror Vertically：将元器件符号垂直翻转，即对 X 轴作镜向翻转处理。 
④ Mirror Both：将元器件符号同时对 X 轴和 Y 轴作镜向翻转处理。 
⑤ Rotate：将元器件符号逆时针转 90°，直接按键盘上的 R 键也起同样作用。 

3. 元器件编号 
PSpice 对电路进行模拟分析时，要求电路图中的每一个元器件均有一个与其类别有关的编号，

称为 Part Reference。按 PSpice 的规定，同类元器件的编号都以同一个关键字母开头。如电路中所有

的电阻编号均以 R 开头，后面可以跟不同的数字字母组合（如 R1、R2、Rbias……），这样就可以区

分出电路中的每一个电阻；二极管的编号为 D1、D2……双极晶体管的编号为 Q1、Q2，等等。按照

PSpice 的规定，代表不同类型元器件的关键字母如第 1 章中的表 1-2 所示。 
提示：PSpice 中代表不同类型元器件的关键字母与我国相关标准的规定不完全相同。例如，国

家标准规定，对于所有的有源器件（包括二极管、双极晶体管、MOS 场效应晶体管等），都采用关

键字符 V 表示，而所有的信号源应该采用关键字符 G，等等。如果需要绘制符合国家标准规定的电

路图，可以调用 Capture 软件包中的 Part Editor 软件[1][11]，修改描述元器件类型的关键字符。 
提示：在绘制电路图时，如果希望绘制的每个元器件符号均按绘制次序自动进行编号，应使    

图 2-42 中的 Automatically reference placed parts 选项处于选中状态，这也是系统的默认设置。否则，

 

图 2-17  绘制元器件的快捷菜单 
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在电路图中绘制的每个元器件编号均为其关键字母后面加问号“？”。例如，所有的电阻编号均为

“R？”。在此情况下，进行 PSpice 模拟之前就需要采用 2.4 节介绍的修改元器件属性参数的方法修

改元器件编号，这样做非常烦琐。 

4．Place Part 选择框 
放置在电路图中的元器件符号都是通过图 2-16 所示 Place Part 选择框选定的。前面已介绍了从

中调用元器件符号的基本过程，下面进一步介绍图中涉及的其他几项功能。 
（1）元器件符号显示模式的选择 
某些元器件符号（如数字门电路）有常规表示形式，也可以用其 De Morgan 等效形式表示。     

图 2-16 中的 Normal（常规形式）和 Convert（等效形式）选项用于确定以什么形式显示选中的元器

件符号。若元器件符号只有一种表示形式，则 Convert 项呈灰色显示，不可能被选中。 
（2）同一个封装中的元器件选择 
有时在一个器件封装中可能包含有几个元器件，例如一个数字集成电路 7406 封装内包括有 6

个反相器。按照 PSpice 的规定，为了便于以后进行 PCB 设计时明确哪几个元器件符号实际上是同

一个封装内的元器件，在绘制电路图阶段，同一个封装内的元器件采用相同的 Part Reference，这样

在电路图中调用一个反相器时，除了 Part Reference 外，还采用称为 Designator（在封装中的编号）

的属性参数指定调用的是器件封装中的第几个反相器（用 A、B、C……加以区分）。因此对于这类

元器件，电路中采用 Part Reference 和 Designator 共同描述该元器件符号在电路中的编号。 
（3）调入元器件符号库 
PSpice 软件包含有 100 多个元器件符号库文件。但是在绘制电路图时用户只能采用已列在图

2-16 的 Libraries 列表中的那些库文件中的元器件。如果需要选用的元器件符号所在的符号库尚未列

在图 2-16 符号库列表中，可单击图 2-16 中 Add Library 按钮 ，屏幕上将弹出通常的文件打开对话

框。其中列出了 OrCAD/Capture 中提供的符号库文件清单（以 OLB 为扩展名），如图 2-18 所示。从

中选取需要的库名称，单击“打开”按钮，即将选中的符号库文件添加至图 2-16 的符号库列表中。 

 

图 2-18  添加符号库文件选择框 
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（4）删除库文件 
在图 2-16 的符号库名称列表中选择一个符号库后，单击 Remove Library 按钮 ，即将该库文

件从符号库列表中删去。 
（5）搜寻元器件符号 
如果用户不能确定需调用的元器件符号位于哪个符号库文件中，可单击图 2-16（a）中的 Search 

for Part 按钮或图 2-16（b）中的 part Search 按钮，即出现图 2-19 所示对话。在 Search For 文本框内

键入欲调用的元器件符号名（图中以搜寻双极晶体管 Q2N2222 为例），在 Path 文本框中键入符号库

文件所在的路径名，再单击其右侧的 Part Search 按钮 ，系统即在 Path 右侧显示的路径下查找该

元器件符号所在的库文件并将结果显示在图 2-19 的

Libraries 列表框中。其中，元器件符号名后面用斜杠

将元器件符号与其所在的库文件名分开。选中库文件

名后再单击 Add 按钮，即将该库文件添加至图 2-16
的符号库列表框中。 

图 2-19 的 Path 文本框中指定了搜寻的目录路径，

用户可借用其右侧 Browse 按钮选定合适的路径名。如

果绘制的电路图将用于 PSpice 模拟，OrCAD 软件中

存放元器件符号库文件的默认路径为： 
Cadence\SPB_16.6\Tools\Capture\Library\PSpice 

提示：只有 Cadence\SPB_16.6\Tools\Capture\Library\PSpice 路径下符号库文件中的所有元器件符

号才配置有模型参数描述，采用这些元器件绘制的电路图才能用 PSpice 软件进行模拟。在 Cadence\ 
SPB_16.6\Tools\Capture\Library\路径下还存放有多种元器件符号库文件，但是那些符号库文件中的元

器件未配备有模型参数库，因此对于采用那些库文件中元器件符号绘制的电路图，PSpice 软件无法

进行模拟。 
提示：表征一个元器件是否配置有模型参数描述的标志是，在图 2-16 所示 Place Part 选择框的

元器件符号旁边是否存在图形符号 。 

5. 关于元器件符号库 
OrCAD/Capture 中提供了几万个元器件符号，分别存放在 100 多个符号库文件中。为了正确地

选用所需的元器件符号，应对符号库文件的下述构成特点有所了解。 
（1）商品化的元器件符号库名称特点 
库中绝大部分符号都是已商品化的不同型号半导体器件和集成电路。这类元器件符号库文件的

名称有两类。 
第一类是以元器件的类型为库文件名，反映该文件中存放的元器件类型。例如，以 74 开头的库

文件中是各种 TTL 74 系列数字电路；CD4000 库文件中是各种 CMOS4000 系列电路；OPAMP 库文

件中是各种运算放大器，等等。 
提示：bipolar 库文件中是美国生产的各种型号的双极晶体管；ebipolar 库文件中是欧盟生产的

各种型号的双极晶体管；jbipolar 库文件中是日本生产的各种型号的双极晶体管。 
第二类是在库文件名中包含有公司的名称。例如，以 phil 开头的库文件中是飞利浦公司生产的

半导体器件，库文件名以 MOTOR 开头的则是摩托罗拉公司生产的半导体器件等。 
对商品化的元器件只需按元器件的型号名就可以调用相应的符号。PSpice 模型参数库中同时提

供有这些元器件的模型参数。 

 

图 2-19  Search for Part 对话框 
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（2）常用的非商品化元器件符号库 
如果绘制的电路图要进行PSpice模拟，经常要从下述几种符号库中选用非商品化的元器件符号。 
① ANALOG 库：模拟电路中的各种无源元件，如电阻、电容、电感等，需从 ANALOG 库中

选用合适的元器件符号。 
② BREAKOUT 库：在 PSpice 进行统计模拟分析时，要求电路中某些元器件（包括 R、C 等无

源元件，以及各种半导体器件）参数按一定的规律变化。这些元器件符号应从 BREAKOUT 库中调

用（参见 4.3 节介绍）。 
③ SOURCE 库：无论是模拟电路还是数字电路，调用 PSpice 进行模拟分析时，总要有电压偏

置并要在输入端加激励信号。SOURCE 库中包括的就是各种电压源和电流源符号（见第 3 章介绍）。 
④ SOURCSTM 库：若激励信号源的信号波形是采用 StmEd 模块设置的，则信号源符号应从

SOURCSTM 库中调用。 
⑤ SPECIAL 库：顾名思义，SPECIAL 库中包括的是一些特殊的符号，在进行某些类型电路特

性分析以及在电路分析中进行某些特殊处理时将要采用这些符号。SPECIAL 库中符号的含义及使用

方法将在相应章节中介绍。 
（3）Design Cache 库 
Design Cache 库（见图 2-5）不是 OrCAD/Capture 系统预先提供的符号库，而是在绘制电路图的

过程中自动形成的。该库中存放的是在当前电路图绘制中采用的各种元器件符号，包括曾经用过但

已从电路图上删除的那些符号。 
 通过 Design Cache 库，可以同时替换电路中多个同种类型的元器件。具体方法在 2.3.6 节介绍。 
（4）CAPSYM 库 
在选择执行 Place 主命令菜单的有关命令绘制电源符号（Power）、接地符号（Ground）、电连接

标识符（Off-Page Connector）、分层电路设计中的框图端口（Hierarchical Port）和图纸标题栏（Title 
Block）时，都涉及一个名叫 CAPSYM 的符号库。 

6. 差分对电路绘制实例 
图 2-20 是一个差分对电路实例。第 3 章和第 4 章将结合该电路介绍电路特性的模拟分析和统计

分析方法。 

 

图 2-20  差分对电路实例 

图中双极晶体管 Q1、Q2、Q3 和 Q4 是选择执行 Place→Part 子命令，从 BIPOLAR 符号库中调

用的；电容 CLOAD 和电阻 RBIAS、RC1、RC2、RS1、RS2 是从 ANALOG 库中调用符号 C 和符号
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R 绘制的。刚绘制时，电容 C 的编号为 C1，电容为内定值 1n；5 个电阻的编号分别为 R1、R2、…、

R5，其阻值均为 1k。采用 2.4 节介绍的方法可将它们改为图 2-20 中所示的元器件编号名。图 2-20
的中 V1 是调用 SOURCE 库中 VSIN 符号绘制的；V2 和 V3 是调用 SOURCE 库中 VDC 符号绘制的。

刚绘制时信号源的电压默认值均为 0V，也需要采用 2.4 节介绍的方法进行修改。 

2.2.3  电源与接地符号的绘制（Place→Power 和 Place→Ground） 

1. 两种类型“电源”和“接地”符号 
OrCAD/Capture 符号库中有两类电源符号。一类是 CAPSYM 库中提供的 4 种电源符号，它仅仅

是一种符号，在电路图中只表示该处要连接的是一种电源，本身不具备任何电压值。在电路中具有

相同名称的几个电源符号在电学上是相连的，即使相互之间未采用互连线连接。其所在的节点也以

电源符号名称作为节点名。图 2-20 中 VDD、VEE 都是这种类型的电源符号。 
另一类电源符号是由 SOURCE 库中提供的。这些符号真正代表一种激励电源，通过设置可以给

它们赋予一定的电平值。图 2-20 中 V1、V2 和 V3 均为这类电源符号。按通常习惯，电路中两个直

流电源 VDD 和 VEE 按图 2-20 中所示形式绘制。但如上所述这两个符号仅仅是一种“符号”，不具

有任何电平值。因此，在图 2-20 右下角还需绘制一个附加小电路，表示 VDD 实际连至 V2（+12V），

VEE 连至 V3（-12V）。 
提示：对电路进行 PSpice 模拟仿真时，起激励作用的输入信号源必须是从 Source 库中调用的信

号源。执行 Place→Power 模拟绘制的只是一种表示连接关系的符号，不具有任何电压值。 
“接地”符号的情况同样如此。CAPSYM 库中提供有多种接地符号，其中只有名称为“0”的接

地符号（见图 2-20）才代表电位为 0 的“地”。 

2. “电源”和“接地”符号的选用原则 
① 模拟电路中的直流电压源（或电流源）、交流和瞬态信号源以及数字电路中的输入激励信号

源均应执行 Place→Part 子命令，从 SOURCE 库（或 SOURCSTM 库）中选用。 
② 加于数字电路输入端的高电平信号和低电平信号应执行 Place→Power 子命令，从 SOURCE

库中选用$D_HI 和$D_LO 两种符号。 
③ 调用 PSpice 对模拟电路进行模拟分析时，电路中一定要有一个电位为零的接地点。这种零

电位接地符号必须通过执行 Place→Ground 子命令从 SOURCE 库中选用名称为 0 的符号。图 2-20
中采用了三个这种符号。在电路中这三个“地”符号是电学相连的。 

提示：对电路进行 PSpice 模拟仿真时，电路中必须有名称为 0 的接地符号，作为电位为 0 的参

考点。否则，即使电路图中绘制有接地符号，但是由于是名称不为 0 的接地符号，将导致电路中节

点呈现悬浮状态，PSpice 将无法进行模拟，而是显示出每个节点均为 Floating 的出错信息。 

3. 电源和接地符号的绘制步骤 
电源和接地符号的绘制步骤与元器件的绘制步骤相同，只是在选择执行 Place→Power 或 Place

→Ground 子命令后，屏幕上出现的电源或接地符号选择框如图 2-21 所示。 
图 2-21 中显示的是选择名称为 VCC-CIRCLE 的电源符号情况。其中 Symbol 文本框中为该电源

符号的名称；Name 文本框中是用户为该符号起的名字。图 2-21 中其他项目与 Place Part 选择框类似。

将选中的电源或接地符号放置在电路图中的方法也与放置元器件符号的方法相同，包括快捷菜单也  
一样。 
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图 2-21  Place Power 选择框 

2.2.4  端口连接符号的绘制（Place→Off-Page Connector） 

1. Off-Page Connector 的作用 
① 基本作用：规模较大的电路，可采用拼接式电路图设计方案，即用几张图纸绘制该电路，各

图纸之间的连接关系用 Off-Page Connector（端口连接符）表示。不同电路图纸上具有相同名称的端

口连接符之间在电学上是相连的，这也是这类符号名称的含义。 
② 电连接标识符：在单页式电路图内部，即使未用互连线连接，具有相同名称的 Off-Page 

Connector 在电学上也是相连的，因此可将其作为电连接标识符使用。例如，在图 2-20 中，两个 VDD
电源符号也可以用两个名称均为 VDD 的电连接标识符代替。 

③ 端口标识符：对单页式数字电路，可在输入端和输出端处加上 Off-Page Connector，这样就

可以在 PSpice 进行数字模拟过程中以显示、分析这些端口处的信号变化情况。因此，可将其作为端

口标识符使用。 

2. 端口连接符号的种类 
存放在 CAPSYM.OLB 库中的端口连接符号有两种，其符号名分别为 OFFPAGELEFT-L 和

OFFPAGELEFT-R，如图 2-22 所示。放置到电路图中后，符号名可由用户修改。 

 

图 2-22  两种 OFF-Page Connector 符号 

3. 端口连接符号的绘制步骤 
执行 Place→Off-Page Connector 子命令绘制端口连接符号的步骤与绘制电源和接地符号的步骤

相同。实际上，它们的符号选择框结构、快捷菜单、在电路图中的放置方法等都一样。 

2.2.5  互连线的绘制（Place→Wire） 

在电路图中绘制好各种元器件符号后，就需要绘制互连线，实现不同元器件之间的电连接。下

面介绍绘制互连线的步骤以及需要注意的几个问题。 

1. 绘制互连线的基本步骤 
① 执行 Place→Wire 子命令，进入绘制互连线状态。这时光标形状由箭头变为十字形。 
② 将光标移至待绘制互连线的起始位置处，单击鼠标左键，从该位置开始绘制一段互连线。 
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③ 用鼠标控制光标移动，随着光标的移动，互连线随之出现。 
④ 结束绘制某一段互连线的方法有如下三种。 
方法 1：若该段互连线只是某条互连线中的一段，接下来要从光标当前位置转 90°绘制另一段

互连线，则只需单击鼠标左键，结束当前这段互连线的绘制，同时表示该点为新一段互连线的起点，

然后转向上述第③步。 
方法 2：若该段互连线正好与另一段互连线或元器件的一条引出端相连，单击鼠标左键就结束

该互连线的绘制。这时仍然处于绘制互连线的状态，转向上述第②步，就可以在电路图的其他位置

绘制另一条互连线。 
方法 3：若互连线绘制到某一位置后，并没有与另一段互连线或元器件的一条引出端相连，但

是用户要在电路图中另一个位置开始绘制另一条互连线，则需要连击鼠标左键或从快捷菜单中选择

执行 End Wire 子命令，结束当前这段互连线的绘制。然后转向上述第②步。 
提示：这一步虽然执行了 End Wire 子命令，但只是结束当前这段互连线的绘制，系统仍然处于

绘制互连线的状态，光标仍然为十字形。采用下述步骤⑤才完全结束互连线绘制状态。 
⑤ 采用下述三种方法可结束绘制互连线的状态并使光标恢复为箭头形状。 
方法 1：在绘制互连线过程中，按下 Esc 键即可结束互连线的绘制状态。 
方法 2：在绘制互连线过程中，单击 Place 工具按钮中的 Selection 按钮也可结束互连线绘制状

态并使光标恢复为箭头状，进入选择状态。 
方法 3：在结束了某条互连线的绘制后（即在上述第④步中的方法 2 和方法 3 两种情况下），再

次从快捷菜单中选择执行 End Wire 子命令，即可结束互连线绘制状态。 
说明：在上述第④步的方法 3 中，也包括选择执行快捷菜单中的 End Wire 子命令，但其作用是

结束一条互连线的绘制。应注意这两种情况下执行 End Wire 子命令的区别。 

2. 任意角度走向互连线的绘制 
按前面介绍的步骤绘制的互连线只能 90°转弯。如果在上述绘制步骤③中，先按下 Shift 键，

再用鼠标控制光标的移动，即可绘制任意角度走向的互连线。 

3. 互连线与元器件连接关系的判断 
绘制互连线时，只有互连线端头与元器件引线的端头准确对接，系统才认为它们在电学上连接

在一起。从 OrCAD/Capture 符号库中将元器件符号调至电路图中时，每个引线端头都有个空心方形

的连接区，如图 2-23 所示。绘制的每段互连线在处于选中状态时，其两端则有实心的方形连接区（见

图 2-24 电阻左边交叉的两条互连线）。只有这两个连接区重合时，才表示元器件和互连线在电学上

相连，此时元器件端头的空心方形连接区消失。例如图 2-24 中，电阻右边端头与互连线正好对接，

而左边端头与互连线交迭而不是对接，因此此处在电学上未相连，空心方形连接区仍存在。根据电

路图上元器件引出端处是否出现空心方形连接区，可以判断其电学的连接性。两个元器件的引出端

直接相连时，情况与此相同。 

         

图 2-23  元器件符号引出端的连接区                       图 2-24  连接关系的判断 

提示：绘制互连线时，为了保证互连线端头与元器件引线的端头准确对接，应该在 Options→
Preference 对话框的 Grid Display 参数设置标签页中，将 Connectivity Elements 及 Drawing Elements
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两项设置为 Master，使 Pointer snap to grid 选项处于勾选状态（见图 2-44）。 
说明：如果 Pointer snap to grid 选项未处于勾选状态，则工具栏中的 按钮将显示为红色，起警

示作用。单击该按钮可以使红色消失，相当于使 Pointer snap to grid 选项处于选中状态。 

4. 两条互连线之间连接关系的判断 
两条互连线十字交叉或者丁字形相接时，只有在交点处出现实心圆形的连接结点，才表示这两

条互连线在电学上是相连的。图 2-24 中位于左右两侧的交叉互连线和丁字形互连线就是这种情况，

图 2-24 中间的交叉互连线以及丁字互连线上没有连接结点，表示相应两条互连线在电学上不相连。 
形成连接结点的方法有两种：在绘制互连线的过程中，使十字交叉点或丁字形相接点成为一段

互连线的端头，该位置就会自动出现连接结点；或者按照 2.2.7 节介绍的方法，人为放置电连接结点

Junction。 

2.2.6  互连线的自动绘制（Place→Auto Wire） 

电路图中一般都包含有非常多的互连线，采用上述方法逐条绘制每一条互连线将是一项非常烦

琐的工作。为此 Capture 软件提供有自动绘制互连线的功能，可以在指定点（元器件引出端和/或互

连线）之间自动绘制互连线。按照被连接的是两点还是多点，绘制方法也不一样。 

1. 两点间互连线的自动绘制步骤 
① 选择执行 Place→Auto Wire→Two Points 子命令，进入两点间自动绘制互连线的状态，这时

光标呈现“×”形状； 
② 单击需要连接的第一个元器件引出端和/或互连线，作为自动绘制互连线的起点； 
③ 移动光标，在光标与起点之间就出现一条连线。将光标移动至作为互连线的终点（元器件引

出端和/或互连线），则在起点和终点之间就自动绘制好一条互连线，这时光标仍然呈现“×”形状，

表示还处于在两点间自动绘制互连线的状态； 
④ 如果还需要自动绘制另一条互连线，则转向上述第②步。如果不需要继续自动绘制另一条互

连线，单击选择按钮 ，退出自动绘制互连线状态。 

2. 多点间互连线的自动绘制 
① 选择执行 Place→Auto Wire→Multiple Points 子命令，进入多点间自动绘制互连线的状态，这

时光标呈现“×”形状； 
② 单击需要连接的第一个元器件引出端和/或互连线，作为自动绘制互连线的起点； 
③ 移动光标，单击需要与上述第一点相连的第二点、第三点…… 
④ 在电路图的空白处，单击鼠标右键，在出现的快捷菜单中选择执行 Connect 子命令，则自动

绘制出互连线，将选中的几点连接在一起，同时退出自动绘制互连线状态。 
提示：在 2.2.5 节介绍的手工绘制互连线过程中，需要单击的是引出端的端点。而在自动绘制互

连线过程中确定连接点时，应该单击引出端（而不是端点），使得该引出端四周出现虚线框，表示已

将该引出端选中。如果只是单击端点，引出端未处于选中状态，则不会绘制出与该引出端相连的互

连线。 

2.2.7  电连接结点的绘制（Place→Junction） 

为了表示相互交叉或呈丁字形连接的两条互连线是电连接的，可以在绘制好互连线以后按下述

步骤在交叉点处绘制电连接结点。 
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① 执行 Place→Junction 子命令，光标处出现实心圆点。 
② 移动光标至放置电连接结点处。 
③ 单击鼠标左键，在该处放置一个电连接结点。这时系统仍处于绘制电连接结点状态，转向上

述第②步可以继续在电路的其他位置放置电连接结点。 
在绘制电连接结点的状态下，如果将带有实心圆点的光标移至一个电连接结点处并单击鼠标左

键，则该位置原有的电连接结点将被删除。这实际上提供了一种删除电连接结点的方法。 
说明：采用 2.6 节介绍的运行环境参数设置方法（参见图 2-42），可以设置电连接结点的大

小，即 Small、Medium、Large 或 Very Large。 

2.2.8  节点名的设置（Place→Net Alias） 

1. 节点名 
电路中电学上相连的互连线、总线、元器件引出端等构成一个节点。OrCAD/Capture 自动为每

个节点确定一个节点名。其默认格式是以字母 N 开头，后面紧跟数字编号，形式为 N××…×。如

果与一个节点相连的符号中有电源（Power）或接地（Ground）符号，或者有端口连接符号（Off-Page 
Connector），则以这些符号的名称作为该节点的名称。 

在 OrCAD/Capture 中节点名有下述作用： 
① 通过节点名描述电路中各个元器件之间的连接关系，生成电连接网表文件。 
② 电路中不同位置的节点，即使未用互连线连接，只要它们的节点名相同就表示在电学上是相

连的。 
③ PSpice 电路模拟结束后，采用节点名表示电路特性分析的结果（见第 5 章）。 

2. 节点名的设置 
上面介绍了节点名的几种描述形式。如果有某种需要，可自行设置接点名。下面以图 2-20 所示

差分对电路为例说明设置方法。图 2-20 中 Q4 管的集电极为输出端之一，若要将其节点名取为 Out2，
可按下述步骤进行： 

① 执行 Place→Net Alias 子命令，屏幕上将出现图 2-25 所示设置框。 

 

图 2-25  Place Net Alias 设置框 

② 在 Alias 文本框中键入节点名（本例中为 Out）。图 2-25 中另外三栏分别设置节点名采用的

颜色（Color）、字体（Font）和放置方位（Rotation）。 
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为了醒目起见，键入的节点名可采用首字母大写的形式。接点名按照键入时的形式显示，但在

实际应用中 PSpice 软件不考虑大小写字母的区别。 
NetGroup 用于设置网络节点分组组合。 
③ 完成图 2-25 中各项设置后，按 OK 按钮，则电路图中光标箭头处附着一个代表节点名的小

矩形框。 
④ 将光标移动至放置节点名的位置，单击鼠标左键，即可将新的节点名设置于该位置。设置完

成后，新的节点名代替了系统自动形成的 N×…×形式节点名。 
提示：在电路模拟过程中，对于关心其仿真结果的节点，例如输出端节点，采用本节介绍的方

法设置一个节点别名，在调用 Probe 模块查看该节点的信号波形时将非常方便。 
提示：放置节点名时，光标箭头一定要指在欲设置节点名的互连线上，否则将放置不上节点名。 
⑤ 按 Esc 键或者执行快捷菜单中的 End Mode 按钮，结束节点名设置。 

2.2.9  引出端开路符号的绘制（Place→No Connect） 

1.  No Connect 符号的作用 
绘好电路图进行 PSpice 模拟仿真之前，软件内部将自动进行设计规则检查。若发现电路图上存

在元器件引出端为浮置的情况，即某个引出端未与电路中其他元器件相连，系统将发出警告信息，

提醒用户注意，同时中断软件运行，也就是说，PSpice 将不会继续进行模拟仿真过程。但有时根据

电路设计需要，某些引出端确实应该处于浮置状态。在这种情况下，只要在该引出端处放置一个 No 
Connect 符号，对电路进行设计规则检查时，即认为该引出端的浮置为正常情况，不再发出警告信息。 

2. 绘制 No Connect 符号的步骤 
① 选择执行 Place→No Connect 命令，光标处出现代表引出端开路符号的交叉线图形。 
② 移动光标至欲放置开路符号的引出端处。 
③ 单击鼠标左键，在该处放置一个引出端开路符号。这时系统仍处于绘制 No Connect 符号状

态，转向上述第②步可以继续在电路的其他位置放置 No Connect 符号。 
在绘制 No Connect 的状态下，如果将带有交叉线的光标移至一个已放置有 No Connect 符号的

位置并单击鼠标左键，则该位置原有的 No Connect 符号将被删除。这实际上是删除 No Connect 符
号的唯一方法。 

2.3  电路图的编辑修改 

绘制完一个电路图后，往往还要根据实际情况，对已绘制的电路图进行移动、删除、复制，以

及编辑修改元器件的属性参数。本节介绍基本的编辑修改操作。属性参数的编辑修改方法将在 2.4 节  
介绍。 

2.3.1  电路图组成元素的选中 

为了对电路图进行编辑修改，首先需要使待编辑修改的对象处于选中状态。 

1. 选择按钮与电路元素的选中状态 
按照 2.2 节介绍的方法绘制的元器件、互连线、接地符号等统称为电路图中的基本组成元素，

简称为元素（Object）。编辑修改电路图，实际上就对电路元素进行编辑修改。 
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在 Page Editor 窗口中，光标起着绘制电路元素和选择电路元素两种作用。如果单击工具按钮栏

中的 Selection 按钮 ，则光标成为箭头状态，表示光标在起着选择电路元素的作用。在正常结束一

个电路元素的绘制时，光标也会自动转为箭头形状，表示处于选择状态。在绘制电路元素过程中，

只要单击 Select 按钮，光标就立即呈现箭头状态，表示已中断并退出绘制电路元素状态。 
被选中的电路元素将以特定的颜色显示，以区别于未被选中的元素。系统的默认设置颜色为粉

红色。 

2. 选中单个电路元素 
用鼠标左键单击某个电路组成元素，就使其处于选中状态。将光标移至某个电路组成元素处，

按空格键，也可以使该元素处于选中状态。 
如果一条互连线中包括有几段，每次单击只选中其中的一段。对于包括有几个组成部分的电路

元素，可以用单击的方法选中其中一个部分。例如，对一个双极晶体管，可以选中整个晶体管符号

（在该符号范围内单击），也可以只选中该晶体管的器件编号、器件型号、发射极引线、基极引线或

集电极引线这 5 个组成部分中的某个（单击相应部分）。 
如果几个电路元素重叠在一起，例如带有电连接结点的两条交叉互连线，结点位置同时是与之

相连的 4 段互连线的一个端点。这时，只需按下 Tab 键，再用鼠标左键单击电连接结点，将依次使

这 4 段互连线处于选中状态。 

3. 选中多个电路元素 
按下 Ctrl 键后再依次单击需要选中的电路元素，就可以使多个元素均处于选中状态。 

4. 通过搜寻选中电路组成元素 
在一个规模较大、电路组成比较复杂的电路中，用户可以选择执行 Edit→Find 命令，通过指定

电路元素属性参数的方式，查找设计项目中或者一页电路图中具有指定属性参数的一个或多个电路

元素，并使被查找到的元素同时处于选中状态。在指定属性参数名时，可以使用通配符“*”和“?”。 

5. 选中与一个节点相连的全部互连线 
选中一段互连线后，再从快捷菜单中选择执行 Select Entire Net，则在电学上与该节点相连的所

有互连线均被选中。 

6. 选中一个区域内的所有元素 
将光标移至某一位置后按下鼠标左键，然后在保持鼠标左键按下的同时拖动光标，就会出现一

个以按下鼠标左键时的位置为起始顶点、光标当前位置为对角顶点的矩形。当矩形大小符合要求时，

松开鼠标，则位于矩形框线内的所有电路元素均处于选中状态。 
Capture运行环境配置中Select标签页的设置可确定只有完全处于矩形框线内的电路元素才被选

中或者是与框线相交的电路元素也同时被选中（参见图 2-46）。 
选中一个区域的元素后，按下 Ctrl 键，再按上述方法选取其他区域，可使多个区域内的电路元

素同时处于选中状态。 
当然，采用本方法也可以选中一个电路元素。对包含多个组成部分的电路元素，例如前面提到

的双极晶体管，采用拖动鼠标的方法可以很方便地选中整个电路元素。 

7. 选中一页电路图纸中的全部元素 
选择执行 Edit→Select All 子命令，可使当前页电路图中的所有组成元素均被选中。 
需要注意的是，执行此命令后，电路图中的标题栏也被选中。如果对选中的电路元素进行处理
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时（如旋转、复制），标题栏也同样要受到处理，这可能是不希望的。 

8. 选择中的 Selection Filter 
采用上述第 6 条和第 7 条介绍的方法选择一个范围内的电路元素时，可以采用下述方法，设置

Selection Filter 参数，使得该范围内部分类型电路元素被选中。 
① 选择执行 View→Selection Filter 子命令，屏幕上将出现  

图 2-26 所示 Selection Filter 设置框。 
② 按照需要，使相关条目左侧勾选框内出现选中标志√，则

在选择一个区域范围内的元素时，该区域范围内未出现选中标志

√的那些条目对应的元素将不会被选中。 

9. 特殊的选中状态——锁定（Lock） 
① 锁定元素的特点：Capture 软件提供了一种对电路图元素

进行锁定的功能。对于锁定的元素，锁定的只是与该元素图形显

示有关的特性。例如，若锁定一个元器件符号，则不能对该符号

进行与图形显示有关的删除、移动等操作。但是可以进行复制操

作，也可以修改其属性参数。 
② 锁定电路元素的方法：选中一个或者多个电路元素后，选

择执行 Edit→Lock 子命令，或者执行快捷中的 Lock 命令，则被选

中的电路元素即处于锁定状态。 
为了区分电路元素是否处于锁定状态，被锁定的电路元素被

选中后，显示选中状态的虚线框采用的颜色与未被锁定的电路元

素不同。 
选中一个或多个被锁定的电路元素后，选择执行 Edit→Unlock

子命令，或者执行快捷中的 Unlock 命令，则被锁定的电路元素将脱离锁定状态。 

2.3.2  电路元素选中状态的去除 

如果需要，也可以使处于选中状态的电路元素脱离选中状态。 

1. 全部选中状态的去除 
用鼠标左键单击电路图上未绘制电路元素的空白位置，将使电路图中所有被选中的电路元素脱

离选中状态。 

2. 从一组选中的电路元素中去除个别元素的选中状态 
若电路图中已有一组元素处于选中状态，按下 Ctrl 键再单击其中某一个元素，将使该元素脱离

选中状态。 

2.3.3  电路元素的移动（Moving Objects） 

在电路图中可以采用下述几种方法移动被选中的电路元素。 

1．电路元素的拖动——保持连接关系不变 
可用鼠标左键拖动的方法，将选中的一个或多个电路元素拖动到新的位置。采用这种拖动方法

时，移动的电路元素与电路中其他部分相连的互连线和总线会随之伸长或压缩，以保证电路的连接

 

图 2-26  Selection Filter 设置框
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关系保持不变，这又称之为“橡皮筋”功能。 
如果一个电路元素包括几个组成部分，可以用上述方法移动该元素中某个组成部分。例如，可

以采用本方法分别改变电路图中一个双极晶体管的元器件编号和器件型号这两项内容的放置位置。 

2. 按照一定角度拖动互连线——保持连接关系不变 
按照上述方法拖动一段互连线时，只能使其沿着水平或者垂直的方向移动。如果选中一段互连

线后，在按下 Shift 键的同时，用鼠标拖动该互连线段的一个端头，则可以沿任意方向拖动互连线。 

3. 电路元素的单独移动 
如果先按下 Alt 键，再采用拖动的方法，移动的只是被选中的电路元素本身，电路中原先与该

元素相连的互连线不随之发生任何变化。显然这时电路的连接关系将发生变化。 

4. 通过剪贴板移动电路元素 
Edit 子命令菜单中 Cut、Copy、Paste 等子命令的功能与通常 Windows 应用程序中的同名命令一

样，可用于元素的剪切、复制和粘贴处理。 
采用这几条命令也可以将被选中的电路元素移至其他电路设计图，甚至其他的 Windows 应用程

序中。 

5. 电路元素放置方位的改变 
改变电路图中电路元素的放置方位是一种特殊的移动操作。选中电路元素后，执行快捷菜单中

的 Mirror Horizontally、Mirror Vertically 或 Rotate 子命令，可以使选中的电路元素符号对 Y 轴作镜向

翻转、对 X 轴作镜向翻转，或者是逆时针转 90°（直接 R 键也可进行此旋转）。Edit 主命令菜单中的

Rotate 和 Mirror（及其下一层次的三条子命令 Horizontally、Vertically、Both）也起同样的旋转和镜

向翻转作用。 
有些电路元素或其中的组成部分不能进行上述改变方位的操作。例如元器件符号中的器件编号

或器件值只能进行旋转，不允许进行镜向翻转（否则字符就被“反”过来了）。图纸标题栏不得进行

旋转和翻转。在这种情况下快捷菜单中将不出现相应的子命令。Edit 命令菜单中的相应子命令亦呈

灰色显示，不能执行。 

2.3.4  电路元素的复制（Copying Objects） 

在电路图的绘制过程中，可以采用复制已绘电路元素的方法加快绘制速度。 

1. 使用鼠标进行复制 
选中一个或多个电路元素后，按下 Ctrl 键，再用鼠标左键将选中的电路元素拖动到希望的位置，

此时松开 Ctrl 键和鼠标左键，即将选中的电路元素复制在当前光标位置。如果不按下 Ctrl 键，则拖

动的结果是移动电路元素，且保持连接关系不变。 

2. 通过剪贴板复制电路元素 
这一方法与 2.3.3 节中介绍的通过剪贴板移动电路元素的步骤基本一样，唯一区别是应在选中电

路元素后，执行 Edit→Copy 子命令，将被选中的电路元素复制到剪贴板上。而移动操作时，则是执

行 Edit→Cut 子命令，将被选中电路元素移至剪贴板上。 
说明：执行 Edit→Copy 子命令，将被选中的电路元素复制到剪贴板上以后，也可以将其粘贴到

其他 Windows 应用程序中（如 Word 中）。 
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3. 通过外部文件复制一个电路单元 
如果电路中某一部分是一个基本电路单元，以后可能多次复制使用，可以首先将这部分电路作

为元器件符号存入为以 OLB 为扩展名的库文件，在需要的时候（包括绘制其他电路图时），再调用

已存放在库文件中的电路单元。 
（1）将电路单元存入库文件的步骤 
① 选中需要存放的电路单元，执行 File→Export Selection 子命令，屏幕上将弹出如图 2-27 所示

设置框。 

 

图 2-27  Export Selection 设置框 

② 在 Export Selection Name 文本框中键入为该电路单元设置的名称。图中取为 DifPair，表示这

是一个差分对单元。 
③ 在 Library 文本框中键入存放上述单元电路的库文件名称，包括完整路径。用户可按 Browse

按钮，借助屏幕上弹出的 Browse File 对话框确定库文件名及其路径。 
④ 完成上述设置后按 OK 按钮，选中的电路单元即以指定的名称存入指定的库文件中。 
（2）调用存入库文件中电路单元的步骤 
选择执行 File→Import Selection 子命令，屏幕上即出现图 2-28 所示的 Import Selection 选

择框。 
显然，图 2-28 与 Place Power 选择框（见图 2-21）基本相同，从中选定所需符号并放于电路图

上的步骤也一样（见 2.2.3 节介绍）。 

 

图 2-28  Import Selection 选择框 

2.3.5  电路元素的删除 

删除电路元素的操作比较简单。选中待删除的一个或多个电路元素后，采用下面几种方法均可

将选中的电路元素删除：按 Delete 的键；按 Backspace 键；从快捷菜单中执行 Delete 命令；执行 Edit
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→Delete 子命令。 

2.3.6  电路中元器件的替换和更新（Replace Cache 和 Update Cache） 

1. 替换电路设计中元器件的方法  
如果需要将电路中的部分元器件用另外的元器件来替换，可以采用上面 2.3.5 节介绍的方法，先

删除原来的元器件，然后再按照 2.2.2 节介绍的方法放置用来替换的元器件。显然这是一项烦琐的工

作，特别是在电路中采用的多个同一种类型的元器件都需要替换的情况下，工作量很大。针对这一

问题，采用 Replace Cache 命令可以通过很简单的操作，就可以用一种新器件替换电路中原来采用的

同一种类型的所有元器件。 

2. 同时替换电路设计中所有同一型号元器件的步骤  
① 图 2-5 所示 Project Manager 窗口中，展开 Design Cache，从中选中需要被替换的元器件。如

选中需要被替换的是 Q2N2222。 
② 在Design下拉子命令菜单中, 选择执行Replace Cache命令，屏幕上出现图 2-29所示设置框。 
在 Existing Part Name 后面显示的是被选中需要被替换的器件名称 Q2N2222。 
③ 在 New Part Name 文本框中键入用来替换的器件名称。本例中设置为 Q2N2219。 
在 Part Library 文本框中键入用来替换的器件所在的符号库文件名称和所在路径。 
说明：如果不能确切地填写上述两栏内容，可以先单击 Browse 按钮，在出现的对话框中查找、

选中用来替换的器件所在的符号库文件名称和所在路径。然后单击 New Part Name 文本框右侧下拉

按钮，从列表中显示的库文件元器件清单中选中用来替换的器件名称。 
④ 如果要完全替换元器件符号及其属性参数（参见 2.4 节），则勾选 Replace schematic part 

properties；如果要保存绘制电路图过程中已经为不同元器件编辑修改的属性参数，则采用默认选项

Preserve schematic part properties。 

 

图 2-29  Replace Cache 设置框 

⑤ 单击 OK 按钮，完成元器件的替换。按照图 2-29 设置，电路中所有 Q2N2222 晶体管都被替

换为 Q2N2219。 

3. 同时更新电路设计中所有同一型号元器件的步骤 
如果电路中原来采用的元器件型号后来通过 Part Editor 软件模块进行了修改，元器件型号名称

未发生变化，采用下述步骤就可以用修改后的元器件符号更新电路设计中所有同一型号元器件。 
① 在图 2-5 所示 Project Manager 窗口中，展开 Design Cache，从中选中需要被替换的元器件。 
② 在 Design 下拉子命令菜单中, 选择执行 Update Cache 命令，再确认屏幕上出现的提示信息。 
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2.3.7 “操作”的撤销、恢复和重复执行（Undo、Redo 和 Repeat） 

Capture 中不但可以对绘制的电路图进行编辑修改处理，而且可以实现对绘图“操作”的撤销、

恢复和重复执行。 

1.“操作”的撤销（Undo） 
选择执行 Edit→Undo 子命令，可以撤销刚执行的一次操作，恢复操作前的状态。Undo 子命令

的全称与刚执行过的操作有关。例如，若刚进行了 Rotate（旋转）操作，则子命令成为 Undo Rotate。 

2.“操作”的恢复（Redo） 
如果在执行 Edit→Undo 子命令撤销了刚执行的操作后，用户又改变了主意，认为还是应该执行

被撤销的操作，只需选择执行 Edit→Redo 子命令，即可恢复进行刚被撤销的操作。与 Undo 情况一

样， Redo 命令的全称与可恢复的操作类型有关。例如，若刚执行了 Undo Rotate 子命令，则 Redo
子命令的全称就是 Redo Rotate。 

3.“操作”的重复执行（Repeat） 
选择该子命令将重复执行对选中元素刚刚进行的操作。与前两条命令一样，Repeat 子命令的全

称与可重复执行的操作类型有关。 

2.4  电路元素属性参数的编辑修改 

电路元素的属性参数对随后的 PSpice 电路模拟能否顺利进行有很大的影响，在各个电路元素的

编辑修改操作中，属性参数的修改也相对复杂一些。本节在介绍属性参数概念的基础上重点介绍几

种基本电路元素属性参数的编辑修改方法。 

2.4.1  属性参数与属性参数编辑器 

1. 电路元素的属性参数 
电路图中的每一个组成元素都有相应的属性参数，这些属性参数描述了与该电路元素有关的各

种信息。 
① 固有参数（Inherent Properties）：元素的属性参数中，有一部分是 OrCAD/Capture 运行时必

须要有的参数。例如，对于元器件，在 Capture 运行时必须要知道其 Part Reference（器件编号）、Value
（元器件值），以及这些参数在电路图中显示时采用的颜色、字体、方位等，这类参数称之为固有参

数。用户可以修改部分固有参数的设置值，但不能删除固有参数。 
② 用户定义参数（User-defined Properties）：在调用其他软件或模块对绘制好的电路图进行处理

时，往往需要给电路元素添加一部分参数。例如，在调用 PSpice 对电路进行参数扫描分析时（见 4.2 节），

对 PARAM 元素符号要添加用户定义参数。 
③ 参数名和参数值：不同电路元素具有的属性参数类别各不相同，但每项属性参数均用参数名

（Name）及参数设置值（Value）来表示。这里，参数设置值（Value）具有广义的概念，不一定是具

体的数值。例如，对于一个电阻，其元器件编号的参数名为 Reference，该参数的值是电阻在电路中

的编号，可能为 RS1；而电阻值的参数名为 Value，其值为该电阻的阻值，可能为 10k。对于有具体

型号的商品化元器件，例如图 2-20 所示差分对电路中的 Q2N2222 晶体管，其元器件值即为该产品

型号本身。当然，数据库中还有一组相应的模型参数描述该器件的特性。 
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说明：从 PSpice 9 版本开始，属性参数名称采用的字符不再区分大小写。 
由于 OrCAD 软件包中的 CPLD/FPGA、PCB 和 PSpice 这几种不同的 CAD 软件都采用 Capture

生成电路图，因此 Capture 为每个电路元素设置有多种属性参数，不同参数适应于 OrCAD 软件包中

的不同软件。本节只介绍其中与 PSpice 电路模拟有关的属性参数及其编辑修改方法。 
另外，在设计项目管理窗口、元器件符号编辑窗口以及电路图编辑窗口（Page Editor）中均可

以修改电路元素的属性参数。本节只介绍其中最基本的一种方法，即在 Page Editor 中修改属性参数。 

2. 属性参数编辑器的启动 
对于元器件、节点、元器件引线和图纸标题栏这 4 类电路元素，其属性参数的编辑、修改工作

是在属性参数编辑器下进行的。调用属性参数编辑器的方法有下述三种。 
方法 1：选中一个或多个电路元素后，从快捷菜单中选择执行 Edit Properties 子命令； 
方法 2：选中一个或多个元素后，选择执行 Edit→Properties 子命令； 
方法 3：双击待修改其参数的电路元素。 
有些电路元素在编辑修改其属性参数时，不是采用属性参数编辑器，而是通过一个对话框（见

图 2-34），但打开这些对话框的方法也同样是上述三种。 

3. 属性参数编辑器的基本结构 
启动属性参数编辑器（Property Editor）后，出现的界面如图 2-30 所示。 
由图 2-30 可见，属性参数编辑器由编辑命令按钮、参数过滤器（Filter）、电路元素类型选择标

签和属性参数编辑工作区 4 部分组成。 
（1）编辑命令按钮 
位于编辑器左上方的编辑命令按钮有 4 个，其功能如下。 
New Property：单击此按钮打开新增属性参数对话框，用于为选中的元素新增一个用户定义参数。

4.2 节将结合 PSpice 参数扫描实例，介绍新增自定义属性参数的方法。 

 

图 2-30  属性参数编辑器窗口 

Apply：编辑修改属性参数后，单击此按钮更新电路图中该电路元素的属性参数。 
Display：选中电路元素的一项属性参数后，单击此按钮打开显示属性参数设置对话框，此对话

框用于设置属性参数的显示方式（参见图 2-34）。 
Delete Property：删除选中的属性参数。 
Pivot：改变属性参数编辑器的显示方式（参见图 2-31）。 
（2）参数过滤器（Filter） 
由于 Capture 绘制的电路图要同时考虑到多种软件的需要，因此为每一种电路元素设置的属性
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参数很多。为了针对不同软件的需要有选择地显示的参数，图 2-30 中提供了参数过滤器（Filter）。
从 Filter 文本框右侧下拉式列表中选择某一类型后，参数编辑器中将只显示出电路元素中与之相关

的参数。若选择 Current Properties，则显示电路中所有元素所涉及的全部属性参数。对 PSpice 电路

模拟而言，一般选择 Orcad-PSpice，如图 2-30 所示。 
（3）电路元素类型选择标签 
属性参数编辑器用于编辑修改元器件（Parts）、节点（Schematic Nets、Flat Nets）、元器件引线

（Pins）、图纸标题栏（Title Blocks）、全局参数（Globals）、端口（Ports）、节点别名（Aliases）等几

类电路元素的属性参数。调用属性参数编辑器之前选中的电路元素可以包括有多种类型。进行属性

参数的编辑修改时可使用这些标签来选定当前要编辑修改的是哪一类电路元素的属性参数。修改好

一类电路元素参数后，按 Apply 按钮更新电路图中的参数。然后按另一个元素类别标签，继续修改

参数。按 Apply 按钮，只是更新已修改的参数并不关闭参数编辑器窗口。完成需要修改的各类元素

参数后，按窗口右上方“关闭”按钮，参数编辑器窗口才被关闭。 
（4）属性参数编辑工作区 
图 2-30 中以表格形式显示的是参数编辑区。其中最上面一行为参数名（Name）标题行。该标

题行中显示的参数名个数与电路元素类型有关，也与 Filter 选项有关。参数编辑区的每一行对应一

个电路元素，最左边一格是该电路元素的编号名称及其所在的电路设计名和电路图纸名。其右边各

个单元格内分别是该电路元素不同属性参数的参数值（Value）。用户可根据需要修改这些参数值。

不允许用户修改的参数值以斜体表示。 

4. 属性参数编辑器显示方式的改变 
（1）属性参数编辑工作区显示方式的改变 
图 2-30 显示的参数编辑工作区中，每一行描述一个电路元素的多个属性参数。如果属性参数个

数较多，需要采用滚动条查看不同的属性参数，使用不太方便。如果在属性参数编辑器中单击 Pivot
按钮，则参数编辑工作区将改变显示方式，第一列为属性参数名称，每一列显示一个电路元素的所

有属性参数，如图 2-31 所示。 

 

图 2-31  属性参数编辑器工作区的另一种显示模式 

如果在图 2-31 中再次单击 Pivot 按钮，则属性参数编辑器工作区的显示方式又变成图 2-30 所示

情况。 
（2）属性参数值升降顺序的修改 
在图 2-30 显示的参数编辑工作区中，单击属性参数名所在的单元，选中该参数名所在的列，再

单击鼠标右键，从出现的快捷菜单中选择执行 Sort Ascending（或者 Sort Descending）子命令，就按

照上升（或者下降）的顺序更新排列顺序。 
说明：双击属性参数名所在的单元也能改变上升（或者下降）的排列顺序。 
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2.4.2  修改参数值的途径之一：文本编辑方法 

在参数编辑器中修改属性参数值的操作方法有三种。其中使用最多的是文本编辑方法。 
注意：以斜体字符表示的参数值是不可修改的。 

1．文本编辑方法 
对元器件的 Value 和 Reference 这类参数，采用通常的文本编辑方法即可修改其参数值。修改时，

首先用光标选中该参数值所在的单元格，用 Delete 键或 Backspace 键删去不要的字符，键入新参数

值后按回车键即可。 
选中单元格后，图 2-30 中位于编辑命令按钮下方的文本框中就显示有该单元格中显示的内容，

供用户修改。 

2．同时修改多个电路元素的同一种属性参数值的步骤 
① 在图 2-30 显示的参数编辑工作区中，按下 Ctrl 键，再用左键单击第一列相关单元格，选中

相应的元素。 
② 单击右键，从快捷菜单中选择 Edit，将出现图 2-32 所示对话框。 

 

图 2-32  同时修改多个元素的同一种属性参数 

在相关的属性参数名下方的单元格中进入数值。如果选中的是几个电阻，并且需要将这几个电

阻的阻值均修改为 10k，则在 Value 下方单元格键入 10k，如图 2-32 所示。 
③ 单击 OK 按钮，则选中的几个电阻的阻值就全部修改为 10k。 

2.4.3  修改参数值的途径之二：从下拉式列表中选取 

简单数字电路的一个器件封装中包括有多个单元电路。以 7400 与非门电路为例，一个器件封装

中包括 4 个 7400 门电路。因此 7400 电路有一个名称为 Designator 的参数（参见图 2-33），其作用是

指定选中的这个 7400 电路是器件封装中的第几个门。在用光标选中该参数值的单元格后，该格右方

出现下拉式按钮，在相应的下拉式列表中列出了 7400 封装中的 4 个门电路编号 A、B、C、D，用户

直接从中选择需要的编号即可。 

 

图 2-33  与数字门电路有关的属性参数 

2.4.4  修改参数值的途径之三：打开新的对话框 

1．打开新对话框的方法 
如果要确定某一个属性参数在电路图中的显示模式，例如要修改电容 CLOAD 的 Value 在电路
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中的显示情况。在选中该属性参数值 5p 所在单元格后，按图 2-30 中 Display 按钮，屏幕上即出现    
图 2-34 所示对话框。该对话框用于设置在电路图中属性参数的显示格式（Display Format）、采用的

字体（Font）、颜色（Color）和放置方位（Rotation）。这种类型的对话框在多种情况下都会出现。 

 

图 2-34  Display Properties 对话框 

2．同时修改多个元素显示模式的方法 
如果图 2-30 中列出的每个元器件的 Value 参数值在电路图中均采用同一种显示模式，就无须对

每个元器件的 Value 分别设置，而只要用下述方法进行一次设置即可。 
用鼠标左键单击图 2-30 参数名标题栏中 Value 所在的单元格，使该列单元格全部被选中并呈反

白显示。按图中 Display 按钮，屏幕上将出现类似图 2-34 所示对话框。该对话框与图 2-34 的唯一区

别是当前被选中的多个元器件值各不相同，“Value：”的右侧为空白，未给出具体数值。该对话框中

的设置结果适用于被选中的每一个元器件。 
说明：如果要修改只是电路图中元器件的编号或者元器件值等单项参数，只要在电路图中用鼠

标双击该参数后，屏幕上也将出现与图 3-34 类似的对话框，供用户修改相应参数值以及其显示方式。 

2.5  电路图在屏幕上的显示 

在绘制和修改电路图的过程中，往往需要改变屏幕上电路图的显示情况，包括：放大或缩小显

示、显示特定区域、将光标移至特定位置，以及确定是否同时显示坐标网格点和图幅分区等。 

2.5.1  电路图显示倍率的调整（Zooming） 

在 Capture 中，可以按多种不同要求调整电路图的显示倍率。选择 View→Zoom 子命令，屏幕

上将出现图 2-35 所示子命令菜单，供用户确定如何选用倍率在屏幕上显示电路图。 

1. 按内定的倍率放大或缩小显示电路图 
选择执行图 2-35 中 In 子命令，将按固定的倍率放大显示电路图。若选择执行图 2-35 中 Out 子

命令，则效果相反，表示以固定的倍率缩小显示电路图。 
在 Capture 运行环境配置中，Pan and Zoom 标签页中 Zoom Factor（参见图 2-45）的设置值决定

了上述放大/缩小显示时采用的倍率。内定设置值为 2。 

2. 按用户确定的倍率显示电路图 
在图 2-35 中选择执行 Scale 子命令，屏幕上将弹出图 2-36 所示放大倍率设置框。除可以从图中
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提供的 25%，…，400%共 6 种倍率中选用一种外，也可以在选中 Custom 后，在其右侧文本框中键

入用户希望采用的倍率。 

 

图 2-35  View→Zoom 子命令菜单                       图 2-36  Zoom Scale 设置框 

3. 显示特定范围的电路图 
如果要显示观察电路图中局部范围的细节，可按下述方法将该范围电路图放大显示。 
选择执行图 2-35 中 Area 子命令，光标将变成一个中间带十字符号的放大镜。将光标移至待放

大显示区域的某处，按下鼠标左键并拖动，屏幕上就会出现一个以按下鼠标左键时的位置为起始顶

点和光标当前位置为对角顶点的矩形框线。松开鼠标左键，系统将自动调节放大倍率，在全屏范围

内显示出矩形框线内的那部分电路图。这时光标仍为放大镜形状，表示用户还可以继续选择放大某

一范围内的电路图。按 Esc 键或执行快捷菜单中的 End Mode 命令，将结束 Area 子命令，光标恢复

为常规箭头形状。 

4. 显示全部电路图 
若在图 2-35 中选择执行 All 子命令，系统将自动调整缩放倍率，使整页电路图在全屏幕范围内

显示。 

5. 显示选中的电路元素 
在电路图中选中部分电路元素后，再选择执行图 2-35 中 Selection 子命令，就可以在不改变显示

倍率的情况下，使被选中的电路元素显示在屏幕中央。如果在当前倍率下，被选中的元素中有一部

分超出了屏幕范围，系统就会自动调整缩放倍率，使选中的电路元素全部显示出来。 

6. 屏幕显示的刷新 
多次执行图 2-35 中各条子命令改变屏幕显示倍率后，屏幕上可能出现局部位置电路图显示混乱

的问题。选择执行图 2-35 中 Redraw 子命令刷新屏幕显示，可使混乱现象消失。 

2.5.2  坐标网格点和图幅分区的控制 

1. 坐标网格点（Grid）和图幅分区（Grid Reference） 
图 2-37 是屏幕上电路图绘制区示意图。 
由图可见，为了便于确定电路组成元素在图纸上的位置，Capture 中提供了两种方法。 
① 坐标网格点：相当于常规的 X-Y 坐标系统，对应于坐标网格点的间距。光标所在位置的坐

标值显示在窗口底部状态栏的右侧部分。 
② 图幅分区：有时使用坐标刻度显得划分过细。为了表示在图纸上的大概位置范围，可将图纸

的 X 和 Y 方向分别分为几个区间，用数字和/或字母进行编号，称之为图幅分区。图 2-37 中将 X 和

Y 方向分为 4 个区间，X 方向用数字表示分区编号，而 Y 方向则用字母表示分区编号。 
坐标网格点的坐标原点位于图纸的左上角位置，而图幅分区编号的起点则可由用户控制。图 2-37

中图幅分区编号起点选在图纸的右下角。 
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图 2-37  坐标网格点和图幅分区 

2. 坐标网格点的控制 
用户可以从下述 4 个方面控制网格点的使用。 
① 网格点的显示控制：选择执行 View→Grid 子命令，可以使坐标网格点在显示与不显示之间

变化。 
② 网格点形状的控制：进行 Capture 运行环境设置时，Grid Display 标签页（见图 2-44）中 Grid 

Style 栏的设置决定了网格点是用网点（选用 Dots）还是用线条（选用 Lines）表示。 
③ 绘图过程中光标运动模式的控制：若在图 2-44 中使 Pointer snap to grid 处于选中状态，则光

标在电路图中选定的位置以及绘制的互连线、元器件端线等均只能终止在坐标网格点上，这样可以

保证元器件与互连线之间真正实现电连接。 
④ 坐标单位的选用：进行 Schematic Page 属性设置时，Page Size 标签页（见图 2-47）中选用

的尺寸单位也同时作为坐标的单位。无论采用英寸或毫米为单位，网格点之间的间距总是 0.1 英寸

（2.54mm）。 

3. 图幅分区的控制 
图幅分区的控制取决于 Options→Design Template 运行环境设置对话框中 Grid Reference 标签页

的参数设置，详细内容将在 2.6 节介绍（参见图 2-48）。 

2.5.3  电路图特定位置的显示 

如果电路图幅面较大，在屏幕上只能显示其中一部分，可选择执行 View→Go To 子命令，指定

将哪一部分电路图显示在屏幕上。 

1. 显示指定坐标位置的电路图 
选择执行 View→Go To 子命令后，屏幕上将出现图 2-38 所示的 Go To 对话框，图中显示的是

Location 标签页。 
在 X 和 Y 文本框中分别键入坐标值。若选中 Absolute 选项，光标将移到 X、Y 设置值所确定的

位置并将该处显示在屏幕窗口中央；若选中 Relative 选项，则以当前光标所在位置为参考点，光标

移动由 X、Y 设置值规定的距离并将该处显示在屏幕窗口中央。光标所在位置的坐标值显示在屏幕

底部状态栏右侧。 
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2. 显示由图幅分区指定的电路图 
Go To 对话框中 Grid Reference 标签的标签页如图 2-39 所示。 
根据当前电路图中图幅分区的情况，图 2-39 中 Horizontal 和 Vertical 右侧下拉式列表中分别列

有水平和垂直方向图幅分区编号。从中选定需要的编号后，按 OK 按钮，光标即指向选定的图幅分

区范围的中央位置并将该分区显示于屏幕窗口中央。 

             

图 2-38  Go To 对话框（Location）             图 2-39  Go To 对话框（Grid Reference） 

3. 显示指定书签位置的电路图 
单击 Go To 对话框中的 Bookmark 标签，相应的标签页如图 2-40 所示。 
图中 Name 右侧下拉式列表中列出了当前电路图中已放置的所有书签名。从中选定需要的书签

名后按 OK 按钮，光标即指向电路图中该书签所在的位置，并使该书签显示在屏幕窗口的中心。 

 

图 2-40  Go To 对话框（Bookmark） 

2.6  Page Editor 运行环境配置 

与其他应用软件类似，为了适应不同应用需求，OrCAD/Capture 软件提供有运行环境配置功能。

按照其作用范围的不同，OrCAD/Capture 软件中的运行环境配置分为三个层次。第一层次是 Capture
软件运行环境的配置，配置结果对 Capture 软件中各个模块均起作用；第二层次是 Design（电路设

计）的环境配置，只对新开始的电路设计起作用；第三层次是对 Page 的环境配置，其配置的参数只

影响当前绘制的这一页电路图。这三个层次的设置是通过 Page Editor 窗口中 Options 主命令菜单的

不同子命令来完成的。本节在简要介绍环境参数含义的基础上，重点说明其中与电路模拟仿真密切

相关的环境参数含义及配置方法。 
为了满足一般用户的需求，每个环境参数都有默认设置。对于开始应用 Capture 的用户，采用

默认设置就能够满足其绘制电路图的基本要求。如果设置不当，可能对模拟仿真的顺利进行产生不

良影响。 

2.6.1  Capture 运行环境配置 

在 Page Editor 窗口选择执行 Options→Preferences 子命令，屏幕上将出现 Capture 运行环境配置
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对话框，包含有 7 个标签页，用于设置不同类型的运行环境参数。 

1.  Colors/Print 设置 
图 2-41 显示的是 Colors/Print 标签页内容。该标签页用于设置电路图中 38 种不同电路组成元素

在屏幕上显示的色彩，以及在输出打印时是否要打印在电路图纸上。 
Capture 软件已为各种电路组成元素设置了默认色彩。用户若要改变某个元素的色彩，只需单击

该元素名色彩框，然后，从屏幕上出现的色彩设置框中选取一种颜色并按“确定”按钮即可。屏幕

上出现的色彩设置框中有 48 种色彩可供选择，而且用户可以根据需要进行色彩的自定义。 
若元素色彩框左边的复选框处于选中状态，打印或用绘图仪输出电路图时，该电路组成元素将

被打印输出，否则该元素将不打印输出。单击复选框可改变其选中状态。 
说明：① 不管元素色彩框左侧的复选框是否处于选中状态，在屏幕上显示的电路图中总包括该

元素。 
② 图纸的边框线以及图幅分区（Grid References）采用图 2-41 中为 Title Block（图纸标题栏框

线）设置的色彩。 
③ 修改了一些参数的设置后，若改变想法，可按右下角的 Use Defaults 键，恢复使用默认设置。 

 

图 2-41  Capture 运行环境配置 1（Colors/Print） 

2．Miscellaneous 设置 
Miscellaneous 标签页如图 2-42 所示，该标签页中分 11 栏用于设置不同类型参数。 
① Schematic Page Editor：本栏中有 5 项参数。 
前四项参数分别用于设置在电路图绘制窗口中采用 Place 主命令菜单的有关命令绘制直线、椭

圆、矩形、多边形等符号时相关的填充方式（Fill Style）、线条的式样（Line Style）、线条的宽窄（Line 
Width）以及采用的颜色（Color）。 
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图 2-42  Capture 运行环境设置 2（Miscellaneous） 

第五个参数 Junction Dot Size 用于确定执行 Place→Junction 子命令绘制交叉节点符号时 Junction
符号的大小，包括有 Small、Medium、Large、Very Large 共 4 个选项供选用。 

② Part and Symbol Editor：本栏中三个参数只对 Part Editor 元器件符号编辑窗口中绘制的直线、

矩形、椭圆等起作用。三个参数的含义与上述①中的同名参数相同。 
③ Session Log：本项参数设置了 Session Log 窗口中显示的内容采用什么字体。本项参数设置

与电路图的绘制无关。 
④ Docking：若勾选 Docking Place Part 复选框，则在绘制电路图过程中执行 Place Part 命令绘

制元器件时，屏幕上将弹出图 2-16（a）所示 Place Part 对话框，否则将显示出图 2-16（b）所示 Place 
Part 对话框。 

说明：修改本项选中状态后需要重新启动 Capture 才能使设置生效。 
⑤ Find：若勾选 Search Toolbar 复选框，则在执行 Edit→Find 命令时，屏幕上工具栏中将弹出

对应的工具按钮，如图 2-43（a）所示，否则显示出如图 2-43（b）所示对话框。 

 
（a） 

 
（b） 

图 2-43  搜索（Search）工具栏 
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⑥ Text Rendering：若勾选 Render TrueType fonts with strokes，则电路图中的字符用笔划（折线）

表示，而不采用 TrueType 字体。这样可以提高打印输出的速度，但不及使用 TrueType 字体美观。

一般在打印草图时选中本参数。正式打印输出电路图时应采用 TrueType 字体。 
在选中上述参数设置后，对折线表示的字符是保持空心字符状态还是要将字符填实，取决于 Text 

Rendering 一栏中 Fill text 是否处于选中状态。 
⑦ Auto Recovery：若使本栏中 Enable Auto Recovery 处于选中状态，则系统自动将当前设计涉

及的文件、数据库等信息存入/Windows/Temp 路径下的 FILES.ASL 文件中。存放的间隔时间由本栏

中 Update every（  ）minutes 的设置值确定。该时间参数的允许设置范围为 1 分钟到 12 小时。若使

用中出现断电等意外情况，系统再次启动时将根据 FILES.ASL 中保存的信息恢复原有的设计。 
在正常退出 Capture 时，FILES.ASL 文件将被自动删除。 
⑧ Auto Reference：若使本栏中 Automatically reference placed parts 处于选中状态，则在电路中

放置元器件符号时，系统自动顺序编号。例如若电路中已有 4 个电压源符号，在电路图中再放置一

个 VCD 时，其编号自动取为 V5；否则放置在电路图中的每个元器件均在其编号关键词后加个问号，

例如放置的电压源符号，其编号均为 V？，电阻符号均为 R？等。这时就需按照 2.4 节介绍的元器

件属性参数修改方法逐个修改每个元器件的编号。 
说明：在勾选了 Automatically reference placed parts 的情况下，还可以确定是否勾选适用于 PCB

设计的 Design Level 选项。 
若使 Preserve reference on copy 处于勾选状态，则 copy（复制）一个元器件时，新复制生成的元

器件的编号将与被复制的元器件相同。 
说明：本栏包括的两项设置最多只能有一项被勾选。 
提示：如果要对绘制的电路图进行模拟仿真，为了保证电路图中不会出现元器件编号相同的情

况，应该勾选 Automatically reference placed parts。 
⑨ Intertool Communication：若勾选 Enable Intertool Communication，则绘制的电路图可以与

OrCAD 其他软件模块（如 PCB）之间交流数据。 
⑩ Wire Drag：若勾选 Allow component move with connectivity changes，则允许无条件的移动元

器件或者互连线，即使移动的结果会导致连接关系的改变。 
⑪ IREF Display Property：若勾选 Global Visibility，则显示 IREF（intersheet references：不同图

纸之间连接符）。 

3. Grid Display 设置 
Grid Display标签页如图2-44所示，该标签页用于设置与坐标网格点有关的参数。其中，Schematic 

Page Grid 栏中的设置只影响电路图的绘制；Part and Symbol Grid 栏中的设置只对 Part 窗口中编辑的

电路元素符号图形起作用。下面说明 Schematic Page Grid 栏中 4 组参数的含义。Part and Symbol Grid
栏中三组参数的含义与其相同。 

① Visible: 若勾选 Displayed，则屏幕上将显示坐标网格点。View 主命令菜单中 Grid 子命令的

作用与此相同。 
② Grid Style：此栏用于确定坐标网格是采用点状（若选中 Dots）还是直线（若选中 Lines）。 
③ Grid spacing：此栏用于确定坐标网格点之间的间距是引脚到引脚之间间距的几分之一。按

照图 2-44 的设置，坐标网格点之间的间距是引脚到引脚之间间距的二分之一。 
如果没有特别需求，通常将坐标网格点之间的间距设置为等于引脚到引脚之间的间距。 
④ 第四组参数的设置用于确定绘制电路图过程中光标点的移动模式。 
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图 2-44  Capture 运行环境配置 3（Grid Display） 

其中 Connectivity Elements 的设置只影响互连线的绘制，Drawing Elements 的设置只影响电路元

器件等电路元素的绘制。如果设置为 Coarse，则不管 Pointer snap to grid 是否被选择，光标只能在坐

标网格点上移动。同样，如果设置为 Fine，则不管 Pointer snap to grid 是否被选择，光标均可以在坐

标网格点之间移动。 
只有在Connectivity Elements和/或Drawing Elements设置为Master的情况下，Pointer snap to grid

是否处于选中状态才会影响到光标的移动模式。若 Pointer snap to grid 处于选中状态，则光标只能在

坐标网格点上移动，放置在电路图中的元器件引出端将只能终止在坐标网格点上。否则光标就可以

在坐标网格点之间移动。 
说明：如果 Pointer snap to grid 选项未处于勾选状态，则工具栏中的 按钮将显示为红色，起警

示作用。单击该按钮可以使红色消失，相当于使 Pointer snap to grid 选项处于选中状态。 
提示：为了适应不同情况的需求，建议将 Connectivity Elements 以及 Drawing Elements 两项设置

为 Master，使 Pointer snap to grid 选项处于勾选状态。 
按照上述设置，在绘制互连线时，就可以保证互连线端头与元器件引线的端头准确对接，真正

实现电连接。 
在编辑修改电路图时，如果需要微调元器件编号、元器件值等元素在电路图中的位置，可以单

击工具栏中的 按钮，使得其呈现为红色，相当于取消 Pointer snap to grid 选项的选中状态，就允许

光标点可以在网格点之间移动，实现位置的微调。  

4．Text Editor 设置 
Preferences 设置对话框中的 Text Editor 标签页用于设置以 VHDL 文件作为电路图输入描述时的

有关参数设置。 
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Text Editor 标签页的设置与 PSpice 软件模块的运行无关。 

5．Pan and Zoom 设置 
Preferences 设置对话框中的 Pan and Zoom 标签页如图 2-45 所示，该标签页用于设置缩放显示电

路图时的倍率变化值，以及电路图在窗口中滚动显示时的移动幅度的大小。可以分别设置 Page Editor
（电路图绘制窗口）和 Part Editor（元器件符号编辑窗口）中的这两个参数。 

① Zoom 倍率设置：执行 View→Zoom 子命令下的 In 和 Out 命令可以将电路图放大和缩小处理

后重新显示。每次放大、缩小的倍率由图 2-45 中的 Zoom Factor 设置值确定。内定设置值为 2 倍。 
② Pan 幅度设置：有时电路图纸幅面较大，在绘图窗口中不能完整显示。为此 Capture 软件提

供了自动翻滚功能（Auto Pan），即在进行选取电路图单元或移动电路元器件符号等需要移动光标的

操作时，若光标移至窗口边界时还要继续向窗口边界外的电路图位置移动，电路图将自动翻滚，使

窗口以外的部分显示在窗口中。每次翻滚的幅度由图 2-45 中 Auto Scroll Percent 设置值确定。内定

设置为 5，表示每次自动翻滚该方向上整个图幅的 5％。 

6. Board Simulation 设置 
Preferences设置对话框中的Board Simulation标签页用来选择对 PCB设计进行模拟仿真的工具，

用户可以选择用 Verilog 或 VHDL。 
Board Simulation 标签页的设置与 PSpice 软件模块的运行无关。 

 

图 2-45  Capture 运行环境配置 5（Pan and Zoom） 

7. Select 设置 
Preferences 设置对话框中的 Select 标签页如图 2-46 所示，该标签页用于设置 Page Editor（电路

图绘制窗口）和 Part Editor（元器件符号编辑窗口）中的两个参数。 
① 选中判据的设置：在绘制电路图过程中，经常需要用一个矩形框线选取电路图的一部分组成

元素。图 2-46 中 Area Select 栏的两个参数用于确定电路组成元素被选中的判据。若选择 Intersecting，
表明在框线包围之内或与框线相交的元素均算选中；若选择 Fully Enclosed 则表明必须是全部包围在
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框线之内的元素才算被选中。 

 

图 2-46  Capture 运行环境配置 7 （Select） 

② 移动过程中是否显示元器件符号外形：一般情况下，在移动电路组成元素的同时动态显示这

些元素的外形。如果同时移动多个元素，则动态显示多个元素外形将涉及处理大量数据并会影响运

行速度。图 2-46 中 Maximum number of objects to display at high resolution while dragging 一项用于设

置在移动过程中最多显示多少个元素外形。若同时移动的元素数超过这一设置值，则不动态显示移

动元素的外形。 

2.6.2  新设计项目的 Design 环境设置 

在 Options 命令菜单中选择执行 Design Template 后，屏幕上即出现 Design 环境设置框，其中，

共有 6 个标签页设置 Design 的环境参数。设置结果将影响新建设计项目的整个设计过程。 

1. Fonts 设置 
Design Template 设置框中的 Fonts 标签页，用于设置与电路图中不同元素相关的字符采用的字

体、字体样式、字号大小等参数。 

2. Title Block 设置 
Design Template 设置框中的 Title Block 标签用于设置电路设计中采用的图纸标题栏图形，以及

在标题栏中需填写的内容。 

3. Page Size 设置 
Design Template 设置框中的 Page Size 标签如图 2-47 所示，其包含三组参数设置。 
① Units：用于选定尺寸的单位是英寸还是毫米。 
② New Page Size：设置 6 种不同幅面的电路图图纸的长宽尺寸。 
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图 2-47  Design 环境设置 3（Page Size） 

若以英寸为单位，不同幅面的电路图纸代号为 A、B、C、D、E，以及用户自定义（Customs）； 
若以毫米为单位，则图纸幅面代号相应为 A4、A3、A2、A1、A0，以及 Customs。 
③ 图中 Pin-to-Pin Spacing 用于设置器件引线间的最小间距，对应于电路图上网格点之间的   

间距。 

4. Grid Reference 设置 
Grid Reference 的含义是图幅分区，指在图纸的 X 和 Y 方向划分几个区，分别用字母和数字作

为每个区的代号。图纸中各个位置可以用其所在的字母数字分区号表示，有助于确定电路元素在电

路图中的位置。 
Design Template 设置框中的 Grid Reference 标签页（见图 2-48）用于确定与图幅分区有关的参

数，包括有 6 组参数设置。 

 

图 2-48  Design 环境设置 4（Grid Reference） 
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① Horizontal：该栏内包括 4 项参数选项，用来设置水平方向图幅分区的划分方式。 
Count：设置水平方向的分区数。 
Alphabetic（字母）和 Numeric（数字）两个选项中只能有一项处于选中状态，用于确定分区编

号采用字母还是数字。 
Ascending（增大）和 Descending（减小）两个选项中只能有一项处于选中状态，用于确定从图

纸左上角起向右，分区的编号是增大还是减小。 
Width：设置分区编号框线的宽度。 
② Vertical：该栏内的 4 项参数选项，用来设置垂直方向图幅分区的划分方式，每项参数的含

义和设置要求与 Horizontal 中相同，只是其分区编号增大或减小的方向是从图纸左上角起向下。 
③ Border（图纸边框线）Visible、Title Block（标题栏）Visible 和 Grid Reference（图幅分区）

Visible 这三栏分别用于确定图纸边框线、标题栏和图幅分区这三项内容是否在屏幕上显示

（Displayed），以及是否打印在输出的电路图上（Printed）。 
④ ANSI grid references：确定是否采用美国标准化协会关于图幅分区的划分规定。 

5. Hierarchy 设置和 SDT Compatibility 设置 
在 Design Template 设置框中，Hierarchy 标签页中的参数是针对分层式电路设计的设置。SDT 

Compatibility 标签页中的参数则涉及与老版本电路设计之间的参数兼容性设置。 

2.6.3  当前 Design 环境设置的修改 

按 2.6.2 节方法设置的 Design 环境参数只对新的设计起作用。对一个已有的设计项目，要修改

其中部分环境参数设置的方法之一，是在设计管理窗口中选中一个设计文件名再执行 Options→
Design Properties 命令，屏幕上出现图 2-49 所示设置框，其中包含 4 个标签页。 

提示：在设计管理窗口中选中一个设计文件名后，用户才能够在 Options 下拉菜单中选择执行

Design Properties 子命令，用于修改处于选中状态的设计的运行环境状态参数。 
在图 2-49 所示设置框中 Fonts、Hierarchy 和 SDT Compatibility 这三个标签页的形式、设置内容

与 2.6.2 节中相应的标签页相同。修改后的环境参数对当前电路设计均起作用。 

 

图 2-49  设计管理窗口中的 Design 环境设置 
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图 2-49 中 Miscellaneous 标签页列出了当前电路设计的有关信息，包括设计项目的名称、路径

名、设计项目的建立时间和最近一次修改时间。若勾选Display Invisible Power Pins （for documentation 
purposes only），则在电路图中将显示出接电源的引出端。 

2.6.4  当前 Page Editor 环境设置的修改 

在电路设计中新增一页电路图纸时，新增的图纸自动采用原来的 Design 环境设置结果。对于一

页已有的电路图，修改其中部分环境参数设置的方法是在电路图绘制窗口中执行 Options→Schematic 
Page Properties 命令，然后在屏幕上出现的电路图纸属性设置框（见图 2-50）中修改设置。修改的结

果对当前这一页电路图起作用。 
提示：在 Page Editor 窗口处于选中状态时，用户才能够在 Options 下拉菜单中选择执行 Schematic 

Page Properties 子命令，用于修改当前 Page Editor 窗口中绘制的电路图页面的运行环境状态参数。 
图 2-50 中的 Page Size 标签页和 Grid Reference 标签页与 2.6.2 节介绍的 Design 环境设置中两个

同名标签页（见图 2-47 和图 2-48）基本相同，其中各项参数的含义与设置方法也一样。它们之间的

区别只在于适用对象不同。图 2-47 和图 2-48 中的设置只对一个新建的设计起作用。而图 2-50 中这

两个标签页的设置只影响当前已有的电路图纸页面上的内容。 
图 2-50 中 Miscellaneous 标签页列出了当前图纸页的有关信息，包括该页图纸在整个电路设计

中的编号以及该页电路图的绘制时间和最近一次修改时间。 

 

图 2-50  Schematic Page Properties 设置 

2.6.5  自动备份参数设置 

在 Page Editor 窗口选择执行 Options→Autobackup 命令，屏幕上出现图 2-51 所示设置框，设置

与文件备份相关的参数。 
① Backup time (in Minutes)：确定自动备份的时间间隔，以分钟为单位。 
② No of backups to keep：确定存储的备份文件的份数。 
③ Directory for backups：指定存放备份文件的目录名称。 
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图 2-51  自动备份参数设置 
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